Subject: Re: [Bier] Renaming draft-bier-lsr-ethernet-extensions to draft-bier-lsr-non-mpls-extensions?

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 2 Mar 2022 19:18:05 +0000

Hi,

After offline communication, we learned that current editors can no longer focus on this work, so I took over the pen and submitted draft-ietf-bier-lsr-bier-non-mpls-extensions-00.
I will present the changes in the coming IETF113 and hopefully we can move to WGLC.

Thanks!
Jeffrey

Juniper Business Use Only
From: Jeffrey (Zhaohui) Zhang <[email-masked]>
Sent: Tuesday, February 8, 2022 9:12 AM
To: Xiejingrong (Jingrong) <[email-masked]>; Tony Przygienda <[email-masked]>; draft-ietf-bier-lsr-ethernet-extensions <[email-masked]>; BIER WG <[email-masked]>; [email-masked]; [email-masked]
Subject: Renaming draft-bier-lsr-ethernet-extensions to draft-bier-lsr-non-mpls-extensions?

Hi Jingrong, Gang, Senthil,

Thanks for refreshing it. Now that most our Chinese friends are back after the spring festival holidays, I want to bring back this discussion from more than two years ago and move forward.

Here is the history:

  1.  The draft was initially draft-dhanaraj-bier-isis-non-mpls-extensions, but it explicitly states that non-ethernet encap is outside the scope
  2.  As a result, I suggested to replace "non-mpls" with ethernet - it became draft-dhanaraj-bier-lsr-ethernet-extensions in Jan 2019
  3.  In April 2019 I raised the question among the co-authors if we should remove the "ethernet-only" restriction and go back to "non-mpls"
  4.  There were on-and-off discussions among co-authors and the latest email that I can found was on 11/30/2020, arguing *for* changing back to non-mpls
  5.  After that the draft has been stalled. There were a few nudges offline to the editors but nothing happened other than refreshing

I think we should rename it and move forward now - after two years. The co-authors were on those old discussions so should all have the context - can the editors respond here if we should rename?

If you have concerns about going back to non-mpls, please discuss it here.

Thanks.

Jeffrey

Juniper Business Use Only
From: Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, January 31, 2022 12:35 AM
To: Tony Przygienda <[email-masked]<mailto:[email-masked]>>; draft-ietf-bier-lsr-ethernet-extensions <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: Last call to authors of draft-bier-lsr-ethernet-extensions for update of draft ...

[External Email. Be cautious of content]

Hi,

I have just re-published the draft.
The submission needs xml v3 format and the previous version of the draft is old, so a text file has to be used as the base. Hope the authors could update it soon after the spring festival to use xml to reflect the latest references.

thx.
jingrong.

From:Tony Przygienda <[email-masked]<mailto:[email-masked]>>
To:draft-ietf-bier-lsr-ethernet-extensions <[email-masked]<mailto:[email-masked]>>;BIER WG <[email-masked]<mailto:[email-masked]>>
Date:2022-01-20 05:03:24
Subject:Last call to authors of draft-bier-lsr-ethernet-extensions for update of draft ...

Authors of the above draft, we need IANA assignments and registries contained in draft-bier-lsr-ethernet-extensions to progress further WG drafts here. The authors have been given couple of heads up behind the scenes to re-publish the according draft given it expired 6 months ago.

As WG chair I would request with this email for an update/re-publish so I can call the IANA assignments. If we don't see a re-publish within the next 2 weeks we will consider to call/assign an editor to the draft to keep it alive.

thanks

-- tony

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 2 Mar 2022 20:58:02 +0100

Jeffrey, thanks for taking up the pen

-- tony

On Wed, Mar 2, 2022 at 8:18 PM Jeffrey (Zhaohui) Zhang <[email-masked]>
wrote:

> Hi,
>
>
>
> After offline communication, we learned that current editors can no longer
> focus on this work, so I took over the pen and submitted
> draft-ietf-bier-lsr-bier-non-mpls-extensions-00.
>
> *From:* Jeffrey (Zhaohui) Zhang <[email-masked]>
> *Sent:* Tuesday, February 8, 2022 9:12 AM
> *To:* Xiejingrong (Jingrong) <[email-masked]>; Tony Przygienda <
> [email-masked]>; draft-ietf-bier-lsr-ethernet-extensions <
> [email-masked]>; BIER WG <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* Renaming draft-bier-lsr-ethernet-extensions to
> draft-bier-lsr-non-mpls-extensions?
>
>
>
> Thanks for refreshing it. Now that most our Chinese friends are back after
> the spring festival holidays, I want to bring back this discussion from
> more than two years ago and move forward.
>
>
>
> Here is the history:
>
>
>
>    1. The draft was initially draft-dhanaraj-bier-isis-non-mpls-extensions,
>    but it explicitly states that non-ethernet encap is outside the scope
>    2. As a result, I suggested to replace “non-mpls” with ethernet – it
>    became draft-dhanaraj-bier-lsr-ethernet-extensions in Jan 2019
>    3. In April 2019 I raised the question among the co-authors if we
>    should remove the “ethernet-only” restriction and go back to “non-mpls”
>    4. There were on-and-off discussions among co-authors and the latest
>    email that I can found was on 11/30/2020, arguing **for** changing
>    back to non-mpls
>    5. After that the draft has been stalled. There were a few nudges
>    offline to the editors but nothing happened other than refreshing
>
>
>
> I think we should rename it and move forward now – after two years. The
> co-authors were on those old discussions so should all have the context –
> can the editors respond here if we should rename?
>
>
>
> *From:* Xiejingrong (Jingrong) <[email-masked]>
> *Sent:* Monday, January 31, 2022 12:35 AM
> *To:* Tony Przygienda <[email-masked]>;
> draft-ietf-bier-lsr-ethernet-extensions <
> [email-masked]>; BIER WG <[email-masked]>
> *Subject:* RE: Last call to authors of draft-bier-lsr-ethernet-extensions
> for update of draft ...
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> Hi,
>
>
>
> The submission needs xml v3 format and the previous version of the draft
> is old, so a text file has to be used as the base. Hope the authors could
> update it soon after the spring festival to use xml to reflect the latest
> references.
>
>
>
> thx.
>
> jingrong.
>
>
>
>
>
> *From:*Tony Przygienda <[email-masked]>
>
> *To:*draft-ietf-bier-lsr-ethernet-extensions <
> [email-masked]>;BIER WG <[email-masked]>
>
> *Date:*2022-01-20 05:03:24
>
> *Subject:*Last call to authors of draft-bier-lsr-ethernet-extensions for
> update of draft ...
>
>
>
> Authors of the above draft, we need IANA assignments and registries
> contained in draft-bier-lsr-ethernet-extensions to progress further WG
> drafts here. The authors have been given couple of heads up behind the
> scenes to re-publish the according draft given it expired 6 months ago.
>
>
>
> As WG chair I would request with this email for an update/re-publish so I
> can call the IANA assignments. If we don't see a re-publish within the next
> 2 weeks we will consider to call/assign an editor to the draft to keep it
> alive.
>
>
>
> thanks
>
>
>
> -- tony
>
>
>