Subject: [Bimi] Guide to BIMI

From: Jakub Olexa <[email-masked]>
Date: Wed, 26 Aug 2020 17:31:50 +0200

Hi all,

we have published a guide on how to create a "proper" SVG for BIMI using
Adobe Illustrator. The guide is available at
https://www.mailkit.com/resources/blog/ultimate-guide-bimi

We have also updated the BIMI validator
(https://www.mailkit.com/resources/bimi-inspector
<https://www.mailkit.com/resources/bimi-inspector>) today to provide
more detailed responses related to common issues - mostly related to
differences in SVG Tiny 1.2 and SVG Tiny P/S. New messages are:

- SVG contains global coordinate attributes - you will see this message
if your SVG contains an X/Y attribute of the SVG element
- SVG document title is not present - SVG Tiny P/S requires every
document to contain a title element to help with accessibility
- SVG has overflow set - the unsupported overflow attribute exists in
your SVG file
- SVG has incorrect baseProfile - the SVG baseProfile is not set to
"tiny-ps"

-- 

Jakub Olexa
Founder & CEO
E-mail: [email-masked] <mailto:[email-masked]>
Tel: +420 777 744 440 <tel:+420777744440>

Mailkit - Closing the circle between Deliverability and Engagement
<https://www.mailkit.com>

---

From: "Brotman, Alex" <[email-masked]>
Date: Fri, 28 Aug 2020 13:05:20 +0000

Jakub,

Overall, a good guide, and good intro to BIMI and some of the particulars of getting it functional.   If a participant does not have a PEM available (seems by the text it may not be required everywhere), how should the DNS record be constructed?  It might be a good way for a domain holder to get some introductory experience with BIMI.

Also, I saw in the blog post you're working on your validator, however didn't mention if it is ready for beta/production use at this point.

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

> -----Original Message-----
> From: bimi <[email-masked]> On Behalf Of Jakub Olexa
> Sent: Wednesday, August 26, 2020 11:32 AM
> To: [email-masked]
> Subject: [Bimi] Guide to BIMI
>
> Hi all,
>
> https://urldefense.com/v3/__https://www.mailkit.com/resources/blog/ulti
> mate-guide-
> bimi__;!!CQl3mcHX2A!USxQoaxjx22EBZwnV8FF8OHg4V368B5KAPxhQeVuYo
> YbljUijZakkVhFLvkJVgf0sw25sg8$
>
> (https://urldefense.com/v3/__https://www.mailkit.com/resources/bimi-
> inspector__;!!CQl3mcHX2A!USxQoaxjx22EBZwnV8FF8OHg4V368B5KAPxhQe
> VuYoYbljUijZakkVhFLvkJVgf0yPXKQRw$
> <https://urldefense.com/v3/__https://www.mailkit.com/resources/bimi-
> inspector__;!!CQl3mcHX2A!USxQoaxjx22EBZwnV8FF8OHg4V368B5KAPxhQe
> VuYoYbljUijZakkVhFLvkJVgf0yPXKQRw$ >) today to provide more detailed
> responses related to common issues - mostly related to differences in SVG
> Tiny 1.2 and SVG Tiny P/S. New messages are:
>
> - SVG contains global coordinate attributes - you will see this message if your
> SVG contains an X/Y attribute of the SVG element
> - SVG document title is not present - SVG Tiny P/S requires every document
> to contain a title element to help with accessibility
> - SVG has overflow set - the unsupported overflow attribute exists in your
> SVG file
> - SVG has incorrect baseProfile - the SVG baseProfile is not set to "tiny-ps"
>
> --
>
> Jakub Olexa
> Founder & CEO
> <https://urldefense.com/v3/__https://www.mailkit.com__;!!CQl3mcHX2A!
> USxQoaxjx22EBZwnV8FF8OHg4V368B5KAPxhQeVuYoYbljUijZakkVhFLvkJVgf
> 0gpxgCq8$ >
>
> --
> bimi mailing list
> [email-masked]
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bimi__
> ;!!CQl3mcHX2A!USxQoaxjx22EBZwnV8FF8OHg4V368B5KAPxhQeVuYoYbljUij
> ZakkVhFLvkJVgf0N4v5hj4$

---

From: Jakub Olexa <[email-masked]>
Date: Fri, 28 Aug 2020 15:50:28 +0200

Alex,

thanks for the notes. I have extended the part about VMCs to provide
more information regarding BIMI records without certificate. We will be
publishing a separate articale on VMCs soon as we receive a lot of
questions about this topic.

Our validator is linked in the article and has been running as a beta
for almost a year now (and it will be beta until all parts of BIMI are
standardized). It is production ready and we offer an API to interested
parties to make direct queries. It's not setup for batch validation yet
though so we ask those using our validator not to flood it with hundreds
of requests at once.

Jakub Olexa
Founder & CEO