Subject: [Bimi] Updated Documents

From: "Brotman, Alex" <[email-masked]>
Date: Wed, 12 Aug 2020 21:16:15 +0000

As folks may have noticed, we've updated many of the documents relating to BIMI.  We've updated the main BIMI document[1], the Receiver's Guidance[2], and introduced an SVG format document[3].  Within the SVG document is an RNC that can be used to assist with SVG document validation.  There is also a document relating VMCs that has been updated as well.

We'd like to continue to work on these with the community, and continue to incorporate feedback.  Also note a group blog post[4] that has similar information.

1: https://www.ietf.org/id/draft-blank-ietf-bimi-01.txt
2: https://www.ietf.org/id/draft-brotman-ietf-bimi-guidance-02.txt
3: https://www.ietf.org/id/draft-svg-tiny-ps-abrotman-00.txt
4: https://bimigroup.org/new-bimi-documents-published/

Thank you to all of those involved for their work, and thank you for your feedback.

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

---

From: Mladen Baranek <[email-masked]>
Date: Tue, 18 Aug 2020 11:17:32 +0200

Hi Alex,

thank you for the update, we will go through drafts.

I would like to implement BIMI validator and enable my company Miadria
<http://miadria.com> and our platform UseWise.com to use BIMI,
we have SPF, DKIM, DMARC and BIMI records in DNS for Miadria but the logo
is not showing up in gmail or Yahoo mail.

What else must we do to get BIMI enabled?

Currently we are writing BIMI validator in nodejs to be included in
UseWise.com, if you are interested I will let you know when we are finished.

Best regards,

Mladen Baranek
*Chief Technical Officer*
<https://www.miadria.com>

*ADDRESS  *Zagreb, Croatia

*PHONE  *+38513090917

*MOBILE  *+385913010924

*EMAIL  [email-masked]

*WEB  *miadria.com <https://www.miadria.com>

On Wed, Aug 12, 2020 at 11:16 PM Brotman, Alex <[email-masked]>
wrote:

> As folks may have noticed, we've updated many of the documents relating to
> BIMI.  We've updated the main BIMI document[1], the Receiver's Guidance[2],
> and introduced an SVG format document[3].  Within the SVG document is an
> RNC that can be used to assist with SVG document validation.  There is also
> a document relating VMCs that has been updated as well.
>
> We'd like to continue to work on these with the community, and continue to
> incorporate feedback.  Also note a group blog post[4] that has similar
> information.
>
> bimi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bimi
>

-- 

*IZJAVA O ODRICANJU ODGOVORNOSTI*
Sadržaj ove poruke kao i svih 
priloženih datoteka povjerljiv je i namijenjen samo osobama ili subjektima 
koji su navedeni kao primatelji. Ukoliko ste ovu poruku primili greškom, 
molimo odmah obavijestite pošiljatelja, a poruku i sve njene privitke odmah 
uklonite s računala. Bilo kakvo objavljivanje, kopiranje ili distribucija 
svih ili pak samo dijela informacija koje su na bilo koji način sadržane u 
poruci trećim osobama zabranjeno je i može biti zakonski kažnjivo. Primite 
na znanje da su stavovi i mišljenja izneseni u poruci autorovi i ne 
predstavljaju nužno stavove i mišljenja Miadria d.o.o. U skladu s tim 
Miadria d.o.o. ne prihvaća nikakvu odgovornost za potencijalnu štetu 
nastalu primitkom ove poruke i privitaka sadržanih u poruci. 

*DISCLAIMER*
The contents of this email as well as any files attached to it 
are confidential and intended solely for individuals or entities which they 
are addressed to. If you have received this email message in error, please 
notify the sender immediately and permanently remove the message and all 
attached files from the computer. Any disclosure, copying or distribution 
of all or a part of information contained herein to or by third parties is 
prohibited and may be unlawful. Please note that any views or opinions 
presented in this message are solely those of the author and do not 
necessarily represent the views and opinions of Miadria d.o.o. Therefore 
Miadria d.o.o. accepts no liability for any potential damage caused by this 
message and files attached to it.

---

From: "Marc Bradshaw" <[email-masked]>
Date: Tue, 18 Aug 2020 21:57:18 +1000

Hi Mladen,

Our checking tool gives the following result for that domain.

An authenticated email with this record would receive the following BIMI results:
Authentication-Reults: authservid.example.com; bimi=fail (SVG did not validate)

So it looks like the SVG doesn't comply with the svg tiny ps profile.

On Tue, 18 Aug 2020, at 7:17 PM, Mladen Baranek wrote:
> I would like to implement BIMI validator and enable my company Miadria <http://miadria.com/> and our platform UseWise.com <http://usewise.com/> to use BIMI,
> we have SPF, DKIM, DMARC and BIMI records in DNS for Miadria but the logo is not showing up in gmail or Yahoo mail.  
> 
> Currently we are writing BIMI validator in nodejs to be included in UseWise.com, if you are interested I will let you know when we are finished.
> Best regards,

> *Chief Technical Officer*

 <https://www.miadria.com/>

> 
>  
> *WEB  *miadria.com <https://www.miadria.com/>

>  
> 
> 
> On Wed, Aug 12, 2020 at 11:16 PM Brotman, Alex <[email-masked]> wrote:
> Sadržaj ove poruke kao i svih priloženih datoteka povjerljiv je i namijenjen samo osobama ili subjektima koji su navedeni kao primatelji. Ukoliko ste ovu poruku primili greškom, molimo odmah obavijestite pošiljatelja, a poruku i sve njene privitke odmah uklonite s računala. Bilo kakvo objavljivanje, kopiranje ili distribucija svih ili pak samo dijela informacija koje su na bilo koji način sadržane u poruci trećim osobama zabranjeno je i može biti zakonski kažnjivo. Primite na znanje da su stavovi i mišljenja izneseni u poruci autorovi i ne predstavljaju nužno stavove i mišljenja Miadria d.o.o. U skladu s tim Miadria d.o.o. ne prihvaća nikakvu odgovornost za potencijalnu štetu nastalu primitkom ove poruke i privitaka sadržanih u poruci. 
> 
> *DISCLAIMER*
> The contents of this email as well as any files attached to it are confidential and intended solely for individuals or entities which they are addressed to. If you have received this email message in error, please notify the sender immediately and permanently remove the message and all attached files from the computer. Any disclosure, copying or distribution of all or a part of information contained herein to or by third parties is prohibited and may be unlawful. Please note that any views or opinions presented in this message are solely those of the author and do not necessarily represent the views and opinions of Miadria d.o..o. Therefore Miadria d.o.o. accepts no liability for any potential damage caused by this message and files attached to it. 
> -- 
> bimi mailing list
> [email-masked]

--

  Marc Bradshaw
  marcbradshaw.net | @marcbradshaw <https://twitter.com/marcbradshaw>

---

From: Mladen Baranek <[email-masked]>
Date: Tue, 18 Aug 2020 20:15:23 +0200

Hi,

Thank you for the information. It seems that our designer was not able to
produce correct SVG using Adobe Illustrator or Xara Pro.

We went through https://www.ietf.org/id/draft-svg-tiny-ps-abrotman-00.txt and
updated SVG manually.

What else do we have to do in order to get the logo in Yahoo email or
gmail?

 Best regards,

Mladen Baranek

*PHONE  *+38513090917

*MOBILE  *+385913010924

On Tue, Aug 18, 2020 at 1:58 PM Marc Bradshaw <marc=
[email-masked]> wrote:

> *EMAIL  [email-masked] <mladen@miadria..com>
>
>
>
> information..
> Sadržaj ove poruke kao i svih priloženih datoteka povjerljiv je i
> namijenjen samo osobama ili subjektima koji su navedeni kao primatelji.
> Ukoliko ste ovu poruku primili greškom, molimo odmah obavijestite
> pošiljatelja, a poruku i sve njene privitke odmah uklonite s računala. Bilo
> kakvo objavljivanje, kopiranje ili distribucija svih ili pak samo dijela
> informacija koje su na bilo koji način sadržane u poruci trećim osobama
> zabranjeno je i može biti zakonski kažnjivo. Primite na znanje da su
> stavovi i mišljenja izneseni u poruci autorovi i ne predstavljaju nužno
> stavove i mišljenja Miadria d.o.o. U skladu s tim Miadria d.o.o. ne
> prihvaća nikakvu odgovornost za potencijalnu štetu nastalu primitkom ove
> poruke i privitaka sadržanih u poruci.
>
> *DISCLAIMER*
> The contents of this email as well as any files attached to it are
> confidential and intended solely for individuals or entities which they are
> addressed to. If you have received this email message in error, please
> necessarily represent the views and opinions of Miadria d.o..o. Therefore

-- 

*DISCLAIMER*

---

From: "Marc Bradshaw" <[email-masked]>
Date: Wed, 19 Aug 2020 09:26:20 +1000

Hi Mladen,

The SVG is now passing our validator...

An authenticated email with this record would receive the following BIMI results:
Authentication-Results: authservid.example.com; bimi=pass header.d=miadria.com header.selector=default
BIMI-Indicator: PHN2ZyB2ZXJzaW9uPSIxLjIiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2Zy
    Igd2lkdGg9IjMwMCIgaGVpZ2h0PSIzMDAiIHZpZXdCb3g9IjAgMCAyOC4zIDI4LjMiIGJh
    c2VQcm9maWxlPSJ0aW55LXBzIj48dGl0bGU+TWlhZHJpYTwvdGl0bGU+PHBhdGggZmlsbD
    0iI0JGMTgxOCIgZD0iTTAsMHYyOC4zaDI4LjNWMEgweiBNMTEuMSwyNy43SDYuOFY0LjRo
    NC4zVjI3Ljd6IE0yMiwyNy43aC00LjNWNC40SDIyVjI3Ljd6Ii8+PC9zdmc+Cg==
BIMI-Location: v=BIMI1;
    l=https://www.miadria.com/mlogo.svg

As others have already said, individual receivers are likely to have their own requirements at this stage in addition to the purely technical requirements.

On Wed, 19 Aug 2020, at 4:15 AM, Mladen Baranek wrote:
> Hi,
> 
> Thank you for the information. It seems that our designer was not able to produce correct SVG using Adobe Illustrator or Xara Pro. 
> 
> We went through https://www.ietf.org/id/draft-svg-tiny-ps-abrotman-00.txt and updated SVG manually.
> 
> What else do we have to do in order to get the logo in Yahoo email or gmail? 
>  Best regards,

>  
> 
> 
> On Tue, Aug 18, 2020 at 1:58 PM Marc Bradshaw <marc=[email-masked]> wrote:
>> __
>> Hi Mladen,
>> 

>>>  
>>> *EMAIL  [email-masked] <mailto:mladen@miadria..com>

>>>> We'd like to continue to work on these with the community, and continue to incorporate feedback.  Also note a group blog post[4] that has similar information..
>>>> 
>>> Sadržaj ove poruke kao i svih priloženih datoteka povjerljiv je i namijenjen samo osobama ili subjektima koji su navedeni kao primatelji. Ukoliko ste ovu poruku primili greškom, molimo odmah obavijestite pošiljatelja, a poruku i sve njene privitke odmah uklonite s računala. Bilo kakvo objavljivanje, kopiranje ili distribucija svih ili pak samo dijela informacija koje su na bilo koji način sadržane u poruci trećim osobama zabranjeno je i može biti zakonski kažnjivo. Primite na znanje da su stavovi i mišljenja izneseni u poruci autorovi i ne predstavljaju nužno stavove i mišljenja Miadria d.o.o. U skladu s tim Miadria d.o..o. ne prihvaća nikakvu odgovornost za potencijalnu štetu nastalu primitkom ove poruke i privitaka sadržanih u poruci. 
>>> 
>>> *DISCLAIMER*
>>> The contents of this email as well as any files attached to it are confidential and intended solely for individuals or entities which they are addressed to. If you have received this email message in error, please notify the sender immediately and permanently remove the message and all attached files from the computer. Any disclosure, copying or distribution of all or a part of information contained herein to or by third parties is prohibited and may be unlawful. Please note that any views or opinions presented in this message are solely those of the author and do not necessarily represent the views and opinions of Miadria d.o..o. Therefore Miadria d.o..o. accepts no liability for any potential damage caused by this message and files attached to it. 
>>> -- 
>>> bimi mailing list
>>> [email-masked]

--

  Marc Bradshaw