Subject: Re: [Bimi] FW: Missing viewport-fill and other attributes for svg element

From: Trent Adams <[email-masked]>
Date: Thu, 12 Aug 2021 14:21:33 +0000

Yeah, it sounds reasonable to support the "viewport-fill" attribute for the <svg> root element.

It should, however, still be restricted from use by other elements that establish viewports (i.e. <animation>, <image>, <video>, <foreignObject>)... though I'm assuming that restrictions on those elements alone will suffice.  But it might be worth a note in the spec (and ensuring the RNC covers it).

BTW - I wonder if there are any other restrictions that should be reconsidered while we're under the hood.  Anything else that should be considered?

- Trent

On 8/12/21, 6:26 AM, "bimi on behalf of Brotman, Alex" <[email-masked] on behalf of Alex_Brotman=[email-masked]> wrote:

    Hey folks,

    Not sure if others would have a comment on this.  I've created this as:

    https://urldefense.com/v3/__https://trac.ietf.org/trac/bimi/ticket/2__;!!ORgEfCBsr282Fw!46jcbKwG2pH6MAbqadwZIiG0wPWYYwurdowDgcX9-hpseNUy_iQT-BXyT8bUNEF0$ 

    Seems like a reasonable request.  Barring comments to the contrary, this would be in the next iteration of the RNC and draft.

    --
    Alex Brotman
    Sr. Engineer, Anti-Abuse & Messaging Policy
    Comcast

    > -----Original Message-----
    > From: Daniel Micay <REDACTED>
    > Sent: Tuesday, August 10, 2021 2:58 AM
    > To: [email-masked]
    > Subject: Missing viewport-fill and other attributes for svg element
    >
    > The viewport-fill attribute and a few other rendering related attributes such as
    > shape-rendering are only defined by the SVG Tiny Portable/Secure grammar for
    > title and desc elements but not the svg element where they usually work with
    > the full SVG 1.2 Tiny specification.
    >
    > It's possible to approximiate viewport-fill with a rect, but it isn't quite the same
    > thing:
    >
    >     <rect width="100%" height="100%" fill="white"/>
    >
    > Using viewport-fill="white" is much nicer since it will fill the whole viewport even
    > if the aspect ratio is different. Google recommends using a solid background
    > color for BIMI, where this subset of SVG is required, so it's annoying that the
    > proper way to do it is missing:
    >
    > https://urldefense.com/v3/__https://support.google.com/a/answer/10911027__;!!ORgEfCBsr282Fw!46jcbKwG2pH6MAbqadwZIiG0wPWYYwurdowDgcX9-hpseNUy_iQT-BXyT_4AU6V6$ 
    >
    > The lack of these attributes also makes it harder than necessary to use this
    > format since you need to strip out shape-rendering, etc. from an existing SVG
    > Tiny 1.2 even though they're harmless. Rendering quality directives can be
    > implemented as a no-op anyway. I don't really see a reason to forbid those,
    > especially with it permitted for title/desc.
    -- 
    bimi mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bimi__;!!ORgEfCBsr282Fw!46jcbKwG2pH6MAbqadwZIiG0wPWYYwurdowDgcX9-hpseNUy_iQT-BXyT2e1H1VG$

---

From: Jakub Olexa <[email-masked]>
Date: Thu, 12 Aug 2021 14:52:34 +0000 (UTC)

video, image and animation are not allowed at all.

I would suggest removing text support as text rendering of SVG may result in inconsistent display across devices/engines which in turn may result in logos not being true to the intended original.

---

From: "Brotman, Alex" <[email-masked]>
Date: Thu, 12 Aug 2021 18:50:01 +0000

We'd just be adding it back to the <svg> element.

We can have a separate thread about the text support, if you'd like.  I understand the concerns, though wonder if the usefulness is there for some entities.

> From: bimi <[email-masked]> On Behalf Of Jakub Olexa
> Sent: Thursday, August 12, 2021 10:53 AM
> To: [email-masked]
> Subject: Re: [Bimi] FW: Missing viewport-fill and other attributes for svg
> element
>
> I would suggest removing text support as text rendering of SVG may result in
> inconsistent display across devices/engines which in turn may result in logos
> not being true to the intended original.
>
> --
> bimi mailing list
> [email-masked]
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bimi__
> ;!!CQl3mcHX2A!WMLvDbolzGDA9je0UkLRG5ZOAj1D-
> lHRIJNG2TkxUQB1E6vSeEMlCv1QEcD1J7kV2fyGmLM$

---

From: Jakub Olexa <[email-masked]>
Date: Thu, 12 Aug 2021 20:02:20 +0000 (UTC)

Quite frankly I have not encountered a single logo that would be tiny-ps compliant and used a text but the fact that it's possible to use text on itself it somewhat scary to me...not to mention that I know a way how to abuse the text element.

---

From: "Marc Bradshaw" <[email-masked]>
Date: Thu, 26 Aug 2021 06:47:13 +1000

Hi Jakub,

Is there any issue with text other than potentially inconsistent display? Is there an attack vector here?

--

  Marc Bradshaw
  marcbradshaw.net | @marcbradshaw <https://twitter.com/marcbradshaw>

---

From: Jakub Olexa <[email-masked]>
Date: Thu, 26 Aug 2021 10:38:51 +0200

Hi Marc,

I think the actual display inconsistency is the biggest issue from the 
marketer's standpoint as the whole purpose of BIMI is showing brand logo 
and VMC is all about authenticating that the logo matches the trademark.

In theory I could make a text with characters in the SVG that could 
change the display completely depending on the SVG renderer. Eg. the 
text content which would read "Brand" in the system font would show up 
as "Google" by creating custom characters for individual letters.

Jakub Olexa
Founder & CEO
E-mail: [email-masked] <mailto:[email-masked]>
Tel: +420 777 744 440 <tel:+420777744440>

Mailkit - Closing the circle between Deliverability and Engagement 
<https://www.mailkit.com>

On 25.08.2021 22:47, Marc Bradshaw wrote:
>> I would suggest removing text support as text rendering of SVG may 
>> result in inconsistent display across devices/engines which in turn 
>> may result in logos not being true to the intended original.
>>
>
> --
>
> 	
>   Marc Bradshaw
> marcbradshaw.net <http://marcbradshaw.net/> | @marcbradshaw 
> <https://twitter.com/marcbradshaw>
>
>
>
>