Subject: [Bimi] FW: Missing viewport-fill and other attributes for svg element

From: "Brotman, Alex" <[email-masked]>
Date: Thu, 12 Aug 2021 12:25:43 +0000

Hey folks,

Not sure if others would have a comment on this.  I've created this as:

https://trac.ietf.org/trac/bimi/ticket/2

Seems like a reasonable request.  Barring comments to the contrary, this would be in the next iteration of the RNC and draft.

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

> -----Original Message-----
> From: Daniel Micay <REDACTED>
> Sent: Tuesday, August 10, 2021 2:58 AM
> To: [email-masked]
> Subject: Missing viewport-fill and other attributes for svg element
>
> The viewport-fill attribute and a few other rendering related attributes such as
> shape-rendering are only defined by the SVG Tiny Portable/Secure grammar for
> title and desc elements but not the svg element where they usually work with
> the full SVG 1.2 Tiny specification.
>
> It's possible to approximiate viewport-fill with a rect, but it isn't quite the same
> thing:
>
>     <rect width="100%" height="100%" fill="white"/>
>
> Using viewport-fill="white" is much nicer since it will fill the whole viewport even
> if the aspect ratio is different. Google recommends using a solid background
> color for BIMI, where this subset of SVG is required, so it's annoying that the
> proper way to do it is missing:
>
> https://support.google.com/a/answer/10911027
>
> The lack of these attributes also makes it harder than necessary to use this
> format since you need to strip out shape-rendering, etc. from an existing SVG
> Tiny 1.2 even though they're harmless. Rendering quality directives can be
> implemented as a no-op anyway. I don't really see a reason to forbid those,
> especially with it permitted for title/desc.

---

From: Jakub Olexa <[email-masked]>
Date: Thu, 12 Aug 2021 13:40:28 +0000 (UTC)

Makes sense. Nothing insecure abou viewport fill and there should be no display issues with this.

---

From: "Marc Bradshaw" <[email-masked]>
Date: Fri, 13 Aug 2021 11:22:20 +1000

Sounds reasonable to me.

On Thu, 12 Aug 2021, at 10:25 PM, Brotman, Alex wrote:
> bimi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bimi
> 

--

  Marc Bradshaw
  marcbradshaw.net | @marcbradshaw <https://twitter.com/marcbradshaw>