Subject: [BLISS] draf draft-poetzl-sipping-call-completion-02.txt: now available

From: "Jesske, R" <[email-masked]>
Date: Tue, 6 Mar 2007 07:07:33 +0100

Dear all,
The draft draft-poetzl-sipping-call-completion-02.txt is now available.

http://tools.ietf.org/wg/sipping/draft-poetzl-sipping-call-completion-02.txt

We would be happy about comments and discussion

Best Regards

Roland

Deutsche Telekom AG
T-Com, Zentrum Technik Einführung
Roland Jesske
Gateways, Protokolle, Konvergenz, TE33-6
Deutsche-Telekom-Allee 1, 64295 Darmstadt, Raum 314(Besucheradresse)
Postfach, 64307 Darmstadt (Postanschrift)
06151 83-5940 (Tel.)
06151 83-4577 (Fax)
E-Mail: [email-masked]
http://www.t-com.de

Registerrechtliche Unternehmensangaben:
Deutsche Telekom AG
Aufsichtsrat: Dr. Klaus Zumwinkel (Vorsitzender)
Vorstand: René Obermann (Vorsitzender), 
Dr. Karl-Gerhard Eick (stellvertretender Vorsitzender),
Hamid Akhavan, Timotheus Höttges, Lothar Pauly
Handelsregister: Amtsgericht Bonn HRB 6794,
Sitz der Gesellschaft: Bonn
WEEE-Reg.-Nr.: DE50478376
***************************************************************
Deutsche Telekom AG
Supervisory Board: Dr. Klaus Zumwinkel (Chairman)
Board of Management: René Obermann (Chairman), 
Dr. Karl-Gerhard Eick (Deputy Chairman),
Hamid Akhavan, Timotheus Höttges, Lothar Pauly
Commercial register: Amtsgericht Bonn HRB 6794,
corporate seat: Bonn
WEEEreg.no: DE50478376

_______________________________________________
BLISS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bliss

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Tue, 6 Mar 2007 15:14:53 +0100

Roland,

is the queue-operation parameter really necessary?
'add' is just a synonym for a SUBSCRIBE with an Expire > 0

The 'suspend' / 'resume' functionality can be done by the calling UA: it
can ignore ('suspend') or handle ('resume') incoming NOTIFYs.

What's the point of the 'caller' parameter? The SUBSCRIBE request already
contains 'From' and possibly P-Asserted-Id. 

Aren't the 'short-term-denial' and 'long-term-denial' parameters already
covered by existing SIP response codes?

Wolfgang

[non-standard sig as required by dubious EU regulations]
--
T-Systems Enterprise Services GmbH
Aufsichtsrat: René Obermann (Vorsitzender)
Executive Committee: Lothar Pauly (Vorsitzender)*, Helmut Binder, Albert Henn, Olaf Heyden*, Katrin Horstmann, Ulrich Kemp, Axel Knobe*,
Wilfried Peters*, Dr. Herbert Schaaff*, Zvezdana Seeger*
Handelsregister: Amtsgericht Frankfurt am Main HRB 55933
Sitz der Gesellschaft: Frankfurt am Main
WEEE-Reg.-Nr. DE87523644
*Geschäftsführer gem. § 35 GmbHG

---

From: "Huelsemann, Martin" <[email-masked]>
Date: Thu, 15 Mar 2007 17:41:26 +0100

Hi Wolfgang, Jason,

using 'suspend' and 'resume' is a question of the effectiveness of running the service, because if a UAC knows that the user is busy and sends a 'suspend', the UAS doesn't has to initiate a call-completion recall to that user, wait for his response, cancel the recall, not knowing anyway if there is still a need to recall this user, and first then recall the next user in the queue.

You are right 'add' is a synonyme for SUBSCRIBE with Expires > 0, the advantage of it's usage is that it can very easily be interworked with the PSTN TCAP ccbsRequest invoke component.

For the denial reasons, there might be SIP response codes which match those reasons, but for me they seem to be more appropriate for the SIP transactions itself then for the call-completion event. So we decided to use an extra parameter, to have a clear separation between those two things.

For the caller parameter, there might be the service operation scenario where not the originating user is initiating the call-completion request, but an Application Server handles the call-completion operations for the user. In this case the UAC on the terminating side cannot derive the served user from the From header or P-Asserted ID, but the caller must be explicitly identified.

Regards, Martin

> -----Ursprüngliche Nachricht-----
> Von: Beck, Wolfgang 
> Gesendet: Dienstag, 6. März 2007 15:15
> An: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Betreff: [BLISS] AW: [Sipping] 
> drafdraft-poetzl-sipping-call-completion-02.txt; queue-operation
> 
> 
> Roland,
> 
> Executive Committee: Lothar Pauly (Vorsitzender)*, Helmut 
> Binder, Albert Henn, Olaf Heyden*, Katrin Horstmann, Ulrich 
> Kemp, Axel Knobe*,