Subject: WG: [BLISS] latest call-completion draft

From: "Huelsemann, Martin" <[email-masked]>
Date: Fri, 20 Jul 2007 11:07:58 +0200

Yes, I agree that the queue model has to be described more exactly, so text for the high-level operations is missing. In the next revision I will try to consider this in a better way.

Very shortly, there are no queue manipulation operations anymore, they are implicit. So there are no explicit queue manipulation operations like adding or removing oneself to or from the queue like in the PSTN.

A queue entry is created when a call ends in busy, and the caller can subscribe to the state of this queue entry. 

A queue entry is deleted when it matures after timer expiry, or when the caller starts a call-completion attempt after having received the regarding call-completion notification.

This means a 'deactivation' of call-completion like in the PSTN is not possible, you subscribe to call-completion if you are interested in this information, and you unsubscribe if you are no longer interested. 
An explicit deactivation request from the PSTN could also be interworked in a un-SUBSCRIBE.

So in principle it is very simple now, the only thing I have to do is to explain this in the draft in a understandable manner.

Regards, Martin

>> -----Ursprüngliche Nachricht-----
>> Von: [email-masked] [mailto:[email-masked]] 
>> Gesendet: Freitag, 20. Juli 2007 04:40
>> An: [email-masked]
>> Betreff: Re: [BLISS] latest call-completion draft
>> 
>> 
>> 
>>    From: "Huelsemann, Martin" <[email-masked]>
>> 
>>    the latest call-completion draft has been uploaded, as agreed
>>    call-completion was shifted to BLISS, so you can find the result
>>    under
>>    
>> http://www.ietf.org/internet-drafts/draft-poetzl-bliss-call-completion-00.txt.
>
>As a big nit, the text seems to have been put through something that
>has altered the formatting a great deal.
>
>Technically, I think it would help to clean up the Requirements
>section.  As written, it mixes details of the mechanism (e.g., "In
>this case the state of the caller changes from 'queued' to
>'ready-for-call-completion' and the caller will be informed
>accordingly.") with the actions it is to support.  A careful
>enumeration of the high-level operations would be quite helpful.
>
>Also, I don't see a discussion of how the "queue manipulation
>operations" are performed.  Maybe those are implicit.  But I get the
>feeling that the author understands how CCBS works so intuitively that
>he is not spelling out the algorithms and interactions in the
>necessary detail.
>
>Dale
>
>_______________________________________________
>BLISS mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/bliss

_______________________________________________
BLISS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bliss

---

From: [email-masked]
Date: Fri, 20 Jul 2007 06:56:08 -0400

A queue entry is created when a call ends in busy, and the caller
   can subscribe to the state of this queue entry. 

   A queue entry is deleted when it matures after timer expiry, or
   when the caller starts a call-completion attempt after having
   received the regarding call-completion notification.

I'd like to see more detail on how the call-completion arbitration
operatoin works.  How do the calling UA and the call-completion
arbiter interact to get the right things to happen in all cases?

Dale