Subject: [BLISS] draft-elwell-bliss-dnd-01 posted

From: "Elwell, John" <[email-masked]>
Date: Fri, 16 Nov 2007 18:16:31 +0000

http://www.ietf.org/internet-drafts/draft-elwell-bliss-dnd-01.txt
This has been updated, mainly to reflect comments received around the
time of the Vancouver meeting and some further thoughts from the new
co-author, Srivatsa. Although part of the automatic call handling (ACH)
topic in BLISS, for which a separate draft has been submitted
(draft-elwell-bliss-ach), we felt we needed to maintain the DND draft
because there is not a 100% overlap with ACH (e.g., the DND draft also
contains something on presence).

Changes from draft-00 are mainly:
- additional means of invoking DND (casual, based on sensing a user's
current activity);
- distinction between conveying DND to a proxy and conveying the
condition to the caller;
- problem of indicating DND to a caller when the condition does not
relate to the original called party (e.g., the call was forwarded
first);
- whether to wait for all branches to respond or act immediately a
branch reports DND;

Comments?

John

_______________________________________________
BLISS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bliss

---

From: "Steve Langstaff" <[email-masked]>
Date: Mon, 19 Nov 2007 04:24:11 -0800

In the ID, where you say e.g.:

      REQ1 - There MUST be a way for a UA to indicate through presence
      that it is not willing to receive a call or message because the
      user does not wish to be disturbed.

Do you mean "There MUST be a single way for..." or "There MUST be at
least one way...".

> -----Original Message-----
> From: Elwell, John [mailto:[email-masked]] 
> Sent: 16 November 2007 18:17
> To: [email-masked]
> Cc: Srivatsa Srinivasan
> Subject: [BLISS] draft-elwell-bliss-dnd-01 posted
> 
> This has been updated, mainly to reflect comments received 
> around the time of the Vancouver meeting and some further 
> thoughts from the new co-author, Srivatsa. Although part of 
> the automatic call handling (ACH) topic in BLISS, for which a 
> separate draft has been submitted (draft-elwell-bliss-ach), 
> we felt we needed to maintain the DND draft because there is 
> not a 100% overlap with ACH (e.g., the DND draft also 
> - additional means of invoking DND (casual, based on sensing 
> a user's current activity);
> - distinction between conveying DND to a proxy and conveying 
> the condition to the caller;
> - problem of indicating DND to a caller when the condition 
> does not relate to the original called party (e.g., the call 
> was forwarded first);
> - whether to wait for all branches to respond or act 
> immediately a branch reports DND;
> 
> 
> Comments?
> 
> John
> 
> 
>

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 19 Nov 2007 18:00:52 +0000

Steve,

What I mean is that there MUST be at least one way that an
implementation can use and be sure that other conformant implementations
will do the same.

John

> From: Steve Langstaff [mailto:[email-masked]] 
> Sent: 19 November 2007 12:24
> To: Elwell, John; [email-masked]
> Cc: Srivatsa Srinivasan
> Subject: RE: [BLISS] draft-elwell-bliss-dnd-01 posted
>