Subject: [Blockchain-interop] New rev of blockchain gateway interoperability architecture draft -- FW: New Version Notification .....

From: Thomas Hardjono <[email-masked]>
Date: Mon, 26 Oct 2020 17:13:40 +0000

Folks,

Below is a revision of the blockchain gateway interoperability architecture draft.

It now goes into further details of each of the phases.

https://datatracker.ietf.org/doc/draft-hardjono-blockchain-interop-arch/

Best

-- thomas --

________________________________________
From: [email-masked] [[email-masked]]
Sent: Monday, October 26, 2020 1:09 PM
To: Ned Smith; Martin Hargreaves; Thomas Hardjono
Subject: New Version Notification for draft-hardjono-blockchain-interop-arch-01.txt

A new version of I-D, draft-hardjono-blockchain-interop-arch-01.txt
has been successfully submitted by Thomas Hardjono and posted to the
IETF repository.

Name:           draft-hardjono-blockchain-interop-arch
Revision:       01
Title:          An Interoperability Architecture for Blockchain Gateways
Document date:  2020-10-27
Group:          Individual Submission
Pages:          20
URL:            https://www.ietf.org/archive/id/draft-hardjono-blockchain-interop-arch-01.txt
Status:         https://datatracker.ietf.org/doc/draft-hardjono-blockchain-interop-arch/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-hardjono-blockchain-interop-arch
Htmlized:       https://tools.ietf.org/html/draft-hardjono-blockchain-interop-arch-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-hardjono-blockchain-interop-arch-01

Abstract:
   With the increasing interest in the potential use of blockchain
   systems for virtual assets, there is a need for these assets to have
   mobility across blockchain systems.  An interoperability architecture
   for blockchain systems is needed in order to permit the secure flow
   of virtual assets between blockchain systems, satisfying the
   properties of transfer atomicity, consistency and durability.  The
   architecture must recognize that there are different blockchain
   systems, and that the interior constructs in these blockchains maybe
   incompatible with one another.  Gateway nodes perform the transfer of
   virtual assets between blockchain systems while masking the
   complexity of the interior constructs of the blockchain that they
   represent.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Michael McBride <[email-masked]>
Date: Mon, 26 Oct 2020 23:42:06 +0000

Hi Thomas,

Great document. It looks like the gateway could be what many of us would term an oracle? If so, the oracle (or gateway) could be responsible not only for on/off chain transactions but also for DLT interoperability. 

Which leads to the need for a use case and/or problem statement document. There is skepticism (within the ietf) about the validity of blockchain technology. We need to be very clear about the problem, including use cases, if the goal of this work is to eventually rally a wg. 

Thanks,
mike

-----Original Message-----
From: Blockchain-interop <[email-masked]> On Behalf Of Thomas Hardjono
Sent: Monday, October 26, 2020 10:14 AM
To: [email-masked]
Subject: [Blockchain-interop] New rev of blockchain gateway interoperability architecture draft -- FW: New Version Notification .....

Folks,

https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hardjono-blockchain-interop-arch%2F&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=6uu3zd4yRZjmgednPF4dsjrs86DXE8JGFieImvJQW%2BY%3D&amp;reserved=0

Best

-- thomas --

A new version of I-D, draft-hardjono-blockchain-interop-arch-01.txt
has been successfully submitted by Thomas Hardjono and posted to the IETF repository.

Name:           draft-hardjono-blockchain-interop-arch
Revision:       01
Title:          An Interoperability Architecture for Blockchain Gateways
Document date:  2020-10-27
Group:          Individual Submission
Pages:          20
URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-hardjono-blockchain-interop-arch-01.txt&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=rmv8jnYLjZuGvYPglwk7nrhrb%2BkFZFFZy57kLJUaEGc%3D&amp;reserved=0
Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hardjono-blockchain-interop-arch%2F&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=6uu3zd4yRZjmgednPF4dsjrs86DXE8JGFieImvJQW%2BY%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hardjono-blockchain-interop-arch&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=KLy6P58VkIL4IU065QzFEv7UuG7jRBeXRB25GTqW6KE%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-hardjono-blockchain-interop-arch-01&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=%2B1B5w4hx4Hn8Xqfp4yhG4LN0xRwXywyxKX5o3vtQ66Y%3D&amp;reserved=0
Diff:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-hardjono-blockchain-interop-arch-01&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=1eI9LDhuLsWvk37uIkmxLcIpiuA5ZgqlM7dzYpqdjhI%3D&amp;reserved=0

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

--
Blockchain-interop mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fblockchain-interop&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=79HXXAFK%2FXlpnSAWBm5he4stIxOpJ%2BpJQAFm6Z9RZsE%3D&amp;reserved=0

---

From: Thomas Hardjono <[email-masked]>
Date: Tue, 27 Oct 2020 16:19:29 +0000

Thanks Michael,

>>> It looks like the gateway could be what many of us would term an oracle? 
>>> If so, the oracle (or gateway) could be responsible not only 
>>> for on/off chain transactions but also for DLT interoperability. 

I tend not to use the term "Oracle" because it has different meanings to different people (too confusing, even NISTR 8202 does not define it).

The gateway in our case has the task of moving virtual assets whose provenance (and authenticity & legitimacy) has been established previously (by other entities).  So a gateway is not asserting any truthful statement about the asset original or value (which is what Oracles are thought to do).

>>> Which leads to the need for a use case and/or problem statement document. 

We will be uploading a short use-case document very soon.

The problem statement is basically simple:  a gateway-to-gateway protocol that can satisfy the properties mentioned in the arch draft.

>>> There is skepticism (within the ietf) about the validity of blockchain technology. 
>>> We need to be very clear about the problem, including use cases, 
>>> if the goal of this work is to eventually rally a wg. 

Interestingly, we are not actually addressing any blockchain/DLT problem. The scope of work is limited only to 2 gateways and the things that need to occur between them for a proper transfer.

Looking the Figures in the draft, the word "blockchain/DLT" in the figures should be able to be substituted with the word "database", and if designed correctly the gateway-to-gateway transfer protocol should work just as well.

Best

-- thomas --

________________________________________
From: Michael McBride [[email-masked]]
Sent: Monday, October 26, 2020 7:42 PM
To: Thomas Hardjono; [email-masked]
Subject: RE: New rev of blockchain gateway interoperability architecture draft -- FW: New Version Notification .....

Hi Thomas,

Thanks,
mike

-----Original Message-----
From: Blockchain-interop <[email-masked]> On Behalf Of Thomas Hardjono
Sent: Monday, October 26, 2020 10:14 AM
To: [email-masked]
Subject: [Blockchain-interop] New rev of blockchain gateway interoperability architecture draft -- FW: New Version Notification .....

Folks,

Best

-- thomas --

Abstract:

The IETF Secretariat

---

From: Rafael Belchior <[email-masked]>
Date: Tue, 27 Oct 2020 16:53:27 +0000

Hello All,

On oracles: there are many definitions and implementations, and the term 
is typically associated with blockchains (see, for example, this work: 
https://www.researchgate.net/publication/343291410_Foundational_Oracle_Patterns_Connecting_Blockchain_to_the_Off-chain_World).

We can consider oracles "validators", in the sense that they assert 
something is happening (or not) in a specific blockchain. Just a 
thought.

Cheers,

A 2020-10-27 16:19, Thomas Hardjono escreveu:
> I tend not to use the term "Oracle" because it has different meanings
> to different people (too confusing, even NISTR 8202 does not define
> it).
> 
> The gateway in our case has the task of moving virtual assets whose
> provenance (and authenticity & legitimacy) has been established
> previously (by other entities).  So a gateway is not asserting any
> truthful statement about the asset original or value (which is what
> Oracles are thought to do).
> 
> 
> The problem statement is basically simple:  a gateway-to-gateway
> protocol that can satisfy the properties mentioned in the arch draft.
> 
> 
> Interestingly, we are not actually addressing any blockchain/DLT
> problem. The scope of work is limited only to 2 gateways and the
> things that need to occur between them for a proper transfer.
> 
> Looking the Figures in the draft, the word "blockchain/DLT" in the
> figures should be able to be substituted with the word "database", and
> if designed correctly the gateway-to-gateway transfer protocol should
> work just as well.
> 
> Best
> 
> 
> -- thomas --
> 
> 
> 
> Subject: RE: New rev of blockchain gateway interoperability
> architecture draft -- FW: New Version Notification .....
> 
> Hi Thomas,
> 
> Great document. It looks like the gateway could be what many of us
> would term an oracle? If so, the oracle (or gateway) could be
> responsible not only for on/off chain transactions but also for DLT
> interoperability.
> 
> Which leads to the need for a use case and/or problem statement
> document. There is skepticism (within the ietf) about the validity of
> blockchain technology. We need to be very clear about the problem,
> including use cases, if the goal of this work is to eventually rally a
> wg.
> 
> Thanks,
> mike
> 
> Subject: [Blockchain-interop] New rev of blockchain gateway
> interoperability architecture draft -- FW: New Version Notification
> .....
> 
> 
> Folks,
> 
> Subject: New Version Notification for
> draft-hardjono-blockchain-interop-arch-01.txt
> 
> URL:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-hardjono-blockchain-interop-arch-01.txt&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=rmv8jnYLjZuGvYPglwk7nrhrb%2BkFZFFZy57kLJUaEGc%3D&amp;reserved=0
> Status:
> Htmlized:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-hardjono-blockchain-interop-arch&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=KLy6P58VkIL4IU065QzFEv7UuG7jRBeXRB25GTqW6KE%3D&amp;reserved=0
> Htmlized:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-hardjono-blockchain-interop-arch-01&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=%2B1B5w4hx4Hn8Xqfp4yhG4LN0xRwXywyxKX5o3vtQ66Y%3D&amp;reserved=0
> Diff:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-hardjono-blockchain-interop-arch-01&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7Ce37dda00e3e344006e9108d879d28fcd%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637393292548341856%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=1eI9LDhuLsWvk37uIkmxLcIpiuA5ZgqlM7dzYpqdjhI%3D&amp;reserved=0
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> --

-- 
Rafael Belchior
Ph.D. student in Computer Science and Engineering, Blockchain - Técnico
Lisboa
https://rafaelapb.github.io/
https://www.linkedin.com/in/rafaelpbelchior/