Subject: [Blockchain-interop] Thoughts on unique DLT numbering/identification

From: Thomas Hardjono <[email-masked]>
Date: Fri, 9 Oct 2020 18:41:22 +0000

One of the gaps or issues with blockchain systems or DLTs today is the lack of a globally unique and uniform numbering (identification) scheme for each system.

For example, if a community in one country is running its own network of nodes (using a version of Hyperledger or Quorum), and a different community in another country is using the same software-stack on a different set of nodes, there is no way for a machine today (e.g. client) to distinguish between these communities (networks).

There has been some proposals for numbering/identification of the entities (e.g. VASP number), but this does not cover the network as a whole.

Do we need something like ARIN registry to allocate AS-numbers for blockchain networks.

Thoughts anyone?

-- thomas --

---

From: Miguel Correia <[email-masked]>
Date: Sat, 10 Oct 2020 13:40:47 +0100

Hi Thomas,

This is a very interesting topic.

I think today we distinguish blockchains in two ways:

- the client software we use is associated to a single blockchain and the identification is implicit in the software; or the client software is associated to more than one  blockchain and the software provides us that distinction (e.g., showing we if we are using blockchain bc1 or bc2)

- by IP address / port of (a subset of) the nodes 

I think currently this satisfies most needs, but I also think some kind of ID scheme will be needed in the future. For example, organizations may start using many instances of the same permissioned blockchain software (e.g., Fabric), with nodes in several other organizations. Using IPs/ports might be possible but surely not practical.

One solution would be to continue using IP addresses and use DNS to register names for blockchains. However, for consortium blockchains that involve several organizations, this creates the problem of who shall register the name.

Another aspect is that IDs/names are often used to help finding a resource. Is that interesting in this context?

Best,
Miguel

> On 9 Oct 2020, at 19:41, Thomas Hardjono <[email-masked]> wrote:
> 
> 
> -- 
> Blockchain-interop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/blockchain-interop

---

From: Thomas Hardjono <[email-masked]>
Date: Sat, 10 Oct 2020 14:24:44 +0000

Hi Miguel,

>>> I think today we distinguish blockchains in two ways:

Agree - this is what is being used today. The client software is either configured (e.g. with IP address/port of nearest nodes), or the user needs to type in a destination system.

>>> One solution would be to continue using IP addresses and use DNS to 
>>> register names for blockchains. However, for consortium blockchains that involve several organizations, 
>>> this creates the problem of who shall register the name.

My understanding is that the current direction of the regulators (e.g. FATF) is to require entities handling virtual assets (i.e. VASPs or virtual asset service providers) to have some form of legal identification (e.g. LEI number) or business registration (e.g. Incorporation number in the US).

However, that is just numbering or identification for one entity (one VASP).  If a group VASPs form a consortium sharing a common blockchain system with many nodes, then on the protocol level there still needs to be some identification for that "system" consisting of the multiple nodes.

>>> Another aspect is that IDs/names are often used to help finding a resource. 

Yes, exactly -- this what we need, some way to uniquely identify resources within a blockchain systems (independent of whether the resource is reachable, such as when within/behind private blockchains).

Best

-- thomas --

________________________________________
From: Blockchain-interop [[email-masked]] on behalf of Miguel Correia [[email-masked]]
Sent: Saturday, October 10, 2020 8:40 AM
To: [email-masked]
Subject: Re: [Blockchain-interop] Thoughts on unique DLT numbering/identification

Hi Thomas,

Best,
Miguel

---

From: Miguel Correia <[email-masked]>
Date: Mon, 12 Oct 2020 11:43:31 +0100

Hi Thomas,

I think we should discuss the relevance of this aspect because the IETF could be the right organization to handle it. I think the scope is wider than interoperability, but it is an enabler for interoperability so it might make sense to work on a proposal to solve it.

Best,
Miguel

> On 10 Oct 2020, at 15:24, Thomas Hardjono <[email-masked]> wrote:
> 
> 
> 
> Hi Miguel,
>

---

From: Thomas Hardjono <[email-masked]>
Date: Mon, 12 Oct 2020 13:04:05 +0000

Hi Miguel,

I agree with you that IETF is a good place to discuss this problem of numbering/identification of blockchain systems. Perhaps this could be a separate draft.

Something like this:

(a) Blockchain network number:  32 bits

(b) Provider (VASP) identification number:  32 bits

Would 32-bits be large enough for uniquely numbering blockchain systems in the future?  (The SWIFT number for bank identification are only 11 characters, and they seem to be working ok).

-- thomas --

Sent: Monday, October 12, 2020 6:43 AM

Hi Thomas,

Best,
Miguel

---

From: Martin Hargreaves <[email-masked]>
Date: Mon, 12 Oct 2020 15:20:46 +0000

Hi Thomas and Miguel,

I think 32 bits should be enough unless we envisage embedded DLT gateways in IoT devices or other very widespread small systems - I think that's relatively unlikely at this point, and would probably deserve a later revision to a number of areas.

Best,

Martin

-----Original Message-----
From: Blockchain-interop <[email-masked]> On Behalf Of Thomas Hardjono
Sent: Monday, October 12, 2020 2:04 PM
To: Miguel Correia <[email-masked]>; [email-masked]
Subject: Re: [Blockchain-interop] Thoughts on unique DLT numbering/identification

Hi Miguel,

Something like this:

-- thomas --

Hi Thomas,

Best,
Miguel

>>>> register names for blockchains. However, for consortium blockchains
>>>> that involve several organizations, this creates the problem of who shall register the name.
>
> From: Blockchain-interop [[email-masked]] on
> behalf of Miguel Correia [[email-masked]]
> - the client software we use is associated to a single blockchain and
> the identification is implicit in the software; or the client software
> is associated to more than one  blockchain and the software provides
> us that distinction (e.g., showing we if we are using blockchain bc1
> or bc2)
>

--
Blockchain-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/blockchain-interop
This message is intended solely for the addressee and may contain privileged and confidential information. If you have received this message in error, please send it back to us, and immediately and permanently delete it. Do not use, copy or disclose the information contained in this message or in any attachment. Quant Network does not guarantee that this email has not been intercepted and amended or that it is virus free.

---

From: Miguel Correia <[email-masked]>
Date: Mon, 12 Oct 2020 16:27:09 +0100

Hi Thomas,

Good question :) 

Before we think about the length, I think we need to think about the structure of the IDs and how they are going to be generated. I see three basic options:

- UUIDs generated randomly (RFC 4122)

- a 2-level solution as in IEEE 802 MAC addresses, with a central entity that assigns part of the space to a company and the company generates unique IDs inside that space

- a more complex solution as in IP addresses

I’m not even sure the same solution makes sense for (a) and (b).

Best,
Miguel

> On 12 Oct 2020, at 14:04, Thomas Hardjono <[email-masked]> wrote:
> 
> 
> Hi Miguel,
>

---

From: Miguel Correia <[email-masked]>
Date: Mon, 12 Oct 2020 16:38:01 +0100

Hi Martin,

I agree 32 bits will probably be enough, but the Internet history has also shown we can consume bits much faster than initially thought :-) If we go for 32 bits I would suggest specifying also a mechanism for updating the size later, if needed.

Best,
Miguel

> On 12 Oct 2020, at 16:20, Martin Hargreaves <[email-masked]> wrote:
> 
> Hi Thomas and Miguel,
>

---

From: Thomas Hardjono <[email-masked]>
Date: Mon, 12 Oct 2020 18:16:49 +0000

Hi Miguel,

This is a very interesting question.

For now, I think a 32-bit number (UUIDs generated randomly) should be enough.   There is always opportunity  to embed semantics within the 32-bit (or use a resolvable identifier, like OIDs/Handle).

Right now many VASPs are still undecided about the simple VASP identifier number.

-- thomas --

________________________________________
From: Miguel Correia [[email-masked]]
Sent: Monday, October 12, 2020 11:27 AM
To: Thomas Hardjono
Cc: [email-masked]
Subject: Re: [Blockchain-interop] Thoughts on unique DLT numbering/identification

Hi Thomas,

Good question :)

Best,
Miguel