Subject: [Blockchain-interop] Interesting paper when truthful behaviour may not be guaranteed

From: Luke Riley <[email-masked]>
Date: Tue, 16 Feb 2021 20:53:52 +0000

Hi all,

This is the paper I mentioned in the meeting: https://eprint.iacr.org/2018/489

Placing two gateways (with access to the same ledger but run by different parties) into a game against each other to guarantee (if economically rational) that the data returned is correct.

Regards,

Luke
This message is intended solely for the addressee and may contain privileged and confidential information. If you have received this message in error, please send it back to us, and immediately and permanently delete it. Do not use, copy or disclose the information contained in this message or in any attachment. Quant Network does not guarantee that this email has not been intercepted and amended or that it is virus free.

---

From: Thomas Hardjono <[email-masked]>
Date: Tue, 16 Feb 2021 21:07:37 +0000

Thanks Luke,

>>> Placing two gateways (with access to the same ledger but run by different parties) 
>>> into a game against each other to guarantee (if economically rational) 
>>> that the data returned is correct.

I like this idea very much -- perhaps adding gateway reputation (as Gilbert suggested) as the value point.  So the more a gateway is found to be unreliable (crashes too many times, tries to cheat, etc), it lowers the reputation score of the gateway.

Then the gateway election protocol could factor-in this reputation score.

-- thomas --

________________________________________
From: Blockchain-interop [[email-masked]] on behalf of Luke Riley [[email-masked]]
Sent: Tuesday, February 16, 2021 3:53 PM
To: [email-masked]
Subject: [Blockchain-interop] Interesting paper when truthful behaviour may not be guaranteed

Hi all,

Regards,

Luke