Subject: RE: [bmwg] WG Last Call: draft-ietf-bmwg-dsmterm-05

From: "Perser, Jerry" <[email-masked]>
Date: Mon, 7 Apr 2003 17:45:42 -0700

Good point.

The I-D references "the end of last binary digit of the Internet Datagram
[RFC791]".  Is this clear enough?

Jerry.
 
-----Original Message-----
From: Dana Heins [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 10:15 AM
To: Bmwg (E-mail)
Subject: RE: [bmwg] WG Last Call: draft-ietf-bmwg-dsmterm-05

While we're cleaning up the Delay defintion, perhaps there is a more clear
phrasing of the phrase: 'bit of the IP packet'.  Does 'bit' refer to binary
digit or is it slang meaning  a 'piece of the packet'?  Perhaps it would be
more clear with phrases like:

Start of the IP Header (what if it's tunneled?)
Start of packet (but only if qualified IP packet)
-----Original Message-----
From: Debby Stopp [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 9:41 AM
To: Bmwg (E-mail)
Subject: RE: [bmwg] WG Last Call: draft-ietf-bmwg-dsmterm-05

I have some comments regarding this definition:
     3.2.4 Delay

        Definition:
          The time interval starting when the last bit of the input IP
          packet reaches the input port of the DUT/SUT and ending when
          the last bit of the output IP packet is seen on the output
          port of the DUT/SUT.

 According to this def, we need to be able to determine the time at which
the last bit of the packet reaches the DUT/SUT - isn't this white box?  How
are we supposed to find out this time w/out asking the DUT/SUT?  Same
discussion for the other goalpost; how are we supposed to find out the time
that  the last bit left the DUT/SUT? 
I question the appropriateness of defining 'delay' specifically in this
document.  The word 'delay', is a well-known & highly utilized term in the
internet community.  I suggest that you append an modifier on this def, such
as "IP Delay" in order to differentiate it from the well-known  terminology
usage. 
In the same section:
Delay is delay, regardless of the technology being measured. 
 This is an ambiguous statement; either remove it or crisp up exactly what
you were trying to say.
& lastly -  If delay happens and no one measures it, is it still delay?
:) 

Debby Stopp
_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "Perser, Jerry" <[email-masked]>
Date: Mon, 7 Apr 2003 17:45:42 -0700

Good point.

Jerry.

-----Original Message-----
From: Debby Stopp [mailto:[email-masked]]
Sent: Wednesday, March 19, 2003 9:41 AM
To: Bmwg (E-mail)
Subject: RE: [bmwg] WG Last Call: draft-ietf-bmwg-dsmterm-05

        Definition:

Debby Stopp

---

From: "Perser, Jerry" <[email-masked]>
Date: Tue, 8 Apr 2003 09:42:13 -0700

Dana,

You have a good point.  I was not being sarcastic.  My goal is to make this
I-D as clear as possible.

I am willing to change 'the last bit' to 'the end of last binary digit of
the Internet Datagram [RFC791]'.  

Before I change it, I would like some consensus from the reflector.  Is the
change clearer?  Or is there a more precise way of stating this?

Jerry.

> Sent: Tuesday, April 08, 2003 8:56 AM
> To: 'Perser, Jerry'
> Hi Jerry,
> After I wrote that, I noticed that this phrase 'the last bit' 
> is used in
> many RFC's, so it seems that this is a well understood phrase.  
> 
> From: Perser, Jerry [mailto:[email-masked]]
> Sent: Monday, April 07, 2003 5:46 PM
> To: 'Dana Heins'; Bmwg (E-mail)

---

From: "Perser, Jerry" <[email-masked]>
Date: Tue, 8 Apr 2003 09:42:13 -0700

Dana,

Jerry.

---

From: Scott Poretsky <[email-masked]>
Date: Tue, 08 Apr 2003 13:07:33 -0400

'the last bit' is a well understood phrase because 'bit' has a specific 
meaning in the networking industry.  It is also consistent with previous 
IETF work.  For those reasons I recommend that the document use 'the last 
bit'.

Scott

---

From: Scott Poretsky <[email-masked]>
Date: Tue, 08 Apr 2003 13:07:33 -0400

Scott