Subject: RE: [bmwg] Terminology Question: Throughput

From: [email-masked]
Date: Mon, 17 Nov 2003 16:59:29 -0500

Besides Jerry's excellent citations from a well-respected dictionary, we
cannot dismiss the fact that "ingress" and "egress" are commonly used terms
in the IETF's MPLS RFCs.

Scott

-----Original Message-----
From: Perser, Jerry [mailto:[email-masked]]
Sent: Monday, November 17, 2003 3:25 PM
To: [email-masked]'
Subject: RE: [bmwg] Terminology Question: Throughput

> Ingress and Egress are not defined terms.  Inferred terms 
> lead to ambiguity and "specmanship", IMO.
> Can you find a ref for them?  

I find that Merriam-Webster definition is sufficient. See
http://www.m-w.com/.

Main Entry: ingress 
Etymology: Middle English, from Latin ingressus, from ingredi
Date: 15th century
1 : the act of entering : ENTRANCE
2 : the power or liberty of entrance or access

Main Entry: egress 
Function: noun
Etymology: Latin egressus, from egressus, past participle of egredi to go
out, from e- + gradi to go -- more at GRADE
Date: 1538
1 : the action or right of going or coming out
2 : a place or means of going out : EXIT 

> Probe is an undefined word in benchmarking, last time I 
> checked, though I hear it's a fairly decent for a Ford. :)

Sorry, I forget that we are not all Electrical Engineers using Test
Equipment.  I use 'probe' in the same context as an oscilloscope probe, a
voltage probe, a logic analyzer probe. See
http://www.tek.com/cgi-bin/si.pl?term=probe.

Instead of a philosophical Rate probe, lets say I got a real-world Frequency
counter
(http://we.home.agilent.com/cgi-bin/bvpub/agilent/Product/cp_Product.jsp?NAV
_ID=-11154.0.00).  Where do I connect the frequency counter's input to the
DUT/SUT?  Do I connect the counter where the packets go into the DUT/SUT, or
where the packets come out of the DUT/SUT?

Jerry.

> Thank you and Aloha,
> /m
> 
> 
> Michele Bustos
> Ixia
> 818-444-3244
> [email-masked]
> 
> -----Original Message-----
> From: Perser, Jerry [mailto:[email-masked]]
> Sent: Monday, November 17, 2003 10:13 AM
> To: [email-masked]'
> Subject: RE: [bmwg] Terminology Question: Throughput
> 
> 
> > I believe IPSEC is a special case where it is not so clear 
> cut in terms 
> > of ingress and egress but rather in the sense of clear and crypto 
> > traffic applied to throughput or forwarding rates.
> > 
> > 	Tim-
> > 
> 
> Where do I connect my RATE probe to make the throughput measurement?
> 
> RFC1242 was very clear on stating "input frames per second".  
> "Terminology
> for Benchmarking IPSec Devices" MUST be equal clear cut in 
> terms of ingress
> and egress as RFC1242 was.
> 
> Throughput does not equal Forwarding rate.  The RATE probe is 
> connected in
> different places.  You have used the term correctly here.  I 
> would suggest
> that your I-D reflects this.  I disagree with the concept 
> that Throughput is
> defined as a Forwarding rate.
> 
> Jerry.
> 
> ___________________________________________________________ 
> Jerry Perser                         Spirent Communications
> Director of Test Methodology         SmartBits Division 
> Phone: 818.676.2320                  26750 Agoura Road 
> Lab:   818.676.2337                  Calabasas, CA, 91302 
> Cell:  818.292.6457                  Corp:  818.676.2300
> 
>   
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
> 

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Tim Van Herck <[email-masked]>
Date: Mon, 17 Nov 2003 14:21:34 -0800

Scott,

> cannot dismiss the fact that "ingress" and "egress" are commonly used terms

Dismiss, no ! But I would not use those terms. Maybe inbound 
clear|crypto and outbound clear|crypto is more appropriate since it 
lines up with the IPSEC framework terminology.

But when you look at MPLS label switching capacity then an ingress 
packet is still identical to an egress packet i.e. none of the payload 
has been changed. Even in the case of an LER you can still track the 
signature by setting a different offset on the egress port. In the case 
of IPSEC there is nothing that you can do to match a signature against. 
That is just it's purpose ! Hence you will need to decrypt somewhere, so 
rather in terms of ingress and egress it may be easier to talk in terms 
of clear and crypto links since that is what is of interest. And yes, 
some of those links can be labeled as ingress and some of them as egress 
but that is already implied in the original throughput definition. No 
need for us to re-invent the wheel, right ?

	Tim-

---

From: Tim Van Herck <[email-masked]>
Date: Mon, 17 Nov 2003 14:21:34 -0800

Scott,

	Tim-