Subject: RE: [bmwg] IPSec Terminology Question: Encryption/Decryption Thr oughput

From: Michele Bustos <[email-masked]>
Date: Wed, 12 Nov 2003 09:05:34 -0800

Hi Timmons, good to hear from you.
Thank you for the comment.  This
will be addressed in the meth draft.
Thanks!
/m

-----Original Message-----
From: Player, Timmons [mailto:[email-masked]]
Sent: Wednesday, November 12, 2003 8:18 AM
To: [email-masked]'
Subject: [bmwg] IPSec Terminology Question: Encryption/Decryption
Throughput

When performing an IPSec Encryption/Decryption Throughput the draft isn't
clear as to which side of the DUT pps or Mbps should be measured.  I'm
pretty sure that Mbps will be different for ingress and egress.  And pps
could be different for ingress and egress depending on the size of the input
packet, at least for the encryption throughput case.

Timmons C. Player
ATP Engineer
Spirent Communications
c/o CENTAUR Lab @ UGA
110 E. Clayton St.
3rd Floor
Athens, GA 30606
+1.706.461.8467 

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Michele Bustos <[email-masked]>
Date: Wed, 12 Nov 2003 09:05:34 -0800

-----Original Message-----
From: Player, Timmons [mailto:[email-masked]]
Sent: Wednesday, November 12, 2003 8:18 AM
To: [email-masked]'
Subject: [bmwg] IPSec Terminology Question: Encryption/Decryption
Throughput

Timmons C. Player
ATP Engineer
Spirent Communications
c/o CENTAUR Lab @ UGA
110 E. Clayton St.
3rd Floor
Athens, GA 30606
+1.706.461.8467

---

From: "Perser, Jerry" <[email-masked]>
Date: Wed, 12 Nov 2003 14:47:29 -0800

If you are going to measure at the ingress AND egress, then you will need
two different definitions for the two metrics.

Jerry.

> From: Tim Van Herck [mailto:[email-masked]]
> Sent: Wednesday, November 12, 2003 10:46 AM
> To: Player, Timmons
> Cc: [email-masked]'
> Subject: Re: [bmwg] IPSec Terminology Question: Encryption/Decryption
> Throughput
> 
> 
> 	Timmons,
> 
> Like Michele already mentioned this will be addresses in the meth I-D 
> but to answer the question, we will indeed document that you can 
> represent throughput in four ways :
> 
> - measured at ingress in pps (clear traffic)
> - measured at ingress in Mbps (clear traffic)
> - measured at egress in pps (crypto traffic)
> - measured at egress in Mbps (crypto traffic & using crypto pkt size)
> 
> 	Tim-
>

---

From: "Perser, Jerry" <[email-masked]>
Date: Wed, 12 Nov 2003 15:44:59 -0800

Tim,

Before we can agree, I like to get some basic terminology correct:

- Throughput is measured at the ingress of the DUT/SUT
- Forwarding Rate is measured at the egress of the DUT/SUT
- Layer 2 measurements are in frames
- Layer 3 measurements are in packets

If anyone disagrees with these definitions, please point to the correct
definition document.  I bring this up because I don't think we are talking
apples to apples here.

Jerry.

> Sent: Wednesday, November 12, 2003 3:17 PM
> To: Perser, Jerry
> Cc: [email-masked]'
> 	Jerry,
> Let me restate that. We will define a tput test with two 
> ipsec devices 
> in a back to back setup on which we only measure at ingress ports and 
> may report the projected egress rate/Mbps.
> 
> In other scenario's we can use the defined framesizes to 
> measure rates. 
> In all cases the definition of a rate doesn't change, just 
> the framesize 
>   used to calculate the throughput changes. Agree ?
> 
> See section 9.1
> 
> 	Tim-
> 
> >>>When performing an IPSec Encryption/Decryption Throughput 
> >>
> >>the draft isn't
> >>
> >>>clear as to which side of the DUT pps or Mbps should be 
> >>
> >>measured.  I'm
> >>
> >>>pretty sure that Mbps will be different for ingress and 
> >>
> >>egress.  And pps
> >>
> >>>could be different for ingress and egress depending on the 
> >>
> >>size of the input
> >>

---

From: "Perser, Jerry" <[email-masked]>
Date: Wed, 12 Nov 2003 15:44:59 -0800

Tim,

Jerry.