Subject: RE: [bmwg] IPSec Terminology Question: Encryption/Decryption Thr oughput

From: "Perser, Jerry" <[email-masked]>
Date: Wed, 12 Nov 2003 14:47:29 -0800

If you are going to measure at the ingress AND egress, then you will need
two different definitions for the two metrics.

Jerry.

> -----Original Message-----
> From: Tim Van Herck [mailto:[email-masked]]
> Sent: Wednesday, November 12, 2003 10:46 AM
> To: Player, Timmons
> Cc: [email-masked]'
> Subject: Re: [bmwg] IPSec Terminology Question: Encryption/Decryption
> Throughput
> 
> 
> 	Timmons,
> 
> Like Michele already mentioned this will be addresses in the meth I-D 
> but to answer the question, we will indeed document that you can 
> represent throughput in four ways :
> 
> - measured at ingress in pps (clear traffic)
> - measured at ingress in Mbps (clear traffic)
> - measured at egress in pps (crypto traffic)
> - measured at egress in Mbps (crypto traffic & using crypto pkt size)
> 
> 	Tim-
> 
> > When performing an IPSec Encryption/Decryption Throughput 
> the draft isn't
> > clear as to which side of the DUT pps or Mbps should be 
> measured.  I'm
> > pretty sure that Mbps will be different for ingress and 
> egress.  And pps
> > could be different for ingress and egress depending on the 
> size of the input
> > packet, at least for the encryption throughput case.
> 
> 
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
> 

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Tim Van Herck <[email-masked]>
Date: Wed, 12 Nov 2003 15:16:50 -0800

Jerry,

Let me restate that. We will define a tput test with two ipsec devices 
in a back to back setup on which we only measure at ingress ports and 
may report the projected egress rate/Mbps.

In other scenario's we can use the defined framesizes to measure rates. 
In all cases the definition of a rate doesn't change, just the framesize 
  used to calculate the throughput changes. Agree ?

See section 9.1

	Tim-

---

From: Tim Van Herck <[email-masked]>
Date: Wed, 12 Nov 2003 15:16:50 -0800

Jerry,

See section 9.1

	Tim-