Subject: RE: [bmwg] Terminology Question: Throughput

From: "Perser, Jerry" <[email-masked]>
Date: Mon, 17 Nov 2003 12:24:46 -0800

> Ingress and Egress are not defined terms.  Inferred terms 
> lead to ambiguity and "specmanship", IMO.
> Can you find a ref for them?  

I find that Merriam-Webster definition is sufficient. See
http://www.m-w.com/.

Main Entry: ingress 
Etymology: Middle English, from Latin ingressus, from ingredi
Date: 15th century
1 : the act of entering : ENTRANCE
2 : the power or liberty of entrance or access

Main Entry: egress 
Function: noun
Etymology: Latin egressus, from egressus, past participle of egredi to go
out, from e- + gradi to go -- more at GRADE
Date: 1538
1 : the action or right of going or coming out
2 : a place or means of going out : EXIT 

> Probe is an undefined word in benchmarking, last time I 
> checked, though I hear it's a fairly decent for a Ford. :)

Sorry, I forget that we are not all Electrical Engineers using Test
Equipment.  I use 'probe' in the same context as an oscilloscope probe, a
voltage probe, a logic analyzer probe. See
http://www.tek.com/cgi-bin/si.pl?term=probe.

Instead of a philosophical Rate probe, lets say I got a real-world Frequency
counter
(http://we.home.agilent.com/cgi-bin/bvpub/agilent/Product/cp_Product.jsp?NAV
_ID=-11154.0.00).  Where do I connect the frequency counter's input to the
DUT/SUT?  Do I connect the counter where the packets go into the DUT/SUT, or
where the packets come out of the DUT/SUT?

Jerry.

> Thank you and Aloha,
> /m
> 
> 
> Michele Bustos
> Ixia
> 818-444-3244
> [email-masked]
> 
> -----Original Message-----
> From: Perser, Jerry [mailto:[email-masked]]
> Sent: Monday, November 17, 2003 10:13 AM
> To: [email-masked]'
> Subject: RE: [bmwg] Terminology Question: Throughput
> 
> 
> > I believe IPSEC is a special case where it is not so clear 
> cut in terms 
> > of ingress and egress but rather in the sense of clear and crypto 
> > traffic applied to throughput or forwarding rates.
> > 
> > 	Tim-
> > 
> 
> Where do I connect my RATE probe to make the throughput measurement?
> 
> RFC1242 was very clear on stating "input frames per second".  
> "Terminology
> for Benchmarking IPSec Devices" MUST be equal clear cut in 
> terms of ingress
> and egress as RFC1242 was.
> 
> Throughput does not equal Forwarding rate.  The RATE probe is 
> connected in
> different places.  You have used the term correctly here.  I 
> would suggest
> that your I-D reflects this.  I disagree with the concept 
> that Throughput is
> defined as a Forwarding rate.
> 
> Jerry.
> 
> ___________________________________________________________ 
> Jerry Perser                         Spirent Communications
> Director of Test Methodology         SmartBits Division 
> Phone: 818.676.2320                  26750 Agoura Road 
> Lab:   818.676.2337                  Calabasas, CA, 91302 
> Cell:  818.292.6457                  Corp:  818.676.2300
> 
>   
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
> 

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Tim Van Herck <[email-masked]>
Date: Mon, 17 Nov 2003 13:48:57 -0800

Jerry,

Please provide CONSTRUCTIVE feedback ! This just proves that you can 
browse the web ;-)

> http://www.tek.com/cgi-bin/si.pl?term=probe.

OK, let me put it in terms that you use. You CANNOT simply use ingress 
and egress in an ipsec context since both of them can be clear traffic 
or encrypted traffic. The throughput definition implies that there is no 
control plane traffic on the *egress* link (that's why you use signature 
fields in your testpackets) and  that the ingress packets are identical 
to the egress packets, which is not the case in an ipsec context. You 
cannot match the packets once the are flushed through an SA. It's like 
attaching a logic analyzer over an DA convertor ! It doens't make sense.

> where the packets come out of the DUT/SUT?

Forget about frequencies, rates, ... all throughput measurements are 
still done by looking at packet counters !

I suggest you re-read the Spirent Test Methodology paper, case TM-0100. 
You will find nothing in there that even indicates that rates are compared !

	Tim-

---

From: Tim Van Herck <[email-masked]>
Date: Mon, 17 Nov 2003 13:48:57 -0800

Jerry,

	Tim-