Subject: Re: [bmwg] Internet Draft Review and Preparation in BMWG

From: Kenneth Green <[email-masked]>
Date: Sun, 2 Oct 2011 15:57:51 -0700

Hi Benoit,

I do not recall doing anything special, I simply followed the instructions and it worked. 

FYI I am running the free version of XMLmind 4.9.1 under Win7-64.

The new XML2RFC menu does not appear until you open an RFC XML file.

Initially when trying to open my draft document I got the error "Cannot load document....rfcXXXX.dtd (The system cannot fund the file specified)".

Once I removed the offending line ( <!DOCTYPE rfc SYSTEM 'rfcXXXX.dtd'> ) from the top of my XML file it loaded successfully.

Regards,
Kenneth

Kenneth Green
Solution Architect
Ixia

-----Original Message-----
From: Benoit Claise [mailto:[email-masked]] 
Sent: Friday, 30 September 2011 7:16 PM
To: Kenneth Green
Cc: Al Morton; [email-masked]
Subject: Re: [bmwg] Internet Draft Review and Preparation in BMWG

Hi Kenneth,

Based on your feedback, I wanted to install the "Bill Fenner plug-in" on the latest version of XMLmind 5.0.0,.
I followed http://code.google.com/p/xml2rfc-xxe/wiki/Installation, but could not get the add on to be recognized...

Regards, Benoit.
> Interesting tools that certainly make the editing of IDs a lot easier than trying the native text format.
>
> Nroffedit
> + small to download, easy to install, easy to use text_to_nroff 
> + feature is very useful indeed learning nroff by example seems simply 
> + enough (at least enough to get the job done)
> - does not generate alternate output formats such as html or pdf ? The 
> online version of xml2rfc already supports an nroff output format so conversion xml->nroff is readily available. I wonder if a feature or tool could be added to Nroffedit to generate XML output and so allow maximum flexibility across source formats and output formats (since xml2rtf supports output as html and pdf which are very useful and much more readable and navigable alternatives to the native RFC text format)?
>
> XMLmind XML Editor
> - bigger download, easy to install.
> + Found " Bill Fenner plug-in" here: 
> + http://code.google.com/p/xml2rfc-xxe/
> + XML tag format is easy to learn by example and supports tables 
> + (didn't see that in the nroff examples)
> - tool is much harder to learn/get started than with nroffedit
> - Need to download and figure out where to install 'xml2rfc' if you 
> don't want to use the online version
> + Can generate various useful additional output formats including html 
> + and pdf
>
> My understanding is that the IETF only ever holds the text files so it is up to the author to hold/archive the primary source file. If that is correct then I guess we can each choose our favourite format/tool combination. Certainly with just a little comparative experimentation the Nroffedit solution appears much simpler and easier to use and its bidirectional feature is a valuable asset.
>
> Regards,
> Kenneth
>
> Kenneth Green
> Solution Architect
> Ixia
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Al Morton
> Sent: Monday, 19 September 2011 11:48 PM
> To: [email-masked]
> Subject: [bmwg] Internet Draft Review and Preparation in BMWG
>
> BMWG,
>
> While looking for something else, I stumbled on 
> http://tools.ietf.org/tools/idcomments/
> a comment extraction tool.
>
> Unfortunately, I found that this is not an operational tool at the moment.  It requires the rfcdiff tool, and rfcdiff is no longer available as a stand-alone tool.
> It is still available as a web-service, of course:
> http://tools.ietf.org/rfcdiff
>
> I was planning to ask that bmwg'ers try this when preparing comments for a couple of months, then consider whether it would become a recommended practice in bmwg, but we'll put that thought on the shelf.
> I'll pursue the current status of idcomments tool in my copious spare time...
>
> As we finish-up a few WG documents, I suspect that many of our remaining drafts are based on XML formatting.
> I have toyed with the possibility to make XML drafts a recommended practice in our group, too, and have helped people install XXE (XMLMind XML Editor) with Bill Fenner's plug-in.
> Then I saw this, a new nroff WYSIWYG editing tool:
> http://aaa-sec.com/nroffedit/
> It converts txt to nroff, too.  Nice if you know nroff.
>
> My informal attempts to move us in an improved direction continue, in any case. It's just a matter of time till the boiler-plate changes again.
>
> Comments on these topics are welcome,
> Al
> bmwg chair
>
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg

---

From: Ilya Varlashkin <[email-masked]>
Date: Wed, 12 Oct 2011 20:25:52 +0200

> I followed http://code.google.com/p/xml2rfc-xxe/wiki/Installation, but could not get the add on to be recognized...

I was using XMLmind for couple of years now and version 5.x is indeed no go with xml2rfc plug-in, but install XMLmind and you can hook up xml2rfc-xxe exactly as described in the link you've mentioned. 

Kind regards,
iLya

---

From: Al Morton <[email-masked]>
Date: Thu, 13 Oct 2011 08:34:12 -0400

Thanks Ilya, this should smooth out a bump in the road to XXE.
Al

At 02:25 PM 10/12/2011, Ilya Varlashkin wrote:
> > Based on your feedback, I wanted to install the "Bill Fenner 
> plug-in" on the latest version of XMLmind 5.0.0,.
> > I followed 
> http://code.google.com/p/xml2rfc-xxe/wiki/Installation, but could 
> not get the add on to be recognized...
> >
>
>I was using XMLmind for couple of years now and version 5.x is 
>indeed no go with xml2rfc plug-in, but install XMLmind and you can 
>hook up xml2rfc-xxe exactly as described in the link you've mentioned.
>
>Kind regards,
>iLya