Subject: [bmwg] request for comment: New Version Notification for draft-liu-bmwg-virtual-network-benchmark-00.txt

From: "Vic Liu" <[email-masked]>
Date: Mon, 7 Jul 2014 09:52:20 +0800

Hi all 

We are researching on virtual network and we've submit a draft of benchmark for virtual network.
Hope we can discuss on the mailing list and any comment are big welcome.
URL:  http://www.ietf.org/internet-drafts/draft-liu-bmwg-virtual-network-benchmark-00.txt

Thank you!
All the best!
Vic

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2014年7月5日, 星期六 4:32
收件人: Vic Liu; Dapeng Liu; Bob Mandeville; Dapeng Liu; Bob Mandeville; Brooks Hickman; Guang Zhang; Brooks Hickman; Guang Zhang; vic
主题: New Version Notification for draft-liu-bmwg-virtual-network-benchmark-00.txt

A new version of I-D, draft-liu-bmwg-virtual-network-benchmark-00.txt
has been successfully submitted by Dapeng Liu and posted to the IETF repository.

Name:		draft-liu-bmwg-virtual-network-benchmark
Revision:	00
Title:		Benchmarking Methodology for Virtualization Network Performance
Document date:	2014-07-04
Group:		Individual Submission
Pages:		16
URL:            http://www.ietf.org/internet-drafts/draft-liu-bmwg-virtual-network-benchmark-00.txt
Status:         https://datatracker.ietf.org/doc/draft-liu-bmwg-virtual-network-benchmark/
Htmlized:       http://tools.ietf.org/html/draft-liu-bmwg-virtual-network-benchmark-00

Abstract:
   As the virtual network have been wide establish in IDC. The
   performance of virtual network has become a consideration to the IDC
   managers. This draft introduce a benchmarking methodology for
   virtualization network performance.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Muhammad Durrani <[email-masked]>
Date: Sun, 6 Jul 2014 19:01:05 -0700

Hi Vic,

Key points are as following:

   a)The hypervisor type is of ultimate importance to the test results.
      Tester VM must be installed on the same hypervisor type as the
      real DUT. When feasible, tester VM software should be installed on
      a separate, but identical type of, hypervisor.
   b)The VNIC speed will have impact on test results. Tester must
      calibrate against all VNIC speeds to be tested against a real DUT.
   c)VM allocation of CPU resources and memory will affect test results
   d)Packet sizes will affect test results dramatically due to the
      nature of virtual machine

[MD] why don’t we configure tester VM with PCI by-pass mode to access the NIC directly this way there will be no dependency on the hypervisor - which is way better approach then above mentioned.

   e)Other possible extensions of above table: The number of VMs to be
      created, latency and/or jitter readings, one VNIC per VM vs.
      multiple VM sharing one VNIC, and uni-directional traffic vs. bi-
      directional traffic.
[MD] for multiple VM using one vNIC - we should be SR-IOV architecture which also has limited dependency on hypervisor.

Please fix your draft with above suggestions - Please don’t bring in vSwitch in the picture for tester VM - this will always limit the performance to half regardless of mem/cpu availability.

Regards,
Muhammad

-----Original Message-----
From: bmwg [mailto:[email-masked]] On Behalf Of Vic Liu
Sent: Sunday, July 06, 2014 6:52 PM
To: [email-masked]
Cc: 'Dapeng Liu'
Subject: [bmwg] request for comment: New Version Notification for draft-liu-bmwg-virtual-network-benchmark-00.txt

Hi all 

Thank you!
All the best!
Vic

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2014年7月5日, 星期六 4:32
收件人: Vic Liu; Dapeng Liu; Bob Mandeville; Dapeng Liu; Bob Mandeville; Brooks Hickman; Guang Zhang; Brooks Hickman; Guang Zhang; vic
主题: New Version Notification for draft-liu-bmwg-virtual-network-benchmark-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
bmwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bmwg