Subject: Re: [bmwg] Benoit Claise's No Objection on draft-ietf-bmwg-traffic-management-04: (with COMMENT)

From: Barry Constantine <[email-masked]>
Date: Tue, 2 Jun 2015 22:52:49 +0000

Hello Benoit,

Thank you for providing comments on the draft, specifically the references to aqm work, applicability to SCTP, etc.

They were all meaningful and we incorporated them into the -05 version that was just posted

Thank you,
Barry and Ramki

-----Original Message-----
From: Benoit Claise [mailto:[email-masked]] 
Sent: Tuesday, May 26, 2015 1:28 PM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Benoit Claise's No Objection on draft-ietf-bmwg-traffic-management-04: (with COMMENT)

Benoit Claise has entered the following ballot position for
draft-ietf-bmwg-traffic-management-04: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bmwg-traffic-management/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 6.2.1 Queue/Scheduler Individual Tests Overview I understand that is not finished work, but do we need to say a few words about codel and pie http://datatracker.ietf.org/doc/draft-ietf-aqm-pie/ and http://datatracker.ietf.org/doc/draft-ietf-aqm-codel/

- More of a transport AD question:
"To this end, the stateful tests will use TCP test patterns to emulate applications."
Do we need to emulate any applications on SCTP test patterns?
Asking the transport ADs about which deployed protocols use SCTP, their answer was: WebRTC, SS7 signalling in 3gpp mobile networks.

Editorial:

- Section 1:

   Specifically, this framework defines the methods to characterize
   the capacity of the following traffic management features in network
   devices; classification, policing, queuing / scheduling, and
   traffic shaping.

Section 1.2

   This testing framework describes the tests and metrics for each of
   the following traffic management functions:
   - Policing
   - Queuing / Scheduling
   - Shaping

I would add classification to that list.

-  Section 1.2
    "Note the NDE SHOULD be used in "full pipe" delay mode."

I don't know what "full pipe" delay mode is

- OLD:
It is not within scope of this of this framework to specify
NEW:
It is not within scope of this framework to specify

- General observation. This is one of these documents where too many acronyms make it difficult to read (and I have some QoS background)
Ex: "The tests will verify that the network device can handle the CIR with CBS and the EIR with EBS
Note: I don't expect any action on this remark

- Section 6:

   Each test SHOULD compare the network device's internal statistics
   (available via command line management interface, SNMP, etc.) to the
   measured metrics defined in section 4. 

FYI. Most MIB interface/QoS counters are not updated real-time in routers. 10 sec for interface stats is common.
So no real-time monitoring is possible.

- two instances of tester*: not sure what they mean
    configure the tester* to generate a profile of emulated of an application traffic mixture

---

From: Benoit Claise <[email-masked]>
Date: Thu, 04 Jun 2015 06:29:04 -0700

Thanks Barry for addressing my comments.

A minor editorial change with the following sentence

    WebRTC, SS7 signaling, and 3gpp are
    examples of SCTP protocols that could be modeled with this
    framework to benchmark SCTP's effect on traffic management
    performance.

They use SCTP but are not SCTP

Regards, Benoit

---

From: Barry Constantine <[email-masked]>
Date: Thu, 4 Jun 2015 14:14:22 +0000

OK yes, that makes sense Benoit.

We’ll change that in the next revision.

Thank you,
Barry Constantine

JDSU Network and Service Enablement
Principal Member Technical Staff
301-325-7069

From: Benoit Claise [mailto:[email-masked]]
Sent: Thursday, June 04, 2015 9:29 AM
To: Barry Constantine; The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Benoit Claise's No Objection on draft-ietf-bmwg-traffic-management-04: (with COMMENT)

   performance.

Regards, Benoit

Hello Benoit,

Thank you,

Barry and Ramki

-----Original Message-----

To: The IESG

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

COMMENT:

Editorial:

- Section 1:

   traffic shaping.

Section 1.2

   - Policing

   - Queuing / Scheduling

   - Shaping

-  Section 1.2

- OLD:

NEW:

- Section 6:

---

From: Barry Constantine <[email-masked]>
Date: Tue, 9 Jun 2015 18:50:06 +0000

Hello Benoit,

Thanks for catching that error.

We revised and re-posted a new version.

Thank you,
Barry and Ramki

   performance.

Regards, Benoit

Hello Benoit,

Thank you,

Barry and Ramki

-----Original Message-----

To: The IESG

COMMENT:

Editorial:

- Section 1:

   traffic shaping.

Section 1.2

   - Policing

   - Queuing / Scheduling

   - Shaping

-  Section 1.2

- OLD:

NEW:

- Section 6: