Subject: [bmwg] Favor: Confirm Errata 5207

From: Warren Kumari <[email-masked]>
Date: Mon, 18 Dec 2017 12:59:51 -0500

Hi there all,

This errata looks correct to me, but before I validate it I wanted to
ask the WG to confirm I'm not missing anything obvious.

https://www.rfc-editor.org/errata/eid5207

If I don't hear anything to the contrary I'll mark it verified on Friday.

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 18 Dec 2017 19:49:10 +0000

Hi Warren,

I think the fix:

OLD
   The DUT SHOULD be able to respond to address resolution requests sent
   by the DUT wherever the protocol requires such a process.
NEW
   The DUT SHOULD be able to respond to address resolution requests sent
   by the tester wherever the protocol requires such a process.

is fine, but it would suggest that
NEW++
   The tester SHOULD be able to respond to address resolution requests sent
   by the DUT wherever the protocol requires such a process.

is also needed, for symmetry.

Al

> -----Original Message-----
> From: bmwg [mailto:[email-masked]] On Behalf Of Warren Kumari
> Sent: Monday, December 18, 2017 1:00 PM
> To: [email-masked]
> Subject: [bmwg] Favor: Confirm Errata 5207
> 
> Hi there all,
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.rfc-
> 2Deditor.org_errata_eid5207&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=bjjaUdU3P64iEA1Bgik69SjnzDG
> 75gAiRQKHQje6bj8&s=AMJgPjE-e67R_B7CwNtTtd385iZHZryxhsF3IS_Sw3M&e=
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=bjjaUdU3P64iEA1Bgik69SjnzDG
> 75gAiRQKHQje6bj8&s=67LX3SMcO-MP3Udz0Fe-zdJfPsMvHmhl73LQBBnvZwo&e=

---

From: Warren Kumari <[email-masked]>
Date: Mon, 18 Dec 2017 16:27:51 -0500

> is also needed, for symmetry.

While I agree with you, that it likely larger than an Errata can
cover, and would likely need a -bis document... :-(
W

---

From: Lucien Avramov <[email-masked]>
Date: Mon, 18 Dec 2017 13:58:44 -0800

Is it possible to try to submit Al’s suggestion and see if there are issues with avoiding a -bis? His context is important.

Thank you,
Lucien

> On Dec 18, 2017, at 13:27, Warren Kumari <[email-masked]> wrote:
> 
> https://www.ietf.org/mailman/listinfo/bmwg

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 19 Dec 2017 13:36:23 +0000

It occurs to me that I could put in a comparable errata
to fix the same sentence:

OLD

and then we'll have both points recorded for update.

Is this your preferred course, Warren?
Al

> From: Lucien Avramov [mailto:[email-masked]]
> Sent: Monday, December 18, 2017 4:59 PM
> To: Warren Kumari
> Cc: MORTON, ALFRED C (AL); [email-masked]
> Subject: Re: [bmwg] Favor: Confirm Errata 5207
> 
> Is it possible to try to submit Al’s suggestion and see if there are
> issues with avoiding a -bis? His context is important.
> 
> Thank you,
> Lucien
> 
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwIFaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=5204fHGyWNDbTF2RjS1WM2VVgqk
> 3zGyQwDrtBTRxa0E&s=Hf-dPvFb6GqU9N9vH6l-P4sC7xJZG03jvx6HYV7u-KA&e=

---

From: Warren Kumari <[email-masked]>
Date: Sat, 30 Dec 2017 20:29:05 -0500

> Is this your preferred course, Warren?

So, I let this stew for as while (I was supposed to submit it on Friday).
I ended up going with:
"The DUT and tester SHOULD both be able to respond to address
resolution requests wherever the protocol requires such a
process."

This seems sufficiently clear, and only required a minor change to the text.
W

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 31 Dec 2017 14:26:58 +0000

Thanks Warren, that's very efficient wording.
My hat is off to you! (I know you like hats)
Happy New Year,
Al

> From: Warren Kumari [mailto:[email-masked]]
> Sent: Saturday, December 30, 2017 8:29 PM
> To: MORTON, ALFRED C (AL)
> Cc: Lucien Avramov; [email-masked]
> >> >>   The tester SHOULD be able to respond to address resolution
> requests
> >> sent
> >> >>> This errata looks correct to me, but before I validate it I
> wanted
> >> to