Subject: [Bridge-mib] WG last call:draft-ietf-bridge-rstpmib-05.txt

From: "David B Harrington" <[email-masked]>
Date: Tue, 21 Sep 2004 16:56:20 -0400

Hi,

This starts the WG last call for this document. The last call will end
October 5th.
Please review this document to ensure the technical quality and
clarity of the specification are adequate.
Please comment, even if the comment is "I have reviewed this document
and it appears adequate."
We intend to submit this document for approval as a Proposed Standard.

This document has dependencies on bridgemib-smiv2; that document will
be forthcoming soon.

Thanks,
David Harrington
[email-masked]
Bridge-mib co-chair

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Tuesday, September 21, 2004 3:38 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Bridge-mib] I-D ACTION:draft-ietf-bridge-rstpmib-05.txt
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Bridge MIB Working Group of the
IETF.
> 
> 	Title		: Definitions of Managed Objects for 
> Bridges with 
> 			  Rapid Spanning Tree Protocol
> 	Author(s)	: E. Bell, V. Ngai
> 	Filename	: draft-ietf-bridge-rstpmib-05.txt
> 	Pages		: 19
> 	Date		: 2004-9-21
> 	
> This memo defines a portion of the Management Information 
> Base (MIB) for use with network management protocols in 
> TCP/IP based internets.
> In particular, it defines a MIB module for managing the Rapid 
> Spanning Tree capability defined by the IEEE P802.1t [802.1t] 
> and P802.1w [802.1w] amendments to IEEE Std 802.1D-1998 for 
> bridging between Local Area Network (LAN) segments.
> Provisions are made for support of transparent bridging.  
> Provisions are also made so that these objects apply to 
> bridges connected by subnetworks other than LAN segments.  
> This memo also includes a MIB module in a manner that is 
> compliant to SMIv2 [RFC2578].
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-bridge-rstpmib-05.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to [email-masked] with the word 
> unsubscribe in the body of the message.  
> You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
> 	"get draft-ietf-bridge-rstpmib-05.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-bridge-rstpmib-05.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack"
or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been
split
> 	up into multiple messages), so check your local documentation
on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
ENCODING mime
FILE /internet-drafts/draft-ietf-bridge-rstpmib-05.txt
_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 22 Sep 2004 00:03:13 +0200

> This starts the WG last call for this document. The last call will end

[...]
 
> This document has dependencies on bridgemib-smiv2; that document will

I had a quick look and observed that this document refers in several
places to [RFC1493] while in reality it refers to [RFC1493bis]. The
little interesting detail here is that the BRIDGE-MIB revision aka
RFC1493bis adds a new object dot1dStpPortPathCost32 (without saying 
so clearly - this is almost hidden, only the compliance statements 
give some clue).

So what I think needs to be done is to spell out clearly in the
RSTP-MIB document that this in fact depends on the BRIDGE-MIB 
revision. Furthermore, in the BRIDGE-MIB revision aka RFC1493bis, 
the section titled "Changes from RFC 1493" should be rewritten to 
list the semantic changes relative to RFC 1493, removing the 
list of changes between the various IDs (there are things listed 
that were introduced and later removed, which is not important 
to keep around in the final version).

Despite this, my quick read of the RSTP-MIB ID under last call did 
not find anything I worry about.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany