Subject: RE: [Bridge-mib] MSTP MIB

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 21 Jul 2005 18:43:29 +0300

Juergen,

This version is prior to any review, and I do not believe it's useful to
make comments at this phase.  They are fighting to find an assigned
editor, when someone is in place we will review the documents and
provide all necessary inputs.

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juergen 
> Schoenwaelder
> Sent: Thursday, July 21, 2005 6:30 PM
> To: David B Harrington
> Cc: 'Bridge-Mib (E-mail)'
> Subject: Re: [Bridge-mib] MSTP MIB
> 
> On Thu, Jul 21, 2005 at 10:46:45AM -0400, David B Harrington wrote:
> 
> > The IEEE 802.1 WG is developing a MIB module for MSTP. The latest 
> > revision is available at 
> > http://www.ieee802.org/1/files/public/docs2005/ruzin-mstp-mib-02.txt
> > 
> > The changes from the previous revision are:
> > 1) The syntax had been debugged (by both ucd-snmp and SNMPc).
> > 2) The object mstpGenCfgIdDigest  has been added.
> > 3) Some ideas from both malhotra-mstpmib-01and 
> > frattura-mstp-mib-0411.txt have been used
> > 4) The explanations have been inserted (in the clause "3. 
> Structure of 
> > MSTP-MIB").
> 
> Dave, can you advise them to use a decent MIB parser? I did 
> run the MIB module through libsmi and I was not really 
> impressed. They seem to mix SMIv2/SMIv1 syntax, they use data 
> types not properly imported, they have notifications 
> referencing objects that are not-accessible and so on. The 
> point is not really to tell them what is broken and why but 
> to teach them that they better first check whether the tools 
> they use for syntax checking are actually appropriate.
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 
> _______________________________________________
> Bridge-mib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bridge-mib
> 

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 21 Jul 2005 12:15:32 -0400

Hi Juergen,

I think it a good suggestion to educate the WG about the tools to use.
I am sending a message with a link to
http://www.ops.ietf.org/mib-review-tools.html and an smilint report on
the module.

dbh