Subject: Re: [Bridge-mib] Question of link aggregation groups in Q-Bridge portList

From: "chungwei wu" <[email-masked]>
Date: Wed, 12 Dec 2001 14:24:09 -0800

Please be patient with me. Seem to me there is something missing here.
So let me rephrase the scenario in details.

When an EMS discovers a dot1qVlanStaticEntry and the 30th bit in 
dot1qVlanStaticEgressPorts is set to 1. The EMS knows the dot1dBasePortNum 
30 is selected for the dot1qVlanStaticEgressPorts. To get this port's ifType 
in ifIndex, It reads the dot1dBasePortIfIndex from dot1dBasePortTable with 
dot1dBasePortNum = 30, then uses this index (dot1dBasePortIfIndex) to 
retrive ifType in ifTable.

The dot1dBasePortIfIndex is a foreign key to the ifTable.

Any comments?

Question for your previous email:

>A bridge port does not have to have an ifIndex and the values do not have 
>to be the same.

However, on page 48 of "Understanding Standards Track IETF MIB Modules - 
SNMP counters tutorial", it said "All ports that bridge have an ifIndex and 
dot1dBasePortNum".

If a port (physical or logical) is capable of bridging, it will have an 
entry in the dot1dBasePortTable and be assigned a dot1dBasePortNum. This 
port should also have an entry in the ifTable. Even though its ifIndex may 
be different during switch reboot.

Thanks,
Chungwei

>From: Michael MacFaden <[email-masked]>
>To: chungwei wu <[email-masked]>
>CC: [email-masked]
>Subject: Re: [Bridge-mib] Question of link aggregation groups in Q-Bridge 
>portList
>Date: Wed, 12 Dec 2001 11:11:59 -0800
>
>On Wed, Dec 12, 2001 at 10:51:11AM -0800, chungwei wu wrote:
> >Correct me if I am wrong - Back to the 30th bit set in portList example. 
>The
> >manager will retrieve port ifIndex from the dot1BasePortTable by locating
> >the entry indexed by dot1BasePort with value of *30*.
>
>Incorrect.
>
>A given bridge port is identified by dot1dBasePortNum. An EMS
>must start with dot1dBasePortTable to learn what "bridge ports" the
>transparent bridge has.
>
>A bridge port does not have to have an ifIndex and
>the values do not have to be the same.
>
>Please see http://www.nmops.org/download/understanding-snmp-counters.pdf
>page 48.
>
> >Then it uses this ifIndex as a key to the ifTable to find more port 
>related information such
> >as ifType. Since LAG is one of the ifType, the manager knows this port is 
>a
> >logical LAG rather than a physical one.
>
>Easier to use ifXTable ifConnectorPresent to determine if a port is
>physical or logical (see page 46 of the above document).
>
>
>I will answer your product specific questions separately.
>
>Regards,
>Mike MacFaden
>

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: Michael MacFaden <[email-masked]>
Date: Wed, 12 Dec 2001 17:48:34 -0800

>The dot1dBasePortIfIndex is a foreign key to the ifTable.

That is my understanding. Some folks might argue the term
"foreign" key doesn't apply precisely. SNMP is not exactly SQL.

>SNMP counters tutorial", it said "All ports that bridge have an ifIndex and 

Oops, My error, sorry. I got it confused with dot1dBasePortCircuit.

Clearly the object dot1dBasePortIfIndex in rfc1493 doesn't explicitly 
say an ifIndex of zero is valid I the new rewrite of the BRIDGE-MIB
draft-ietf-bridge-bridgemib-smiv2-01.txt
changed the SYNTAX from INTEGER to InterfaceIndex and not 
InterfaceIndexOrZero.

Mike