Subject: Implementations of iCalendar and ICAP

From: Mark Tearle <[email-masked]>
Date: Wed, 9 Dec 1998 16:23:15 +0800 (WST)

Hi

I was wondering what reference implementations of vCard, iCalendar
and ICAP are out there?  

I haven't spotted anything yet that suits my need
(unix command line/curses interface)

Yours
Mark
-- 
Mark Tearle - [email-masked]

"There is a boundary to men's passions when they act from feelings;
   but none when they are under the influence of imagination." - Edmund Burke

---

From: Geir Egil Myhre <[email-masked]>
Date: Fri, 11 Dec 1998 10:14:52 +0100

The Distributed Systems group at the University of Tromsoe, Norway, is 
working on an implementation of iCal as part of a larger project called GDD 
(The Global Distributed Diary). The projects' main scientific goals are:

   1.Address and devise solutions to the data consistency problems that 
arise when small, personal, variably
     connected mobile machines are integrated into an infrastructure for 
data sharing dominated by stationary,
     well connected computers.
   2.Devise a distributed application (a distributed diary), along with 
appropriate system support (which
     includes security), that handles consistent read/write sharing of 
replicated data between a large set of
     heterogeneous, variably connected computers.

Our method is based on an implementation of iCal and CAP augmented with 
enchancements adressing issues arising from the variably connected state, 
and resource weakness, of the computers running Calendar User Agents. Our 
platform is FreeBSD and PalmPilot.

All source will be made freely available as soon as we have a beta up and 
running - expected around march'99.

I would be very interested in hearing from anyone who might be interested 
in our work, which is described in some more detail at 
http://gunnarnt.cs.uit.no/gdd/ , please contect me at [email-masked]

Geir Egil Myhre
[email-masked]

|-----Original Message-----
|From:	Pete O'Leary [SMTP:[email-masked]]
|Sent:	Thursday, December 10, 1998 9:04 PM
|To:	[email-masked]
|Subject:	RE: Implementations of iCalendar and ICAP
|
|Andre is correct.
|
|Does anyone know of any free/open-source implementations of iCalendar that
|are available or in the works?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Andre Courtemanche
> Sent: Wednesday, December 09, 1998 11:51 AM
> To: 'Mark Tearle'; [email-masked]
> Subject: RE: Implementations of iCalendar and ICAP
>
>
>
> Mark,
>
> I don't know about vCard but iCalendar will be tested
> amongst suppliers in January.
>
> ICAP is not an internet standards but is a private
> proposal from Pete O'leary.
>
>
> -----Original Message-----
> From: Mark Tearle [mailto:[email-masked]]
> Sent: Wednesday, December 09, 1998 3:23 AM
> To: [email-masked]
> Subject: Implementations of iCalendar and ICAP
>
>
> Hi
>