Subject: Subcalendars and inherited content

From: John Stracke <[email-masked]>
Date: Mon, 15 Mar 1999 22:26:54 +0000

A CAP issue raised in the WG meeting today: does a parent calendar
inherit the contents of its subcalendars? The current answer is no; it
was pointed out that this may complicate the CUAs, because they have to
descend down through the tree.  (The CUA can request data from multiple
calendars at once; but it apparently has to descend the tree to know
which calendars to request.)

A couple of possibilities that occur to me:

   * Provide a way to do a deep request on a calendar, one which
     descends down the tree to get all the data.
   * Provide a way to request the tree structure (listing all the
     calendars and the relationships among them), after which the CUA
     comes back and asks for the data from the calendars.  This has the
     advantage that the CUA can pick and choose which calendars it wants
     (much as an IMAP or NNTP client can decide which folders/newsgroups
     it's interested in).

--
/=============================================================\
|John Stracke    | My opinions are my own | S/MIME & HTML OK  |
[email-masked]|============================================|
|Chief Scientist | NT's lack of reliability is only surpassed |
|eCal Corp.      |  by its lack of scalability. -- John Kirch |
\=============================================================/

---

From: [email-masked]
Date: Tue, 16 Mar 1999 17:39:30 -0500

John,

About your comment

[...]
		* Provide a way to do a deep request on a calendar, one
which
		     descends down the tree to get all the data.
[...]

I completely agree with you. It should be available in protocol to allow
the server to perform "Deep searches". This, in fact, would provide you 
with to easily implement "Calendar Data Inheritance" without too much
difficulty.

		-----Original Message-----
		From:	John Stracke [mailto:[email-masked]]
		Sent:	Monday, March 15, 1999 5:27 PM
		To:	calsch WG
		Subject:	Subcalendars and inherited content

		A CAP issue raised in the WG meeting today: does a parent
calendar
		inherit the contents of its subcalendars? The current answer
is no; it
		was pointed out that this may complicate the CUAs, because
they have to
		descend down through the tree.  (The CUA can request data
from multiple
		calendars at once; but it apparently has to descend the tree
to know
		which calendars to request.)

		   * Provide a way to do a deep request on a calendar, one
which
		     descends down the tree to get all the data.
		   * Provide a way to request the tree structure (listing
all the
		     calendars and the relationships among them), after
which the CUA
		     comes back and asks for the data from the calendars.
This has the
		     advantage that the CUA can pick and choose which
calendars it wants
		     (much as an IMAP or NNTP client can decide which
folders/newsgroups
		     it's interested in).

		--
	
/=============================================================\
		|John Stracke    | My opinions are my own | S/MIME & HTML OK
|
	
[email-masked]|============================================|
		|Chief Scientist | NT's lack of reliability is only
surpassed |
		|eCal Corp.      |  by its lack of scalability. -- John
Kirch |

---

From: [email-masked]
Date: Wed, 17 Mar 1999 12:14:50 -0500

John, I agree with Andre and Frank that this is a super idea.  We would
really appreciate a draft of your idea that we can possibly incorporate in
our document.  That would be very good indeed.

"Frank Dawson" <[email-masked]> on 03/16/99 06:36:20 PM

 To:      "John Stracke" <[email-masked]>, "calsch WG"      
          <[email-masked]>                             
                                                              
 cc:      (bcc: Pat R Egen/Egen Consulting/01)                

 Subject: Re: Subcalendars and inherited content              

On Tuesday, March 16, 1999 11:32 AM, John Stracke wrote, in part:
<snip>

>A couple of possibilities that occur to me:

<snip>

>     comes back and asks for the data from the calendars.

<snip>

This should be an easy "macro" function to create out of the current VQUERY
capability we have been discussing. Not a bad idea, John! Can you craft a
proposal for this? I would want to look up, down and across a tree given a
particular CalUID. Should we also have a "macro" function to return any
relationships between calendar components?

- - Frank

---

From: [email-masked]
Date: Wed, 17 Mar 1999 12:16:10 -0500

<snip>

<snip>

- - Frank

---

From: Doug Royer <[email-masked]>
Date: Thu, 18 Mar 1999 17:17:25 -0800 (PST)

> Date: Mon, 15 Mar 1999 22:26:54 +0000
> From: John Stracke <[email-masked]>
> 

If you assume that everyone wants that model. I think CAP allows
for you model and models that wish to hide the hierarchy externally
and not internally.

>      descends down the tree to get all the data.

Subject to access control. Any calendars for which you do not have any
read access must be hidden.

>      (much as an IMAP or NNTP client can decide which folders/newsgroups

As above.