Subject: RE: CAP Example READ-1

From: "Tony Small (Exchange)" <[email-masked]>
Date: Thu, 18 Mar 1999 17:32:39 -0800

Can we define what is meant in this example by MAXSIZE?  Is this the size of
all the items retrived or is this the maximum size of any single item?

Tony

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 17, 1999 9:24 AM
To: CalSched IETF
Subject: CAP Example READ-1

Example READ-1

This example shows how the READ command can be used to read events in a
particular time range from multiple calendars.

C: 10 READ VEVENT relcal2 ://bobo.ex.com/relcal3
S: 10 2.0 cap://cal.example.com/relcal2
S: 10 2.2 cap://bobo.ex.com/relcal3
C: 10 SENDDATA
S: 10 2.0.1
C: CONTENT-TYPE: text/calendar; method=read; component=VCOMMAND
C:
C: BEGIN:VCALENDAR
C: VERSION:2.1
C: METHOD:READ
C: BEGIN:VCOMMAND
C: BEGIN:VQUERY
C: MAXRESULTS:20
C: MAXSIZE:17000000
C: QUERYNAME:MyViewRange
C: QUERY:SELECT (DTSTART,DTEND,SUMMARY,UID);
C:   FROM VEVENT;
C:   WHERE (DTEND >= 19990310T080000Z AND DTSTART <= 19990310T190000Z);
C:   ORDERBY (DTSTART ASC, DTEND, UID, SUMMARY)
C: END:VQUERY
C: END:VCOMMAND
C: END:VCALENDAR
C: .
S: 10 2.0 cap://cal.example.com/relcal2
S: Content-type: text/calendar; Method=RESPONSE; Component=VDATA;
Optinfo=VERSION 2.1
S: Content-Transfer-Encoding: 7bit
S:
S: BEGIN:VCALENDAR
S: VERSION:2.1
S: METHOD:RESPONSE
S: BEGIN:VDATA
S: BEGIN:VEVENT
S: DTSTART:19990310T090000Z
S: DTEND:19990310T100000Z
S: UID:1234
S: SUMMARY:Big time meeting
S: END:VEVENT
S: BEGIN:VEVENT
S: DTSTART:19990310T130000Z
S: DTEND:19990310T133000Z
S: UID:5678
S: SUMMARY:small time meeting
S: END:VEVENT
S: END:VDATA
S: END:VCALENDAR
S: .
S: 10 2.0 cap://bobo.ex.com/relcal3
S: Content-type: text/calendar; Method=RESPONSE; Component=VDATA;
Optinfo=VERSION 2.1
S: Content-Transfer-Encoding: 7bit
S:
S: BEGIN:VCALENDAR
S: VERSION:2.1
S: METHOD:RESPONSE
S: BEGIN:VDATA
S: BEGIN:VEVENT
S: DTSTART:19990310T140000Z
S: DTEND:19990310T143000Z
S: UID:1919191
S: SUMMARY:Summer budget meeting
S: END:VEVENT
S: END:VDATA
S: END:VCALENDAR
S: .

---

From: [email-masked] (Steve Mansour)
Date: Thu, 18 Mar 1999 17:52:38 -0800

Right. We need to define this.  Its current meaning is the size of all objects
retrieved. I can certainly see a strong case for making it the max size of a
single object. How do others feel about this?

-Steve

---

From: John Stracke <[email-masked]>
Date: Mon, 29 Mar 1999 19:37:30 +0000

> single object. How do others feel about this?

Do we need both? Maybe MAXITEMSIZE and MAXSETSIZE?

--
/=============================================================\
|John Stracke    | My opinions are my own | S/MIME & HTML OK  |
[email-masked]|============================================|
|Chief Scientist | NT's lack of reliability is only surpassed |
|eCal Corp.      |  by its lack of scalability. -- John Kirch |
\=============================================================/