Subject: Re: SEQUENCE Number

From: [email-masked]
Date: Mon, 26 Jul 1999 15:12:54 GMT

Dan:
Correct. The sequence number applies to any modifications for the whole 
event definition. A change to an initial event definition to, say add (via 
the ADD method) an occurrence, would monotonically increment the sequence 
number. Effectively, the sequence number represents the revision sequence 
for the whole event definition. 
Note: The UID applies to the whole occurrence set (or whole event) also.
Hope this helps. Did you see a problem with this architectural element?
-- Frank

---

From: "Dan Hickman" <[email-masked]>
Date: Mon, 26 Jul 1999 12:51:59 -0500

Frank,
Thanks for the clarification.  I see no problems with this approach.  I had
originally thought there could be a sequence for each occurrence but I think
it makes sense the way it is.  I didn't see it specifically addressed in the
spec but the examples show it fairly well.  I just wanted to be sure.

Thanks,
Dan Hickman
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]
    Sent: Monday, July 26, 1999 10:13 AM
    To: [email-masked]
    Cc: [email-masked]
    Subject: Re: SEQUENCE Number

    Dan:

    -- Frank

---

From: Alexander Taler <[email-masked]>
Date: Mon, 26 Jul 1999 14:02:11 -0400

There are several properties that cannot vary across recurrences, 
perhaps they should be listed in the next rev of iCalendar, Frank.

Off the top of my head:

UID (mentioned below), SEQUENCE, DTSTAMP, ORGANIZER.

and perhaps: LAST-MODIFIED

Alex

Dan Hickman wrote:
> 
> Frank,
> Thanks for the clarification.  I see no problems with this approach.  I had originally thought there could be a sequence for each occurrence but I think it makes sense the way it is.  I didn't see it specifically addressed in the spec but the examples show it fairly well.  I just wanted to be sure.
> 
> Thanks,
> Dan Hickman
> 
>      Correct. The sequence number applies to any modifications for the whole event definition. A change to an initial event definition to, say add (via the ADD method) an occurrence, would monotonically increment the sequence number. Effectively, the sequence number represents the revision sequence for the whole event definition.
>