Subject: Re: Recurrence ID changes?

From: [email-masked]
Date: Tue, 27 Jul 1999 00:21:46 GMT

Alex:
This is improver iCalendar sytax. No "UID", no "SEQUENCE", etc. Maybe you 
weren't trying to be precise?
You can only add events to an existing request with an "ADD" method; not a 
"REQUEST". 
Dan's point was not just the scenario for adding an occurrence, but 
changing some other details in an occurrence so that a single REQUEST 
would actually obliterate the differences. You are right, for this you 
might be able to use a second REQUEST with an incremented "SEQUENCE" value 
and a "RECURRENCE-ID" to show the different property values from the 
original occurrence set. That is, as long as the occurrence was defined in 
the occurrence set defined by the initial "REQUEST".
-- Frank

---

From: Alexander Taler <[email-masked]>
Date: Tue, 27 Jul 1999 12:43:57 -0400

[email-masked] wrote:
> 
> This is improver iCalendar sytax. No "UID", no "SEQUENCE", etc.
> Maybe you weren't trying to be precise?
> 
> You can only add events to an existing request with an "ADD" method;
> not a "REQUEST".
> 
> changing some other details in an occurrence so that a single
> REQUEST would actually obliterate the differences. You are right,
> for this you might be able to use a second REQUEST with an
> incremented "SEQUENCE" value and a "RECURRENCE-ID" to show the
> different property values from the original occurrence set. That is,
> as long as the occurrence was defined in the occurrence set defined
> by the initial "REQUEST".
> 

Frank,

I was replying to what you said here 
(Message-ID: <[email-masked]>):

> That is good! I forgot about this case. This is the case where you 
> send out a REQUEST (SEQUENCE=0), then follow it up with a
> REQUEST (SEQUENCE=1, RECURRENCE-ID=19990726T133000Z) that changes the 
> LOCATION (or some such peripheral property).
> Now you can't just send one REQUEST reply to the REFRESH. The 
> RECURRENCE-ID values specifies one occurrence that will need
> a separate REQUEST to specify the different LOCATION property (or 
> whatever). 

I don't think that you ever need separate REQUESTs to respond to 
a refresh.  The following is valid iTIP, and shows how a single
REQUEST can include instance specific information.  (Each recurrence
has a different location.)  This could be an initial REQUEST
(SEQUENCE:0) or a response to a REFRESH.

BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:bad string
VERSION:2.0

BEGIN:VEVENT
LOCATION:My place
UID:foo
ATTENDEE:mailto:[email-masked]
ORGANIZER:mailto:[email-masked]
DTSTART:19990712T000000Z
DTSTAMP:19990702T000000Z
SUMMARY:Bridge night
END:VEVENT

BEGIN:VEVENT
LOCATION:Martha's place
UID:foo
ATTENDEE:mailto:[email-masked]
ORGANIZER:mailto:[email-masked]
DTSTART:19990719T000000Z
DTSTAMP:19990702T000000Z
SUMMARY:Bridge night
END:VEVENT

BEGIN:VEVENT
LOCATION:Local pub
UID:foo
ATTENDEE:mailto:[email-masked]
ORGANIZER:mailto:[email-masked]
DTSTART:19990726T000000Z
DTSTAMP:19990702T000000Z
SUMMARY:Bridge night
END:VEVENT

END:VCALENDAR

Alex