Subject: CALSCH Action Items

From: [email-masked]
Date: Tue, 27 Jul 1999 14:46:02 -0700

This is a list of action items for the CALSCH Working Group.
This list will be sent out once a week and updated as often
as practical (That means if I am not available it may take
an extra week or two before you see your changes).

Updates should be sent to mailto:[email-masked] or to myself
mailto:[email-masked] .

There are three parts to this action list:

	(W) Working group action items.
	(C) CAP editor action items.
	(I) iCalendar action items (Frank Dawson)

Each action item will be assigned a unique ID that will aid in
tracking the items.

------------------------------------------------------------------------------

			Working Group Action Items   

Where Resolution is one of:

	U - undecided.
	Y - Chair determined consensus is in favor of the proposal.
	N - Chair determined consensus is NOT in favor of the proposal.
	D - Dropped. Chair has decided that it may never reach consensus.

 The following are a list of proposals and their status in the WG:
 
 WG Action Item					Resolution
 --------------					----------

 W-1 CAP Use HTTP as transport			N
 
 W-2 CAP If all booked and scheduled		U
     appointments are in same table
 
 W-3 CAP Use SASL as authentication method	Y
 
 W-4 Add UID and COUNTER to VFREEBUSY		U 

 W-5 CAP Should CAPABILITY reply be sent	U
     as result of successful AUTHENTICATE
     and IDENTITY 

 W-6 Do we need a scheduled type of
     event as described by the SKI project?	U
     (VTENTATIVE)

 W-7 CAP Auto-logout Timer issues		U
      Do we need one?
      How long?
      Can the server decide not to do this?
  
 W-8 CAP Bounded Latency Issues			U
     <there were issues - I can't remember
     them>

 W-9 CAP MOVE method. Issues with VCARs.	U
     [see note in CAP 7.2.1.5]
 
 W-10 CAP Text mandatory in all response	N
      codes
 
 W-11 CAP Text optional in response codes	Y
      (some response codes may have 
       mandatory data that follows)
       
 W-12 CAP Should parts of response code be	Y
      separated by ';'
      
 W-13 CAP Store Schema				U
 
 W-14 CAP VEVENT Schema				U
 
 W-15 CAP VTODO Schema				U
 
 W-16 CAP VJOURNAL Schema			U
 
 W-17 CAP VCAR Schema				U

------------------------------------------------------------------------------

 The following are a list of action items for the CAP draft editors:
 
 Draft Action Item				Who	Done (Y/N)
 -----------------				---	----------
	
 C-1 Remove unused definitions				N

 C-2 Fix up changes in authentication		Alex	N
     text as commented on the list		Paul

 C-3 Text for 2.7 [Finding CAP Servers]		Doug	N
 
 C-4 VCAR examples				Doug?	N
 
 C-5 PUBLISH text
 
 C-6 REQUEST text
 
 C-7 REPLY text

 C-8 ADD text
 
 C-9 CANCEL text 
 
 C-10 REFRESH text
 
 C-11 COUNTER text
 
 C-12 DECLINECOUNTER Text

------------------------------------------------------------------------------

 The following are a list of action items for the iCalendar-2 draft editors:
 
 Draft Action Item				Who	Done (Y/N)
 -----------------				---	----------

 I-1 MIME alternate/related			Frank	?
     MUST be supported.

 I-2 Remove ordering of properties and		Frank	?
     parameters in draft.

------------------------------------------------------------------------------

Updates should be sent to mailto:[email-masked] or to myself
mailto:[email-masked]

-Doug
-------------------------------------------------------------------
[email-masked]		http://playground.sun.com/~dougr
Pager:				[email-masked]
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL

---

From: Alexander Taler <[email-masked]>
Date: Tue, 27 Jul 1999 19:09:25 -0400

Right on Doug!  This is exactly what we need.

Doug, how about adding the date of a resolution, so that
in case of disagreement we have a starting point for 
searching the mailing list.

How about we all use these ID's in the subjects of our
mail, to help the tracking of open issues.

Alex

---

From: [email-masked] (Richard Shusterman)
Date: Wed, 28 Jul 1999 11:18:57 -0700

Doug,

You should probably break up draft action item C-2 "Fix up changes in
authentication text as commented on the list" into multiple items since it's
fairly large. Specifically, I've already asked the editors for changes or
additions in the following areas of authentication:

   * UPN definition, including anonymous user and how UPN's are used in LDAP and
     certificates.
   * Group definitions, dynamic and static, and how groups are used in VCARs.
   * Policy definitions, in a VCAR format.

Also, add another action item for the CAP draft editors:

   * Redo state diagram to include STARTTLS and IDENTIFY command.

Also, add another action item for the iCalendar-2 draft editors:

   * Associating UPN values with CREATED and LAST-MODIFIED properties.

There's also been some discussion (not on the list) about how to incorporate
retrieval of Calendar User properties using CAP. This would not be a full blown
directory lookup but something simple and limited that could be used by CUA's to
get/set some information about their Calendar User from the Calendar Service,
e.g., their first/last name and CALID. This might also be a good place to tie CAP
into the URI's that are described by the draft-ietf-calsch-locating document. I'm
mentioning this topic here since there's probably action item(s) that need to be
associated with this discussion/work.

Richard