Subject: Re: CAP Capabilities

From: Doug Royer <[email-masked]>
Date: Mon, 19 Jul 1999 16:18:53 -0700 (PDT)

> Date: Mon, 19 Jul 1999 15:11:05 -0700
> From: [email-masked] (Steve Mansour)
> 
> >
> > > What do people think of this?  Any other options to consider?
> >
> > I don't see a conflict.
> >
> > Commands replies have 2 parts, the protocol reply, and optional
> > application reply:
> >
> >         CUA: AUTHENTICATE .....
> >         CS:  2.0 <or what ever is a valid reply>
> >         CS:  <MIME OBJECT>
> >         CS:  BEGIN: ...
> >         CS:  ...
> >         CS:  END: ...
> >
> > The 2.0 is the protocol reply, the MIME object that contains a
> > BEGIN ... END is the optional application reply.
> >
> > Other commands have application data, that's the point of sending
> > a command. Correct?
> 
> Right.
> 
> The concern was that in response to a transport command, we're returning both
> transport data as well as application data.

Yes - the transport command is AUTHENTICATE or SENDDATA, what's the
difference? Both return application data. I see this as consistency.

-Doug
-------------------------------------------------------------------
[email-masked]		http://playground.sun.com/~dougr
Pager:				[email-masked]
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL

---

From: [email-masked] (Steve Mansour)
Date: Mon, 19 Jul 1999 18:13:25 -0700

> > >         CS:  2.0 <or what ever is a valid reply>

this will be multi-lined if we return transport level capabilities

> difference? Both return application data. I see this as consistency.

sounds good.

The transport level response would be multi-line here, and so would the application
level response. We don't have a syntax for that yet. I suppose it shouldn't be too
bad to come up with something.

-Steve

---

From: Alexander Taler <[email-masked]>
Date: Thu, 22 Jul 1999 13:51:14 -0400

> difference? Both return application data. I see this as consistency.

When you issue a SENDDATA you send application level data with it. 
The application level data returned is in response to that.  When you
authenticate you are sending no application level data, so if you get
some back it is unsolicited at the application layer.  

Do we want to allow the receipt of unsolicited data?

Alex