Subject: RE: XML iCal draft changes

From: "Eric R. Plamondon" <[email-masked]>
Date: Fri, 26 Oct 2001 07:34:23 -0400

Good Morning,

I believe it's important to keep the naming 
differences between iCal and xCal to a minimum.
Changing propery and parameter names between 
iCal and xCal, from a coding perspective has 
relatively little impact (it's just code...), 
but will only provide a point of confusion for 
those people trying to adopt it. The base 
specification is the iCalendar one.

As for the issue of case, I'm for mixed case,
to ease readability. No reason, other than a 
style preference (even though it conflicts with
my statement about remaining consistant with 
iCal).

The MIME types outlined so far are
	application/calendar+xml
	application/icalendar+xml
	application/xcal+xml
	text/xcal+xml
I still prefer application/calendar+xml, since it
is closer to the iCal MIME type of text/calendar. However
any of then are acceptable. Can anyone think of 
a reason to discount either of these?

With respect to the DTD / Schema issue, it really
looks like there is interest for both.

Eric

-------------------------------
Eric R. Plamondon
Steltor - Chief Web Architect
2000 Peel Street, 4th Floor
Montreal, Quebec
mailto:[email-masked]
http://www.steltor.com

---

From: Doug Royer <[email-masked]>
Date: Fri, 26 Oct 2001 15:51:25 -0600

> specification is the iCalendar one.

I am hoping to send both xCal and vCard/XML to small memory
devices - I am in favor of short names.
these?
> looks like there is interest for both.

I think we should look into Schema, but if that takes too long
or would slow the process down, I am happy with DTDs.

---

From: "Eric R. Plamondon" <[email-masked]>
Date: Sat, 27 Oct 2001 11:22:23 -0400

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Doug Royer
> Sent: Friday, October 26, 2001 5:51 PM
> To: [email-masked]
> Subject: Re: XML iCal draft changes
> 
> 
> 
> 
> devices - I am in favor of short names. these?

What about using a WBXML encoding of the xCal/xCard proposed
specifications, this would greatly reduce the size of data
sent.

Eric