Subject: VCAR: CARREF rule part

From: Bernard Desruisseaux <[email-masked]>
Date: Fri, 21 Dec 2001 12:58:59 -0500

The CARREF rule parts specifies a reference to a
particular "VCAR" calendar components in the CS.

I don't understand why CARREF is a rule part of
a RIGHTS value type and not a property of a VCAR
component.  It would make sense for a VCAR to be
defined in terms of another VCAR but not for a
RIGHTS to be defined in terms of a VCAR.

What would be the difference between specifying
CARREF in the GRANT property versus in the DENY
property?

Which UPN should be considered when a RIGHTS value
type that has both a UPN rule part and a CARREF rule
part makes reference to a VCAR that has RIGHTS value
types with specific UPNs?

I propopose that we make CARREF a property of VCAR
components instead of a rule part of the RIGHTS
value type.

That is, we would now have:

   BEGIN:VCAR
   CARREF=[email-masked]
   ...
   END:VCAR

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Fri, 21 Dec 2001 13:00:48 -0700

> CARREF in the GRANT property versus in the DENY

Because you are not statically binding VCARS and they
can be changed out from under you. The chain of
events could be a mess for the CUA.

> types with specific UPNs?

You have a GRANT for the operation or not.
If you have a GRANT you can do it.

> components instead of a rule part of the RIGHTS

I propose NO CARREF.

I say we do NOT have a CARREF static.
You do NOT have to build on other VCARs.
You simply have access or not.

You proposing that each update to any VCAR that MIGHT have
a CARREF to it, in effect update all VCARS? What if you don't have
access to them? CARREF is placing inheritance inside of inheritance.
We don't need that. PLUS now  we have to have circular detection
in VCARS (a->b->c->a).

---

From: Bernard Desruisseaux <[email-masked]>
Date: Mon, 24 Dec 2001 09:49:36 -0500

> I propose NO CARREF.

I agree.  I never understood why they were
introduced 3 years ago!

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Recherche et développement              Tél.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878