Subject: Re: Question on calstore current time.

From: "John Stracke" <[email-masked]>
Date: Wed, 19 Dec 2001 10:33:00 -0500

>What if I want it to go to the CUA that I am connected with?
>And not a specific CUA? As in if ANY CUA is connected, then
>the CUA will send the alarm, else the CS  sends it.

I think there are problems with that.

The big one: Suppose the clocks on the CUA and the CS are not in 
sync--say, the CS's clock is 1 minute ahead of the CUA's.  I have an alarm 
set for 2:00.  At 1:59:30, CS time (1:58:30, CUA time), the CUA connects. 
At 2:00:00, CS time (1:59:00, CUA time), the CS decides it doesn't need to 
send an alarm.  At 2:00:10, CS time (1:59:10, CUA time), the CUA 
disconnects and exits.  At 2:00:00, CUA time, the CUA is not running, so 
it doesn't send an alarm.  The alarm is lost.

In addition, there are a couple of scenarios involving CUAs that don't fit 
the mold of a long-lived app with a continual connection to the CS.  For 
example, you might have a daemon syncing your calendar down to a desktop 
PIM; it's got no UI at all, and shouldn't be sending alarms.  Or you might 
have a Web-based app that makes transient connections to the CS; the only 
way for it to handle alarms would be if it queried the CS for them on 
every single page view.

/=======================================================\
|John Stracke                   |Principal Engineer     |
[email-masked]  |Incentive Systems, Inc.|
|http://www.incentivesystems.com|My opinions are my own.|
|=======================================================|
|Unless. -- The Lorax                                   |
\=======================================================/

---

From: Doug Royer <[email-masked]>
Date: Wed, 19 Dec 2001 14:12:30 -0700

> I think there are problems with that.

Yep.

> it doesn't send an alarm.  The alarm is lost.

Yep. The same problem exists if several CUA's are connected and
you only want one to send the alarm.

> way for it to handle alarms would be if it queried the CS for them on

We need MUCH more work on the alarms. I don't think this should
slow down or stop CAP. But it is unresolved.

-Doug

---

From: "Shannon J. Clark" <[email-masked]>
Date: Wed, 19 Dec 2001 15:51:22 -0600

Just a thought along these lines:

First - how do vendors CURRENTLY handle alarms - i.e. can the vendors here
each speak up and explain how they handle it today... interoperability etc
will be greatly eased if we set a standard that is not too distant from
current practices.

Second - fundamentally what are the REQUIREMENTS around alarms? Are ALL
alarms a user-centric condition - i.e. each attendee for a given event might
want DIFFERENT alarm conditions (including no alarm at all) - if this is the
case - do they belong in CAP at all?

Shannon

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Doug Royer
Sent: Wednesday, December 19, 2001 3:12 PM
To: [email-masked]
Subject: Re: Question on calstore current time.

Yep.

-Doug

---

From: "Marshall T. Rose" <[email-masked]>
Date: Wed, 19 Dec 2001 13:58:01 -0800

hi. can any author of either the cap or guide documents please reply to this
note? i've tried sending you some email with some formatting comments, but
it bounces.

thanks,

/mtr

---

From: Doug Royer <[email-masked]>
Date: Wed, 19 Dec 2001 16:27:57 -0700

> will be greatly eased if we set a standard that is not too distant from

There are no standard current practices. When I was working at Sun
one of the most common bugs filed was 'The alarms do not work'. Only
to find out that the CUA was not connected or was not running
at the time of the alarm. People expect them to work. It is not
clear what that is.

Some CS's (yahoo and hotmail for example), only send alarms from
their calendar servers - the CUA's never send the alarms.

I don't know what AOL does.

There is no one way to do it.

> Second - fundamentally what are the REQUIREMENTS around alarms?
> Are ALL alarms a user-centric condition - i.e. each attendee
> for a given event might want DIFFERENT alarm conditions (including
> no alarm at all) - if this is the case - do they belong in CAP
> at all?

I think that the CALSCH WG needs to address the issues. CAP is 
the calendar access protocol for iCalendar - they are in iCalendar
so this WG needs to figure it out. And as there does not seem
to be a standard or even common way to handle this, we need to
look at why there are different methods:

	(1) Web based CUA's can't send alarms if they are
	    html clients only because calendaring is not
	    (and should not be) built into html. (Why am
	    I limited to email alarms only?)

	(2) Some CS's can't send alarms because they may be
	    roaming systems. So they could only queue the alarm
	    when not connected to the net. (My CUA had the
	    alarm in it - why did I not get the alarm?)

	(3) Some implementations ONLY send alarms from the CUA.
            These seem to be intra-net systems where it is assumed
	    both the CUA and CS are on the same local domain and
	    connected most or all of the time. (The CS had the
	    alarm - and it did not go to me, that's why I put
	    the stupid alarm in the CS).

Notification of sporting events that you have signed up for.
They are not going to wait around for the CU to login with a
CUA. The reason these alarms exist is to notify users of
things when they don't know when they are occurring, or when
the CUA should connect just to process alarms. In addition these
CS's may not want everyone polling them for alarms or staying
connected 24x7 just to see when the NFL schedule is updated.

I think these variations exist because there is no standard
way to exchange alarm information. We have standardized on
a way to specify what alarm we want (the VALARM). Now we
need to standardize on a way to exchange the importance of
getting the alarm processed and sent on time.

We need to acknowledge that having all alarms processed
at one end or the other may not always work. 

I don't know the answer yet - but ignoring this issue for very
long is going to cause interoperability issues.

---

From: [email-masked] (Steve Mansour)
Date: Wed, 19 Dec 2001 17:01:11 -0800

> note? i've tried sending you some email with some formatting comments, but

Hi Marshall,  what's up?

-Steve