Subject: Re: Editors notes in CAP

From: Bernard Desruisseaux <[email-masked]>
Date: Fri, 01 Feb 2002 11:55:00 -0500

Doug Royer wrote:
> 
> No - It means that if you don't have DELETE on the old
>      location, and WRITE on the new location PLUS the MOVE
>      permission (that I was defining) - you can't move.

That's different from your previous proposal :

>       The MOVE permission means you have WRITE permission
>        on the TARGET calendar and DELETE permission
>        on the OLD-TARGET calendar. And the permissions do
>        not need to be reciprocal.

Regarding your last proposal:

1- On which location would you need the MOVE permission?

2- You would still need READ permission on the old location.

3- It doesn't buy us anything to have an MOVE permission.
   If the user as READ and DELETE granted for the old location
   and WRITE granted for the new location he'll still be able
   to do "search", "create" and "delete" to move the object
   the hard way.   

Can you agree that we don't need a MOVE permission?

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Fri, 01 Feb 2002 11:33:41 -0700

>    to do "search", "create" and "delete" to move the object

Yes - you are right.

But after thinking about it more, I think we are both off the mark.

I think the the real definition is:

 You need to be able to add a new instance of the RELATED-TO property
 to the new location. You would do that with a MODIFY. It is a
 MODIFY because there may already be instances of RELATED-TO in
 the new location. So you have to MODIFY the new location to also
 contain the new RELATED-TO calid.

 You need MODIFY permission in order to remove an instance of
 RELATED-TO from the old location. You don't DELETE the RELATED-TO
 from the old location because there may be multiple instances
 that your are not removing.  So you have to MODIFY the VAGENDA so
 it no longer contains that specific instance.

So I don't think that READ or WRITE permission is what you need.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Fri, 01 Feb 2002 14:07:51 -0500

>  it no longer contains that specific instance.

This is not an issue.

This WG has agreed to drop hierarchial calendars and
fanout is out of scope.

Since all VAGENDA MUST be stored under CALSTORE where
would you want to move them?

> So I don't think that READ or WRITE permission is what you need.

For components that can be moved across targets (i.e.,
VAGENDA and CALSTORE) I need READ and DELETE for the
old location and WRITE for the new location.

We don't need a MOVE permission, and we don't need the
MODIFY permission to be granted on either the old or the
new location to be allowed to move components across
targets (i.e., VAGENDA and CALSTORE).

Agreed?

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Fri, 01 Feb 2002 15:00:30 -0700

> This WG has agreed to drop hierarchial calendars and

This has NOTHING to do with fanout. And I thought you wanted
to MOVE calendars by altering their RELATED-TO properties?

> would you want to move them?

Are you proposing we delete MOVE of calendars?
I thought that was your entire argument, what is a MOVE?

> targets (i.e., VAGENDA and CALSTORE).

If you still want to MOVE a calendar, you MUST modify
the properties in the CS - true?

---

From: Bernard Desruisseaux <[email-masked]>
Date: Fri, 01 Feb 2002 17:30:37 -0500

> to MOVE calendars by altering their RELATED-TO properties?

Not at all.

> Are you proposing we delete MOVE of calendars?

I don't have to.  You already agreed that removing
hierarchical calendars would break MOVE of VAGENDAs.

In http://www.imc.org/ietf-calendar/mail-archive/msg02812.html :

     Doug Royer wrote:
     > 
     > Patrice Lapierre wrote:
     > >
     > >  1) "move" of VAGENDA no longer make sense.
     > 
     > I agree - it would break that.
    
> I thought that was your entire argument, what is a MOVE?

Not at all.

> the properties in the CS - true?

If you want to modify the RELATED-TO property of a VAGENDA
you must have the permission "MODIFY" and you must use the
"modify" command.

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Fri, 01 Feb 2002 15:59:47 -0700

> hierarchical calendars would break MOVE of VAGENDAs.

I think we then agree.
I'll re-read your email as I thought it applied to moving
caledars.