Subject: RFC 2445 Big ABNF fauxpau

From: [email-masked]
Date: Wed, 27 Feb 2002 14:45:10 -0500

I wonder how the heck this got past EVERYONE but it seems we reused a name 
in 2 places in the ABNF and they are not interchangable.  Anyone got any 
guesses what property parameter defintions Im talking about?...

We accidentally used attparam for both ATTACH and ATTENDEE to be the their 
respective property parameter definitions:

     attach     = "ATTACH" attparam ":" uri  CRLF

     attach     =/ "ATTACH" attparam ";" "ENCODING" "=" "BASE64"
                   ";" "VALUE" "=" "BINARY" ":" binary

     attparam   = *(

                ; the following is optional,
                ; but MUST NOT occur more than once

                (";" fmttypeparam) /

                ; the following is optional,
                ; and MAY occur more than once

                (";" xparam)

                )

and

     attendee   = "ATTENDEE" attparam ":" cal-address CRLF

     attparam   = *(

                ; the following are optional,
                ; but MUST NOT occur more than once

                (";" cutypeparam) / (";"memberparam) /
                (";" roleparam) / (";" partstatparam) /
                (";" rsvpparam) / (";" deltoparam) /
                (";" delfromparam) / (";" sentbyparam) /
                (";"cnparam) / (";" dirparam) /
                (";" languageparam) /

                ; the following is optional,
                ; and MAY occur more than once

                (";" xparam)

                )

This MUST get fixed when we update 2445!  %^|

I propose that we change attparam on ATTACH to be attachparam and we leave 
attparam on ATTENDEE as is.  If there is any sentiment to change that to 
attendeeparam then that works for me too. 

Thoughts??

Shannon:  Can you please chalk this one up on the To Do list for 2445 so 
we dont forget it?? 

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: George Babics <[email-masked]>
Date: Wed, 27 Feb 2002 14:59:25 -0500

[email-masked] wrote:
> 
> I wonder how the heck this got past EVERYONE but it seems we reused a name in 2 places in the ABNF and they are not interchangable.  Anyone got any guesses what property parameter defintions Im
> talking about?...
> 
> We accidentally used attparam for both ATTACH and ATTENDEE to be the their respective property parameter definitions:
> 
> I propose that we change attparam on ATTACH to be attachparam and we leave attparam on ATTENDEE as is.  If there is any sentiment to change that to attendeeparam then that works for me too.

  I agree. Furthermore, either attparam or attendeeparam on ATTENDEE are fine with me.

> 
> Thoughts??
> 
> Shannon:  Can you please chalk this one up on the To Do list for 2445 so we dont forget it??
> 
> Bruce
> Bruce Kahn                                INet: [email-masked]

George

---

From: Dan Winship <[email-masked]>
Date: 27 Feb 2002 15:26:01 -0500

On Wed, 2002-02-27 at 14:45, [email-masked] wrote:
> in 2 places in the ABNF and they are not interchangable.

Someone on the IMAP list mentioned an ABNF validator a while back:
http://www.washington.edu/imap/listarch/2001/msg00875.html

(The link to the validator from that message doesn't work right now, but
it might be a temporary problem, or you could try emailing him.)

-- Dan