Subject: Re: RFC-2445: Re: CAP: LANGUAGE parameter

From: [email-masked]
Date: Fri, 1 Feb 2002 14:56:30 -0500

John posited:

>Of course, we should specify that ALT-foo can appear more than once.

We are already covered by the existing ABNF:

                ; the following is optional,
                ; and MAY occur more than once

                (";" xparam)

(Ok, technically we need to have a " (";" ianaparam) " clause but thats a 
known oversight thats to be corrected w/o any real impact on good engines.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Doug Royer <[email-masked]>
Date: Fri, 01 Feb 2002 15:07:35 -0700

[email-masked] wrote:
> (Ok, technically we need to have a " (";" ianaparam) " clause but
> thats a known oversight thats to be corrected w/o any real impact on
> good engines.

No - the debate was over adding new PROPERTIES, your
quote adds parameters.

New properties:

	LOCATION;LANGUAGE=EN_US:IBM in Bruce's office.
	ALT-LOCATION;LANGUAGE=FR_CA: <...in French Canadian...>

I could make it a mess to do that using a parameter with more
than two languages. I don't think we want 2 or more
parameters on the same property with the same parameter name.