Subject: BEEP new : "3.3 Bounded Latency"

From: Doug Royer <[email-masked]>
Date: Sat, 16 Feb 2002 16:28:37 -0700

I propose the example in "3.3 Bounded Latency",
be replaced with (Note, in the *original* examples
the beep 'msgsize' values were often not correct.)
They will be counted exactly in the last call version.

---------------------------------------------------------------------

   C: MSG 1 4 . 2043 284
   C: Content-Type: application/cap+xml
   C:
   C: <search cmdid="xyz12346" latency="3" action="ask">
   C: <![CDATA[
   C: BEGIN:VCALENDAR
   C: METHOD:SEARCH
   C: CMDID:xyz12346
   C: TARGET:opaqueid101
   C: BEGIN:VQUERY
   C: QUERY:SELECT DTSTART,DTEND,SUMMARY,UID FROM VEVENT
   C:  WHERE DTEND >= '19990714T080000Z'
   C:  AND DTSTART <= '19990715T080000Z'
   C: END:VQUERY
   C: END:VCALENDAR
   C: END

   # After 3 seconds

   S: MSG 1 2 . 102 64
   S: Content-Type: application/cap+xml
   S:
   S: <timeout cmdid="xyz12346"/>
   S: END

   If Bill wants to continue and give the server more time he would
   issue a "continue" reply:

   C: RPY 1 2 . 166 86
   C: Content-Type: application/cap+xml
   C:
   C: <continue cmdid="xyz12346" latency="3" action="ask"/>
   C: END

   If Bill wants to abort the command and not wait any further he would
   issue an "abort" reply:

   C: RPY 1 2 . 166 62
   C: Content-Type: application/cap+xml
   C:
   C: <abort id="xyz12346"/>
   C: END

   S: RPY 1 4 . 2723 112
   S:
   S: <request-status code="2.0.3">
   S:   Request Aborted by the CUA.
   S: </request-status>
   S: END

---

From: Gary Frederick <[email-masked]>
Date: Mon, 18 Feb 2002 08:20:44 -0600

Editing comment below

Gary

> They will be counted exactly in the last call version.

C: ]]>
C: </search>

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 21 Feb 2002 15:56:47 -0500

>    C: <search cmdid="xyz12346" latency="3" action="ask">

Per your proposal:
http://www.imc.org/ietf-calendar/mail-archive/msg04538.html

The search command is missing the target attribute.

     C: <search ... target="opaqueid101" ...>

>    C:  AND DTSTART <= '19990715T080000Z'

Missing:  

     C: ]]>
     C: </search>

>    C: END

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 21 Feb 2002 16:28:28 -0500

>    C: <abort id="xyz12346"/>

Change to:

     C: <abort cmdid="xyz12346"/>

>    S:   Request Aborted by the CUA.

The reply should also contain the "cmdid".
How about:

     S: RPY 1 4 . 2723 112
     S:
     S: <result cmdid="xyz12346">
     S:   <request-status code="2.0.3">
     S:     Request Aborted by the CUA.
     S:   </request-status>
     S: </result>
     S: END

Regards,
Bernard