Subject: CAP: Registration of new MIME media type application/cap+xml

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 21 Feb 2002 17:47:14 -0500

We will need to write a registration form for a new
MIME media type application/cap+xml.  This wasn't
required for application/beep+xml, since this media
is already registered in BEEP.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 21 Feb 2002 16:57:54 -0700

> is already registered in BEEP.

Thanks. I still want to re-bring up the point that there
is NO beep requirement that we have a content type
of XML.

In fact I still think we should just use the already
registered type if text/calendar in the BEEP transport
of CAP and include everything in the iCalendar object.

Then the xcal draft can send out the XML stuff and 
describe the BEEP profile.

	MSG  .... 
	Content-Type: text/calendar
	
	<just include iTIP objects>
	END

	MSG ...
	Content-Type: text/calendar

And for non-iTIP objects.

	BEGIN:VCALENDAR
	CMD:CREATE
	CMDID:...
	...
	END:VCALENDAR
	END

Then the xcal draft can send out the XML stuff and 
describe the BEEP + CAP + XML profile.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Fri, 22 Feb 2002 13:56:00 -0500

> of CAP and include everything in the iCalendar object.

Here's what I think are the options:

a) Use application/beep+xml.  No registration required.

b) Use application/cap+xml.  Registration required.

c) Use text/calendar.  No registration required, but will
   require us to change and review all the examples.

I favor (a) as I believe it will help us get a last call
sooner, but I understand that consensus should drive the
schedule and not the other way around.

Cheers,
Bernard