Subject: Re: CAP Consensus: relativeCALID

From: "John Stracke" <[email-masked]>
Date: Fri, 15 Feb 2002 12:42:55 -0500

>      cap://cal.example.com/abcd1234QWER
>      cap:///abcd1234QWER
>      cap:/abcd1234QWER
>      abcd1234QWER
>
>   For a user currently authenticated to the CAP server on
>   cal.example.com, all four addresses refer to the same
>   calendar.

Why would you use anything except the first or fourth? The middle two are 
just longer versions of the fourth; and supporting them takes extra 
complexity.

/========================================================\
|John Stracke                    |Principal Engineer     |
[email-masked]   |Incentive Systems, Inc.|
|http://www.incentivesystems.com |My opinions are my own.|
|========================================================|
|But this one goes to 11x.                               |
\========================================================/

---

From: Bernard Desruisseaux <[email-masked]>
Date: Fri, 15 Feb 2002 13:28:19 -0500

> just longer versions of the fourth; and supporting them takes extra

I didn't claim the 2nd and 3rd forms were useful.
Per RFC 2396, these forms should simply be legal.
That's all.

Now, to address your complexity concerns, I know
that widely used applications have not had much
trouble supporting the following equivalent forms
of file URL.

   file:/etc/passwd
   file:///etc/passwd
   file://localhost/etc/passwd

There are no reasons for CAP URL to be any different.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Fri, 15 Feb 2002 11:34:15 -0700

> just longer versions of the fourth; and supporting them takes extra

I agree with John.

The first is a full CALID.
The last is a relative CALID

But why would you use the 2nd and 3rd?
The only time you can use a rel-CALID is when you are already
connected to a CAP server and authenticated. So 'cap:' is not
needed.