Subject: BEEP - new: 3.2 Use of XML, MIME and iCalendar

From: Doug Royer <[email-masked]>
Date: Sat, 16 Feb 2002 16:13:32 -0700

I am proposing that section "3.2 Use of XML, MIME and iCalendar"
be replaced with:

   C: MSG 1 2 . 432 62
   C: Content-Type: application/cap+xml
   C:
   C: <generate-uid num=10/>
   C: END

   Otherwise, arbitrary MIME content is included in the BEEP payload by
   using CDATA.

   C: MSG 1 3 . 1023 489
   C: Content-Type: application/cap+xml
   C:
   C: <create cmdid="abcd12346">
   C: <![CDATA[
   C: BEGIN:VCALENDAR
   C: METHOD:REQUEST
   C: BEGIN:VEVENT
   C: UID:abcd12345
   C: ORGAGNIZER:cap://cal.example.com/mary-relcalid
   C: ATTENDEE;PARTSTAT=ACCEPTED:cap://cal.example.com/mary-relcalid
   C: ATTENDEE;PARTSTAT=NEEDS-ACTION;RSVP=TRUE:
   C:  cap://cal.example.com/john-relcalid
   C: ATTENDEE;PARTSTAT=NEEDS-ACTION;RSVP=TRUE:
   C:  cap://cal.example.com/bob-relcalid
   C: DTSTART:20010920T180000Z
   C: DTEND:20010920T190000Z
   C: SUMMARY:Mary invites John and Robert
   C: END:VEVENT
   C: END:VCALENDAR
   C: />]]>
   C: </create>

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 21 Feb 2002 14:45:17 -0500

Doug Royer wrote:
> ...

CDATA is not used properly.

C: <![CDATA[
C: ...
C: ]]>

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 21 Feb 2002 13:20:29 -0700

> CDATA is not used properly.

Yep - cut/paste error. I made a temporary file with
sample CDATA in it, they may all have that error.