Subject: Re: CAP: List Of Items (crisp)

From: Doug Royer <[email-masked]>
Date: Fri, 08 Feb 2002 17:49:40 -0700

> George Babics wrote:
>
>  Miscellaneous:
>  ==============
> 
>  - Look at changes required by CAP to make it compatible with CRISP
>   (If we want to support CRISP, then some changes are needed in CAP. In
>   section 7.1.5, CAPVERSION, CAR, and QUERYLEVEL all need to be able to
>   have values of NONE.)
>  Is this compatibility needed? It is not part of the CAP requirements.

(1) CRISP needs to be updated. It is not in sync with CAP (beep).

(2) We need to make sure that QUERYLEVEL and CAPABILITIES
    allow for iana and X-tokens.

    Do we say that if <car>xxx</car> does not exists, then
    the CS does not support ANY VCARs?

    Do we say that if <query-level>xxx</query-level> does not
    exist, then no query is supported on the CS?

(3) It is not clear to me if a CRISP server sends some kind
    of capability specifying the fact it only supports iTIP
    methods. But ether way (2) above should address that issue.

(4) There would have to be some MINIMUM predefined VCAR support
    in a CRISP server, else how would implementations say 
    that UPN-X can make requests, and UPN-Y can not. For example
    I could assume that <create> of an object of METHOD:REQUEST would
    be allowed - to all UPNs?

(5) Would we have to generate some kind of capability that
    specified which components the server supported? Or
    should this be specified in CRISP as a CAP extension?

---

From: "John Stracke" <[email-masked]>
Date: Mon, 11 Feb 2002 17:42:23 -0500

>Sounds good to me. As you are the most interested. Be sure
>to PING us when we do last call if 'none' is not a valid
>querylevel.

OK, will do.

>> latest CAP version to see whether I can say that explicitly, or (as
>> you suggested a month or few ago) just say "I'm CRISP".
>
> get-capabilities returns <CRISP [version="xx"/> ?

Yeah, like that.

>I see your point. But how about defining in CRISP the VCAR
>that allows users to understand what they are being allowed to do?

That makes sense.  It wouldn't be modifiable, but making it expressible 
would help.

>> because a CRISP client has to log in with no credentials, which it
>> would never do in CAP.
>
>Or how about they just authenticate as anonymous?

Sure...but, either way, "send an iTIP message to a server where I don't 
have an account" is a sharp departure from "perform operations on my home 
server", so we don't need to make the interaction models completely 
congruent.  This makes it easier to write CRISP in a way that won't hold 
back CAP.

/========================================================\
|John Stracke                    |Principal Engineer     |
[email-masked]   |Incentive Systems, Inc.|
|http://www.incentivesystems.com |My opinions are my own.|
|========================================================|
|Cogito ergo Spud. (I think, therefore I yam.)           |
\========================================================/