Subject: Re: (#3) 4.1.1 Grammar for Search Mechanism

From: Doug Royer <[email-masked]>
Date: Sun, 03 Feb 2002 11:08:31 -0700

Patrice Lapierre wrote:

>
> 
> >     capselect  = "SELECT" SP cap-cols SP
> 
> Must also support:
> 
>    SELECT VEVENT.VALARM
>    SELECT VEVENT.*
> 
> >                  "FROM"   SP comp-name SP
> 
> comp-name won't accept VEVENT.VALARM.

True but it does not have to do that.

The 'FROM' value is the component that you are selecting from
If you want to get from VALARM, there is no need for VEVENT.VALARM .

	SELECT * FROM VALARM ...

If you just want the VALARMs for VEVENTs:

	SELECT VALARM[.xxx][,...] FROM VEVENT ....

---

From: Patrice Lapierre <[email-masked]>
Date: 04 Feb 2002 08:21:02 -0500

> 	SELECT VALARM[.xxx][,...] FROM VEVENT ....

Then the example 6b from the proposition must be changed.

  Doug Royer wrote:
  > ...
  >  (6) A contained component without a '.' it is the same as
  >      <component>.* with the result being a properly formatted
  >      <component>(s) in the data stream, and correctly formatted
  >      in the contained component(s) in iCalendar (RFC2445) format.
  >
  >        VALID:
  >
  >              (a) SELECT VEVENT.<a-property-name> FROM VEVENT
  >
  >              (b) SELECT VEVENT.VALARM FROM VEVENT
  >