Subject: CAP: Querying VALARM

From: Bernard Desruisseaux <[email-masked]>
Date: Mon, 11 Feb 2002 14:53:36 -0500

What is the proper VQUERY to get the VALARM components
of all the calendar components stored in a VAGENDA?

  BEGIN:VQUERY
  QUERYNAME:Query-1
  QUERY:SELECT * FROM VALARM
  END:VQUERY

  BEGIN:VQUERY
  QUERYNAME:Query-2
  QUERY:SELECT VALARM FROM VTODO
  QUERY:SELECT VALARM FROM VEVENT
  END:VQUERY

I would say (2).  Since (1) should be used to get only
the VALARM components stored directly in the VAGENDA
(which is currently not allowed).

Correct?

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Mon, 11 Feb 2002 14:10:44 -0700

Bernard Desruisseaux wrote:
> I would say (2).

I also agree.

>  Since (1) should be used to get only

We need to add text that says if the QUERY does not specify
then it is from the 'TARGET'. So if the TARGET is the
CALSTORE, then it comes from the CALSTORE, if the TARGET
is the CALID or RELCALID, then it comes from the VAGENDA.

Agree?