Subject: CAP: Searching iTIP objects

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 14 Feb 2002 17:37:45 -0500

Assuming Mary submits the following iCalendar object
in Bob's calendar:

   BEGIN:VCALENDAR
*  METHOD:ADD
   PRODID:-//ACME/CAPserver//EN
   VERSION:2.0
   BEGIN:VEVENT
   DTSTART:20000218T160000Z
   DTEND:20000218T170000Z
   SUMMARY:Press Conference
   UID:123
   SEQUENCE:1
   ORGANIZER:cap://cal.example.com/mary-relcalid
   ATTENDEE;RSVP=FALSE:cap://cal.example.com/bob-relcalid
   END:VEVENT
   END:VCALENDAR

a) Which VQUERY component will allow Bob to find
   this iCalendar object in his calendar?

   My guess:

   BEGIN:VQUERY
   QUERYNAME:Query-01
   QUERY:SELECT * FROM VEVENT
    WHERE METHOD = 'ADD'
   END:VQUERY

   Without EXPAND:TRUE that is.

b) How will the returned VEVENT component look like?

   My guess:

   BEGIN:VCALENDAR
   PRODID:-//ACME/CAPserver//EN
   VERSION:2.0
   BEGIN:VEVENT
*  METHOD:ADD
   DTSTART:20000218T160000Z
   DTEND:20000218T170000Z
   SUMMARY:Press Conference
   UID:123
   SEQUENCE:1
   ORGANIZER:cap://cal.example.com/mary-relcalid
   ATTENDEE;RSVP=FALSE:cap://cal.example.com/bob-relcalid
   END:VEVENT
   END:VCALENDAR

c) Does the EXPAND property influence the selection
   mechanism of iTIP objects?

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: [email-masked]
Date: Fri, 22 Feb 2002 12:09:45 -0500

> Assuming Mary submits the following iCalendar object

Well, you use iTIP in your subject line but your (snipped) example is CAP, 
NOT iTIP so the rest this may not be exactly what you want to hear...

>    this iCalendar object in his calendar?

would be incorrect since you are searching for any VEVENTs that have 
METHOD:ADD in them but your CAP example had NO METHOD property in the 
VEVENT so your search would NOT find it. 

Had the original entry been in iTIP format instead of CAP then it would 
still be wrong.  That is, no METHOD:ADD in the VCALENDAR and _certainly_ 
NOT a METHOD:ADD inside the VEVENT as that is adding an instance to the 
repeat set; presumably you would search for METHOD:REQUEST inside the 
VEVENT.

> b) How will the returned VEVENT component look like?

is again incorrect because someone (presumably the CS??) added a 
METHOD:ADD to the VEVENT and as stated before that would be defintely 
wrong for 2 reasons.  The first is that ADD is for changing repeat sets 
(not in your example) and secondly that the CS is modifying the data that 
it was given for some unknown reason...

I suggest you need rework your example and then we can see what the answer 
will be...

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...