Subject: VQUERY - registration only

From: Doug Royer <[email-masked]>
Date: Sat, 16 Feb 2002 16:01:24 -0700

As both the CAP BEEP commands and the VQUERY examples are mixed
together. I am going to send them out together.

Here is the proposed text for the VQUERY component.

(Examples in separate email).

-------------------------------------------------------------------------

x.x.x.1 "VQUERY component type"

     To: [email-masked]

     Subject: Registration of text/calendar MIME component - VQUERY

     Component name: VQUERY

     Property purpose: A component used to contain query information.

     Conformance: Can be specified in an iCalendar object.

     Description: This component is used as the container that can
     hold a query designed to be used by a CUA or a CS.

     Format definition:
	
     NOTE: Properties in iCalendar objects can be in any order. This
ABNF
           below specifies the valid contents of a BEGIN/END VQUERY. The
           ordering of the properties is not important. Any two VQUERY
           components that contain exactly the same properties in any
	   random order are equivalent. The same is true for parameters,
           that is any two properties that contain exactly the same
           parameters in any random order are equivalent.

	search     = "BEGIN:VQUERY" CRLF
                     0*1expand *(x-prop) query
                     "END:VQUERY" CRLF

                     ; If not provided, EXPAND defaults to FALSE

        expand     = "EXPAND" *(";" xparam) ":" ( "TRUE" / "FALSE") CRLF

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 21 Feb 2002 14:15:48 -0500

> (Examples in separate email).

Based on the description of other "component purposes", I think
it would be more appropriate to write the following:

Component purpose: Provide a grouping of component properties
^^^^^^^^^          that describe a query.

>      Conformance: Can be specified in an iCalendar object.

RFC 2445 doesn't use a "Conformance" field for components.

>      hold a query designed to be used by a CUA or a CS.

RFC 2445 talks of "grouping" and not of "container".

>            parameters in any random order are equivalent.

With the ABNF written properly (see below) we can delete
this note.   All of this is already specified in RFC 2445.

>         expand     = "EXPAND" *(";" xparam) ":" ( "TRUE" / "FALSE") CRLF

For consistency with RFC 2445, we should rewite this
ABNF as follows:

     queryc    = "BEGIN" ":" "VQUERY" CRLF
                 queryprop
                 "END" ":" "VQUERY" CRLF

     queryprop = *( 

               ; the following are optional,
               ; but MUST NOT occur more than once
                
               expand / queryid /

               ; the following are optional,
               ; and MAY occur more than once

               query / name / x-prop
               )

*** NOTE: I've added the missing rule parts 'queryid' and 'name'
          for the QUERYID and NAME properties.  The registration
          for the NAME property is already part of the VCAR
          proposal.  If the WG wants to use QUERYNAME instead
          of NAME, we'll have to register this property in
          another section as well.

>         expand     = "EXPAND" *(";" xparam) ":" ( "TRUE" / "FALSE") CRLF

We need a separate sections to register the EXPAND property.

   Subject: Registration of text/calendar MIME property EXPAND

EXPAND is of value type BOOLEAN, and we should use the rule part
'boolean' defined in RFC 2445 in its formal definition.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 21 Feb 2002 13:00:49 -0700

> this note.   All of this is already specified in RFC 2445.

I assume your comment was for the text above, and not the
text below you comment.

No - In fact that is one of the bugs in 2445. It did not
specify it in the grammar and we got complaints about that.
The 2445 grammar implies that there is a specific order.
The above text is used to amplify the issue so that someone
that reads 2445 can understand that is a 2445 bug an that
we are not replicating that bug.