Subject: CHILD/PARENT vs RELATED-TO

From: Doug Royer <[email-masked]>
Date: Wed, 13 Feb 2002 13:02:54 -0700

On Georges issues list is:

  "Use of RELATED-TO Property to express relationships
   between calendars. See thread: "RELATED-TO vs
   CHILD/PARENT." 

I would like to propose text like the following be added.

   When a calendar is deleted, the CS MUST delete any other
   RELATED-TO properties in the CS or any other calendar that
   have a RELATED-TO value of that deleted calendar.

   This allows those properties to be changed without the UPN that
   deleted the calendar from needing access to any other
   CS calendar and to allow them not to need to have MODIFY
   or DELETE permissions to those effected calendars
   RELATED-TO property.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Wed, 13 Feb 2002 16:08:21 -0500

>    or DELETE permissions to those effected calendars

I disagree.

If the UPN is not granted the right to modify the
RELATED-TO property of the other VAGENDA components,
then most likely these properties were not set by
him to start with.  Thus, these properties should
not be deleted by him (or by the CS on his behalf).

It was agreed that the RELATED-TO property shall be
maintained by the CUA and it shall stay that way.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Wed, 13 Feb 2002 15:36:41 -0700

> not be deleted by him (or by the CS on his behalf).

And so how does the owner of that calendar get notified
that the RELATED-TO <calid> is gone and that their
calendar property is now bogus?

When it was CHILD/PARENT the CS maintained that field
at the CS level and now that is gone.

> maintained by the CUA and it shall stay that way.

It was proposed :-)

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 14 Feb 2002 09:50:27 -0500

> calendar property is now bogus?

By using the <search> command.

> at the CS level and now that is gone.

But previously the CUA was NOT allowed to modify these
properties.  The properties were managed by the CS ONLY.

> > maintained by the CUA and it shall stay that way.

1- Hierarchical calendars have been removed from CAP.
   As such, the CS has no notion of the RELATED-TO
   property, the CUA does.

2- A property should either be managed by the CUA or
   the CS.  NOT BOTH!

3- What if I delete my VAGENDA and re-create it right
   away with the same CALID?

4- You had mention that you wanted to add an EXTERN
   parameter to the RELATED-TO property to allow links
   outside the CS (when we do fan-out).  The CS is not
   going to modify the VAGENDAs located in other CS,
   so eventually, the CUA will have to handle RELATED-TO
   property with CALID that no longer exists, the same
   way web browser needs to handle broken links (as was
   mentioned by John).

Regards,
Bernard