Subject: Re: CAP: VQUERY new MATCH operator

From: "John Stracke" <[email-masked]>
Date: Wed, 13 Feb 2002 11:17:42 -0500

>I would like to introduce a new MATCH operator such that:

It's not clear to me what good this would be.  Can you give us a use case?

/===========================================================\
|John Stracke                    |Principal Engineer        |
[email-masked]   |Incentive Systems, Inc.   |
|http://www.incentivesystems.com |My opinions are my own.   |
|===========================================================|
|"This horse has made a career out of being dead." -- Harald|
|Alvestrand                                                 |
\===========================================================/

---

From: Bernard Desruisseaux <[email-masked]>
Date: Wed, 13 Feb 2002 11:43:45 -0500

> It's not clear to me what good this would be.  Can you give us a use case?

Mary would like to review the access rights
she has granted to Bob.

By submitting the following VQUERY:

   BEGIN:VQUERY
   QUERYNAME:Query-01
   QUERY:SELECT * FROM VCAR
    USING_PROPERTIES GRANT oneGrant
    WHERE [email-masked]' = oneGrant
   END:VQUERY

Mary will only find the VCAR with a GRANT
property *explicitly* set to "[email-masked]",
that is, she won't find all the VCAR that
apply to Bob (e.g., those with "GRANT:*").
To do so, Mary could submit the following
VQUERY:

   BEGIN:VQUERY
   QUERYNAME:Query-01
   QUERY:SELECT * FROM VCAR
    USING_PROPERTIES GRANT oneGrant
    WHERE [email-masked]' MATCH oneGrant
   END:VQUERY

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878