Subject: xCal Issues List (2002-02-18)

From: "ericp" <[email-masked]>
Date: Mon, 18 Feb 2002 11:31:36 -0500

Good Morning Again,

Here is the current list xCal issues that I've
compiled from the calsch mailing list. Again
we will start discussing, adding, removing
items, once the CAP discussions quite down 
a little.

Issue xCal-001 - The case of official names
- Should the names used within the xCal DTD be
  upper case, lower case, or mixed case
- Current view is a maintain the lowercase

Issue xCal-002 - Changing iCalendar name
- Should the iCalendar names be maintained in
  xCal or should they be modified
- The current view is to maintain, changing the
  only the case. We may need a "prime driective" 
  here.

Issue xCal-002 - Attribute Lists
- there are a few places where attributes are used
  instead of child elements (e.g. in the vCalendar
  element the version, prodid, calscale, and method)
- The current view is to simplify the DTD removing
  all attribute lists

Issue xCal-003 - XML Schema
- include an XML schema in this specification

Issue xCal-004
- correct the differences with "related" and "related-to"
  within the DTD

Issue xCal-005 - WBXML binding
- Provide a wbxml binding for xcal.

Issue xCal-006
- Provide an XML Schema for xcal.

Issue xCal-007 - xCal MIME Type
- Change the MIME Type to reflect requirements RFC 3023
  from text/x-xcal to conformant name. Refer to,
  http://www.normos.org/ietf/rfc/rfc3023.txt
- The current view is
  "application/calendar+xml" for xCal
  "application/calendar+wbxml" for wbxml version
  The draft version 01 was updated with this value.

Issue xCal-008 - Category Items vs Resources
- The DTD mapping for CATEGORIES indicates the use
  of any number of item elements
      <categories>
           <item>1</item>
           <item>2</item>
      </categories>
   While the RESOURCES indicates the same, the DTD
   only accepts
      <resources>1</resources>
      <resources>2</resources>
   There is an inconsistancy with CATEGORIES vs RESOURCES.
   Propose remove "items" from CATEGORIES and just use
   multiple entries
      <categories>1</categories>
      <categories>2</categories>
   making both RESOURCES and CATEGORIES just PCDATA

Thanks,
Eric

-------------------------------
Eric R. Plamondon
Steltor - Chief Web Architect
2000 Peel Street, 4th Floor
Montreal, Quebec
mailto:[email-masked]
http://www.steltor.com

---

From: "John Stracke" <[email-masked]>
Date: Wed, 20 Feb 2002 09:32:39 -0500

>Does changing the case violate the Prime Directive?
>
>VEVENT:... -> <vevent>... -> vevent:...

We're not changing the case.  iCalendar is case-insensitive; "vevent:" 
means exactly the same thing as "VEVENT:".  (It's possible that there are 
implementations out there that don't know that; but that's their bug, not 
xCal's.)

/==============================================================\
|John Stracke                    |Principal Engineer           |
[email-masked]   |Incentive Systems, Inc.      |
|http://www.incentivesystems.com |My opinions are my own.      |
|==============================================================|
|But how do we know destroying the Van Allen belt will kill all|
|life on Earth if we don't try it?                             |
\==============================================================/