Subject: Re: CAP: Scope of stored VQUERY.

From: "John Stracke" <[email-masked]>
Date: Fri, 15 Feb 2002 14:00:30 -0500

>(1) For localization and consistency with VCAR and VAGENDA, 
>    it seems that a QUERYID should be used to identify the VQUERY, 
>    and a property NAME should by used for a localizable 
>    display name.

That might be worthwhile, yeah.  It should probably be possible to provide 
multiple localized variants of the display name.  For queries submitted by 
a CUA for the same user to use later, it wouldn't matter; but, if the CS 
provides convenient predefined searches, then it may need to provide the 
name in multiple languages.

>(2) QUERYNAME (or QUERYID in this proposition) is overloaded. 

Perhaps, but it's not ambiguous.  "Search by name" and "My name is" are 
clearly distinct.  Having to say "Search by reference" and "My name is" is 
less clear, because it's not obvious that "reference" corresponds to 
"name".

/============================================================\
|John Stracke                    |Principal Engineer         |
[email-masked]   |Incentive Systems, Inc.    |
|http://www.incentivesystems.com |My opinions are my own.    |
|============================================================|
|"God does not play games with His loyal servants." "Whoo-ee,|
|where have you *been*?" --_Good Omens_                      |
\============================================================/

---

From: Patrice Lapierre <[email-masked]>
Date: 15 Feb 2002 15:45:39 -0500

On Fri, 2002-02-15 at 14:00, John Stracke wrote:
...
> clearly distinct.  

  True they are distinct. But I dislike having the semantic 
of a property being dependent of the presence of other 
properties.

e.g.,  
 if the "search" command receives:
   
      BEGIN:VQUERY
      QUERYNAME:MyQuery
      END:VQUERY

 the meaning is: find and use a stored VQUERY named MyQuery.      

 However if the "search" command receives:

      BEGIN:VQUERY
      QUERYNAME:MyQuery
      QUERY:SELECT * FROM VEVENT
      END:VQUERY

 the meaning is: use the given VQUERY which happens to be
 named MyQuery. 

> Having to say "Search by reference" and "My name is" is 

I don't understand, the proposal is:

 - All stored VQUERYs must have a unique QUERYID within its 
   scope (VQUERYs that are not stored don't need a QUERYID).
   
 - The NAME property is only for display name 
   (not to be used by QUERYREF).

 - QUERYREF and TARGET are used to uniquely identify
   a stored VQUERY within a CS.
 
  To use a stored VQUERY the only thing that must be provided
is the location (TARGET) and the id (QUERYREF) of the query.

  So you would not have to say "Search by reference" and 
"My name (or id) is", unless your intent is to create a 
new stored VQUERY that refers to another stored VQUERY
(which was not be possible with the previous proposal).

--
Patrice.