Subject: Re: TZID conflict

From: [email-masked]
Date: Fri, 14 Jun 2002 18:14:15 -0400

Bruce, are you saying that the tzidparam line needs to be "fixed?"  If so, 
I'll add it to the list of items needing repair on that draft.

[email-masked]
Sent by: [email-masked]
06/14/02 14:14

        To:     "John Stracke" <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: TZID conflict

John noted: 
> But the ABNF says:
> 
> tzidparam  = "TZID" "=" [tzidprefix] paramtext CRLF
> tzidprefix = "/"
> paramtext  = *SAFE-CHAR
> SAFE-CHAR  = WSP / %x21 / %x23-2B / %x2D-39 / %x3C-7E
>            / NON-US-ASCII 

The ANBF should have been (and should be checked for ALL other ABNF): 

tzidparam  = "TZID" "=" [tzidprefix] param-value CRLF 

since tzidparam needs both a param-text (it has "TZID") and a param-value 
like all other good property parameters. 

Bruce 
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: [email-masked]
Date: Mon, 17 Jun 2002 11:47:14 -0400

Pat asked on 06/14/2002 06:14:15 PM:
> Bruce, are you saying that the tzidparam line needs to be "fixed?" 
> If so, I'll add it to the list of items needing repair on that draft. 

Yes I am but as JP later noted the correction should be to change:

to:

        tzidparam  = "TZID" "=" param-value CRLF 

since the optional tzidprefix could be incorrectly inserted before a 
dquoted string causing some parsing errors.

I also think we (the Royal 'we') should take another look at all the 
property parameters to make sure we correct them all in a similar manner 
if need be.

JP: Did you notice any other similar problems?

Bruce

---

From: JP Rosevear <[email-masked]>
Date: 17 Jun 2002 13:08:47 -0400

> JP: Did you notice any other similar problems?

No, but I wasn't specifically looking.  I just found it doing some spec
reading after some interop failures wrt TZIDs.

-JP
-- 
--
=======================================================================
JP Rosevear				[email-masked]
Ximian Inc.				http://www.ximian.com

---

From: Bernard Desruisseaux <[email-masked]>
Date: Mon, 17 Jun 2002 14:16:06 -0400

> dquoted string causing some parsing errors.

I assume that iCalendar parsers will need to look at the
VERSION property to figure which version of the tzidparam
rule part to use when parsing iCalendar objects.

Correct?

Cheers,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Mon, 17 Jun 2002 12:50:51 -0600

> rule part to use when parsing iCalendar objects.

The ABNF bug makes no differance because a well written iCal parser
and generator would have placed them in quotes anyway:

IN 2445: 

   4.1.1 List and Field Separators

        ...
   Property parameters with values containing a COLON, a SEMICOLON or a
   COMMA character MUST be placed in quoted text.
        ...

---

From: JP Rosevear <[email-masked]>
Date: 17 Jun 2002 16:14:46 -0400

>    COMMA character MUST be placed in quoted text.

A TZID parameter was explicitly excluded from having those characters
under the current abnf.

-JP

---

From: Doug Royer <[email-masked]>
Date: Mon, 17 Jun 2002 16:29:06 -0600

> A TZID parameter was explicitly excluded from having those characters

yes, and thanks for pointing out that the ABNF has a bug.