Subject: Re: TZID conflict

From: [email-masked]
Date: Fri, 14 Jun 2002 14:14:51 -0400

John noted:
> But the ABNF says:
> 
> tzidparam  = "TZID" "=" [tzidprefix] paramtext CRLF
> tzidprefix = "/"
> paramtext  = *SAFE-CHAR
> SAFE-CHAR  = WSP / %x21 / %x23-2B / %x2D-39 / %x3C-7E
>            / NON-US-ASCII

The ANBF should have been (and should be checked for ALL other ABNF):

tzidparam  = "TZID" "=" [tzidprefix] param-value CRLF 

since tzidparam needs both a param-text (it has "TZID") and a param-value 
like all other good property parameters.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: JP Rosevear <[email-masked]>
Date: 14 Jun 2002 11:26:16 -0400

> like all other good property parameters.

One more minor point, this allows things like:

/"Eastern, Nowhere DST"

which is invalid for parsing i think.

-JP
-- 
--
=======================================================================
JP Rosevear				[email-masked]
Ximian Inc.				http://www.ximian.com

---

From: [email-masked]
Date: Fri, 14 Jun 2002 16:43:11 -0400

> which is invalid for parsing i think.

Good catch.  We do not need [tzidprefix] in the ABNF here since its 
already allowed in:

     param-value        = paramtext / quoted-string

     paramtext  = *SAFE-CHAR

     value      = *VALUE-CHAR

     quoted-string      = DQUOTE *QSAFE-CHAR DQUOTE

     NON-US-ASCII       = %x80-F8
     ; Use restricted by charset parameter
     ; on outer MIME object (UTF-8 preferred)

     QSAFE-CHAR = WSP / %x21 / %x23-7E / NON-US-ASCII
     ; Any character except CTLs and DQUOTE

     SAFE-CHAR  = WSP / %x21 / %x23-2B / %x2D-39 / %x3C-7E
                / NON-US-ASCII
     ; Any character except CTLs, DQUOTE, ";", ":", ","

by resolving param-value to a quoted-string which allows the tzidprefix 
character to be in it (its a %x2F which is in QSAFE-CHAR already).

(Anyone found the new home of Chris Newmans ABNF validator??)

Bruce