Subject: answer to query for UNPROCESSED

From: Andrea Campi <[email-masked]>
Date: Thu, 8 Aug 2002 18:08:28 +0200

Hi all,

if I send a query like

SELECT * FROM VEVENT WHERE STATE()='UNPROCESSED'

what do I get back? I guess one mime object for each METHOD, right?
Might be a good idea to add at least an example on the description
for SEARCH, similar to the example for CREATE with >1 TARGET.

Bye,
	Andrea

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Sat, 24 Aug 2002 11:32:31 -0600

> for SEARCH, similar to the example for CREATE with >1 TARGET.

You would get back like all of the properties that are in all of
the UNPROCESSED VEVENTs.

You might really want:

	SELECT VEVENT FROM VAGENDA WHERE STATE() = 'UNPROCESSED'

Which would give you all of the VEVENTs that were UNPROCESSED.

---

From: Andrea Campi <[email-masked]>
Date: Mon, 26 Aug 2002 18:25:53 +0200

> Which would give you all of the VEVENTs that were UNPROCESSED.

Sorry, you're right. But I still would like to ask: what do I get back?
Supposing I have two onprocessed entries, one REPLY and one COUNTER, I
expect I would get:

Content-Type: text/calendar

BEGIN:VCALENDAR
VERSION:2.0 
PRODID:-//someone's prodid
CMD:REPLY
TARGET:cal.example.com
METHOD:REPLY
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
END:VCALENDAR

Content-Type: text/calendar

BEGIN:VCALENDAR
VERSION:2.0 
PRODID:-//someone's prodid
CMD:REPLY
TARGET:cal.example.com
METHOD:COUNTER
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
END:VCALENDAR

Am I right? Can we add an example to clarify this?

Bye,
	Andrea

---

From: Doug Royer <[email-masked]>
Date: Mon, 26 Aug 2002 13:20:05 -0600

> Am I right? Can we add an example to clarify this?

If they are not the same METHOD, they MUST BE in separate
BEGIN/END VCALENDAR objects (as you showed). If they are the
same METHOD, then they can be in separate or the same objects.
This is an iCalendar restriction, not a CAP protocol issue.

I am not sure we need to restate this in CAP.