Subject: RE: dtend/dtstart date value in sample iCalendar DTD Document (xCal)

From: <[email-masked]>
Date: Tue, 6 Aug 2002 10:54:39 -0500

I reread Doug's discussion of the subject thread and agree with him. Use of DTSTART _and_ DTEND would only work if the DTSTART and DTEND had DATETIME format and had DTEND>DTSTART values.

-- Frank

> -----Original Message-----
> From: ext [mailto:[email-masked]]
> Sent: Tuesday, August 06, 2002 08:46
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: dtend/dtstart date value in sample iCalendar DTD Document
> (xCal)
> 
> 
> Either should be valid. The original is more explicit (ie, 
> has a precise start and end).

---

From: Gary Frederick <[email-masked]>
Date: Tue, 06 Aug 2002 11:04:32 -0500

Did you read my use cases on ietf-calendar?

...
Use case #1

 DTSTART;DATE:19971102

with no DTEND/DURATION is an event that takes up no time.

...

Use case #3

 DTSTART;DATE:19971102
 DTEND;DATE:19971103

Valid and represents time.

...
So you can represent an anniversary with Use case #1 and an one day event (12 hours long) with Use case #3.

Gary

---

From: Gary Frederick <[email-masked]>
Date: Tue, 06 Aug 2002 11:08:07 -0500

Make that

So you can represent an anniversary with Use case #1 and an one day event with Use case #3.

Gary Frederick wrote:
>> I reread Doug's discussion of the subject thread and agree with him. 
>> Use of DTSTART _and_ DTEND would only work if the DTSTART and DTEND 
>> had DATETIME format and had DTEND>DTSTART values.
>>
>> -- Frank
>>
>>
>>> Either should be valid. The original is more explicit (ie, has a 
>>> precise start and end).
>>
>>