Subject: Search replies

From: Mark Davidson <[email-masked]>
Date: Thu, 08 Aug 2002 11:10:12 +0100

Hi,

I am currently looking at the search command and want to check my understanding with a few questions:

It might also be useful to add some more examples ,particuarly successful ones, in the search 
section of CAP (section 9.8).

1) Given the search command in section 9.8:

       C: Content-Type: text/calendar
       C:
       C: BEGIN:VCALENDAR
       C: VERSION:2.0
       C: CMD:SEARCH
       C: TARGET:relcal2
       C: TARGET:relcal3
       C: BEGIN:VQUERY
       C: QUERY:SELECT DTSTART,DTEND,SUMMARY,UID
       C:  FROM VEVENT
       C:  WHERE DTEND >= '19990310T080000Z'
       C:  AND DTSTART <= '19990310T190000Z'
       C:  AND STATE() = 'BOOKED'
       C: END:VQUERY
       C: END:VCALENDAR

    I would expect a successful responce to look like this:

       S: Content-Type: text/calendar
       S: BEGIN:VCALENDAR
       S: TARGET:relcal2
       S: CMD:REPLY
       S: VERSION:2.0
       S: BEGIN:VREPLY
       S: DTSTART:19990310T090000Z
       S: DTEND:19990310T100000Z
       S: SUMMARY:Meeting 1
       S: UID:[email-masked]
       S: DTSTART:19990310T170000Z
       S: DTEND:19990310T180000Z
       S: SUMMARY:Meeting 2
       S: UID:[email-masked]
       S: REQUEST-STATUS:2.0
       S: END:VREPLY
       S: END:VCALENDAR

       S: Content-Type: text/calendar
       S: BEGIN:VCALENDAR
       S: TARGET:relcal3
       S: CMD:REPLY
       S: VERSION:2.0
       S: BEGIN:VREPLY
       S: DTSTART:19990310T090000Z
       S: DTEND:19990310T100000Z
       S: SUMMARY:Meeting 1
       S: UID:[email-masked]
       S: REQUEST-STATUS:2.0
       S: END:VREPLY
       S: END:VCALENDAR

2)  If this is correct, then I think the example where
     VEVENT contents are not accessible should look like this:

       S: Content-Type: text/calendar
       S: BEGIN:VCALENDAR
       S: TARGET:relcal2
       S: CMD:REPLY
       S: VERSION:2.0
       S: BEGIN:VREPLY
       S: REQUEST-STATUS:4.1
       S: END:VREPLY
       S: END:VCALENDAR

       S: Content-Type: text/calendar
       S: BEGIN:VCALENDAR
       S: TARGET:relcal3
       S: CMD:REPLY
       S: VERSION:2.0
       S: BEGIN:VREPLY
       S: REQUEST-STATUS:4.1
       S: END:VREPLY
       S: END:VCALENDAR

     ie there should not be BEGIN:VEVENT / END:VEVENT lines

TYPO: In cap08 page 117 2nd from last line, the last word is
       missing a d from the end - should be selected

3) If I want all the VEVENT objects from a VAGENDA do I use

       SELECT VEVENT FROM VAGENDA

       or

       SELECT * FROM VEVENT

4)

---

From: Doug Royer <[email-masked]>
Date: Sat, 24 Aug 2002 11:13:16 -0600

Mark Davidson wrote:
> It might also be useful to add some more examples ,particuarly
> successful ones, in the search section of CAP (section 9.8).
> 
> ...
> ...

The text describes that the VEVENT contents are not accessible.
Not the VEVENT. So no.

If the VEVENTs were not accessible - then yes. See the very
next example that shows what to do when the the components
are not accessible. It is the same as your suggested response.

>        missing a d from the end - should be selected

Fixed - thanks.

>        SELECT VEVENT FROM VAGENDA

It would give you:

	All of the VEVENTs from in VAGENDA and all
	if their properties wrapped in BEGIN/END VEVENT.

>        SELECT * FROM VEVENT

This would give your all of the properties from the VEVENTS in TARGET
not wrapped in BEGIN/END VEVENT.