Subject: Is TARGET mandatory?

From: Andrea Campi <[email-masked]>
Date: Sat, 3 Aug 2002 19:59:40 +0200

Hi all,

nowhere in the current text is indicated whether the TARGET property is 
mandatory or optional. If we want it to be optional, we need to specify 
what is the implied behavior if it's not specified. I would expect all 
commands to operate on a default depending on the user identity (the 
user's default VAGENDA probably), right?

Bye,
	Andrea

---

From: Doug Royer <[email-masked]>
Date: Sun, 04 Aug 2002 12:50:10 -0600

Andrea Campi wrote:
> mandatory or optional.

Section (2.) does, it calls it optional. It is listed in (2.) as
optional because not all containers use the TARGET property.

                   ; These are optional, but MUST NOT occur
                   ; more than once.
                   ;
                   calscale        /
                   method          /
                   target          /
                   iana-prop       /
                   cmd             /

And in:

	7.24 TARGET Property

 	  Property Name: TARGET

 	  Purpose: This property defines the container that the command
          that is issued will act upon.  It its value is a capurl as
	  defended in Section 5.

I guess we could add something like 'And the TARGET property MUST BE
supplied for all commands...' to the text.

> If we want it to be optional, we need to specify

I do not think we want it optional for any command.
However I could go with it as you say, if not supplied then
it is the currently authenticated users calendar. Then what
do we do when the currently authenticated user does not have
a calendar?  I would lean towards making it a requirement
for all commands.

---

From: Andrea Campi <[email-masked]>
Date: Mon, 5 Aug 2002 09:42:04 +0200

> optional because not all containers use the TARGET property.

Right, I overlooked this.

> supplied for all commands...' to the text.

Some commands don't need it (GET-CAPALITY comes to my mind), so I think it
should still be optional; the commands which do need it should indicate it
is MUST be supplied.

> a calendar?  I would lean towards making it a requirement

Me too, for the same reason.

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Bernard Desruisseaux <[email-masked]>
Date: Mon, 05 Aug 2002 10:05:18 -0400

>                    ; These are optional, but MUST NOT occur

Actually this is wrong since TARGET "MAY occur more than once".

> supplied for all commands...' to the text.

Don't do that.  Many commands don't need a TARGET (e.g.,
GENERATE-UID, GET-CAPABILITY).

> a calendar?  I would lean towards making it a requirement

See above.

Cheers,
Bernard
-- 
Bernard Desruisseaux              mailto:[email-masked]
Server Technologies               Tel.  : +1 514 733-8500 x4213
Oracle Corporation                Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Mon, 05 Aug 2002 08:52:21 -0600

> Actually this is wrong since TARGET "MAY occur more than once".

Thanks. I just updated my copy, it will be in the next push.

> GENERATE-UID, GET-CAPABILITY).

We are in agreement.