Subject: 8.6. VQUERY Component

From: Andrea Campi <[email-masked]>
Date: Wed, 23 Oct 2002 22:43:07 +0200

Hi Doug,

back in August Patrice Lapierre proposed 
(<[email-masked]>) to add a TARGET 
property to the VQUERY component to determine where to look for a named 
stored VQUERY. You agreed, I agree, and nobody objected.
Later on, in September, I posted a reminder with a proposed ABNF (in 
<[email-masked]>) and again nobody objected.
So I'd say, let's do it:

      queryc    =  "BEGIN" ":" "VQUERY" CRLF
                 queryprop
                 "END" ":" "VCAR" CRLF

      queryprop = 1*(

                  ; the following are OPTIONAL but MUST NOT occur
                  ; more than once
                  ;
                  queryid / target

                  ; the following are OPTIONAL, and MAY occur
                  ; more than once
                  ;
                  / name / x-prop / iana-prop

                  ; the following MUST occur at least once.
                  ;
                  / query

                 )

Also, in the description, we should add:

The "TARGET" property specifies where to look for a stored "VQUERY" 
component, or where to store a "VQUERY" component.

Bye,
	Andrea

---

From: Doug Royer <[email-masked]>
Date: Wed, 23 Oct 2002 15:05:42 -0600

Thanks your right - I forgot that one.

When creating ANY object, the TARGET in the VCALENDAR component
is already supplied - so TARGET would ONLY be used when performing
a search in one TARGET with the query being stored in another TARGET.

Here is what I added/changed:

      queryprop = 1*(

                  ; 'queryid' is OPTIONAL but MUST NOT occur
                  ; more than once. If the "TARGET" property
                  ; is supplied then the "QUERYID" property
                  ; MUST BE supplied.
                  ;
                  queryid / target

                 )

AND I then added these two paragraphs:

      For a search using a named query, if the "TARGET" property is
      supplied in a "VQUERY" component, then the CS is to search for
      the query in the calid supplied by the "TARGET" property value.

      For a create the "TARGET" property MUST NOT be supplied
      as the destination container is already supplied in
      the "TARGET" property of the "VCALENDAR" component.

---

From: Andrea Campi <[email-masked]>
Date: Wed, 23 Oct 2002 23:54:48 +0200

> a search in one TARGET with the query being stored in another TARGET.

You are right, and I like your changes.

Thanks,
	Andrea