Subject: 3.2 Calendar Store Object Model

From: [email-masked]
Date: Tue, 29 Oct 2002 12:08:34 -0500

Just a quick editorial note. In the Calendar Store hierarchy diagram there 
is (in part):

       +-- VAGENDAs
       |     |
       |     +--properties
       |     +--VEVENTs
       |     |    |
       |     |    +--VALARMs
       |     +--VTODOs
       |     |    |
       |     |    +--VALARMs
       |     +--VJOURNALs
       |     +--VCARs
       |     +--VTIMEZONEs
       |     +--VQUERYs
       |     +--VFREEBUSY
       |     |
       |     |   ...
       .
       .
       +-- VAGENDAs
       .     .
       .     .
       .     .

The 2nd VAGENDAs is superfluous and should be removed.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Doug Royer <[email-masked]>
Date: Tue, 29 Oct 2002 11:20:27 -0700

[email-masked] wrote:
> 
> Just a quick editorial note. In the Calendar Store hierarchy diagram 
> there is (in part):
> 
>        +-- VAGENDAs
>  ...
>       .
>       .
>       +-- VAGENDAs
>       .     .
>       .     .
>       .     .
> 

Why? It looks to me if it is saying there can be more than one.

-- 
-
Doug Royer                       Work: (208)612-INET
[email-masked]                   Fax:  (866)594-8574
http://INET-Consulting.com       Cell: (208)520-4044
http://Royer.com/People/Doug

---

From: [email-masked]
Date: Wed, 30 Oct 2002 10:21:23 -0500

> Why? It looks to me if it is saying there can be more than one.

2 reasons:

1) You already have an 's' at the end making the 1st one plural and
2) The rest of the list shows plural components/containers too with just 1 
entry:
       |     +--properties
       |     +--VEVENTs
       |     |    |
       |     |    +--VALARMs
       |     +--VTODOs
       |     |    |
       |     |    +--VALARMs
       |     +--VJOURNALs
       |     +--VCARs
       |     +--VTIMEZONEs
       |     +--VQUERYs
       |     +--VFREEBUSY
but no multiple VEVENTs, VTODOs, etc.

Oh yea, you need to put an 's' on that VFREEBUSY (or are you only allowing 
1 VFREEBUSY per VAGENDA??? :^) )

Bruce