Subject: 9.5 MODIFY Command

From: Andrea Campi <[email-masked]>
Date: Wed, 23 Oct 2002 22:03:33 +0200

Hi Doug,

as I wrote in <[email-masked]>, MODIFY doesn't have an 
ABNF for reply. I do realize it might be too late to fix this in this 
draft, and I'm not sure I'd be able to come up with an ok ABNF, so I 
just wanted to bring this up again so we don't forget.

Bye,
	Andrea

---

From: Doug Royer <[email-masked]>
Date: Wed, 23 Oct 2002 15:12:38 -0600

It does not need an ABNF, but I just added:

      Response:

      A "VCALENDAR" component is returned with one ore more "REQUEST-STATUS"
      property values.

-- 
-
Doug Royer                       Work: (208)612-INET
[email-masked]                   Fax:  (866)594-8574
http://INET-Consulting.com       Cell: (208)520-4044
http://Royer.com/People/Doug

---

From: Andrea Campi <[email-masked]>
Date: Thu, 24 Oct 2002 00:21:23 +0200

> It does not need an ABNF, but I just added:

Well, most other commands have a definition for *-reply, so for 
consistency at least, I would expect a modify-reply, too.

>      A "VCALENDAR" component is returned with one ore more 

Sorry but the reply should contain a lot more than the REQUEST-STATUS, 
as the description says. It's still not very clear to me WHAT should be 
in the reply, so I guess this badly needs more details...

Bye,
	Andrea

>
>
> Andrea Campi wrote:
>> Hi Doug,
>> as I wrote in <[email-masked]>, MODIFY doesn't have 
>> an ABNF for reply. I do realize it might be too late to fix this in 
>> this draft, and I'm not sure I'd be able to come up with an ok ABNF, 
>> so I just wanted to bring this up again so we don't forget.
>> Bye,
>>     Andrea
>
>
> -- 
> -
> <smime.p7s>

---

From: Doug Royer <[email-masked]>
Date: Wed, 23 Oct 2002 16:55:18 -0600

> in the reply, so I guess this badly needs more details...

What else would be included? The MODIFY succeeds or fails, but
it does not return any data.

---

From: Andrea Campi <[email-masked]>
Date: Thu, 24 Oct 2002 02:06:16 +0200

On Thursday, October 24, 2002, at 12:55 AM, Doug Royer wrote:

>> Sorry but the reply should contain a lot more than the 
>> REQUEST-STATUS, as the description says. It's still not very clear to 
>> me WHAT should be in the reply, so I guess this badly needs more 
>> details...
>

Let me quote what is in the draft:

If multiple components are selected, then what uniquely identified the 
component MUST BE returned (UID, QUERYID, ...) if the component 
contains a unique identifier. If not, sufficient information to 
uniquely identify the modified components MUST BE returned in the reply.

    S: Content-Type: text/calendar
    S:
    S: BEGIN:VCALENDAR
    S: TARGET:relcalid
    S: CMD;ID=delete#1:REPLY
    S: BEGIN:VREPLY
    S: BEGIN:VEVENT
    S: UID:123
    S: REQUEST-STATUS:2.0
    S: END:VEVENT
    S: END:VREPLY
    S: END:VCALENDAR

I guess (given the presence of a query) the intention was to return 
enough data to allow the CUA to check that what got modified is indeed 
what the CUA intended to modify. Not that I think this is a smart way 
to approach the problem...

If you are proposing to change this to only return the REQUEST-STATUS - 
I agree.

Bye,
	Andrea