Subject: [[email-masked]: Question about iTIP + VCARs]

From: Andrea Campi <[email-masked]>
Date: Wed, 23 Oct 2002 22:56:12 +0200

Hi,

this (copied from an old message) is still not fixed (you agreed
it should be fixed).

----- Forwarded message from Andrea Campi <[email-masked]> -----

                BEGIN:VCAR
                CARID:REQUESTONLY
                BEGIN:VRIGHT
                GRANT:NONOWNER
                PERMISSION:WRITE
                RESTRICTION:SELECT * FROM VCALENDAR WHERE METHOD = 'REQUEST'
                END:VRIGHT
                END:VCAR

[...]

Should this be written as:

                BEGIN:VCAR
                CARID:REQUESTONLY
                BEGIN:VRIGHT
                GRANT:NONOWNER
                PERMISSION:WRITE
                RESTRICTION:SELECT * FROM VEVENT WHERE METHOD = 'REQUEST'
                RESTRICTION:SELECT * FROM VTODO WHERE METHOD = 'REQUEST'
                RESTRICTION:SELECT * FROM VJOURNAL WHERE METHOD = 'REQUEST'
                END:VRIGHT
                END:VCAR

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

----- End forwarded message -----

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A. - BT Ignite                  http://www.inet.it
Technical Dept. - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Wed, 23 Oct 2002 15:23:44 -0600

There is no such example (no example has PERMISSION:WRITE in it)

While looking for it, I did notice that some of the examples
still had "READ" and not "SEARCH". I replaced all "READ"s with
"SEARCH" as there is no "READ" command.

The 'REQUESTONLY' example has PERMISSION:CREATE.

And why is the RESTRICTION value in the REQUESTONLY CARID not valid?

-- 
-
Doug Royer                       Work: (208)612-INET
[email-masked]                   Fax:  (866)594-8574
http://INET-Consulting.com       Cell: (208)520-4044
http://Royer.com/People/Doug

---

From: Andrea Campi <[email-masked]>
Date: Thu, 24 Oct 2002 00:17:43 +0200

> There is no such example (no example has PERMISSION:WRITE in it)

Right... I copied it from an old message, so that part might have 
changed... It's now:

              BEGIN:VCAR
              CARID:REQUESTONLY
              BEGIN:VRIGHT
              GRANT:NON CAL-OWNERS()
              PERMISSION:CREATE
              RESTRICTION:SELECT * FROM VCALENDAR WHERE METHOD = 
'REQUEST'
              END:VRIGHT
              END:VCAR

> And why is the RESTRICTION value in the REQUESTONLY CARID not valid?

Well, for one, VCALENDAR is not in comp-name in the ABNF for CAL-QUERY 
value type. Also, if looking for an iTIP component, it's arguably more 
correct to use:

SELECT * FROM VEVENT WHERE METHOD = 'REQUEST'

Bye,
	Andrea

> <smime.p7s>

---

From: Doug Royer <[email-masked]>
Date: Wed, 23 Oct 2002 16:48:50 -0600

> SELECT * FROM VEVENT WHERE METHOD = 'REQUEST'

Or perhaps:

	SELECT VEVENT FROM VAGENDA WHERE METHOD = 'REQUEST'
	SELECT VTODO FROM VAGENDA WHERE METHOD = 'REQUEST'
	SELECT VJOURNAL FROM VAGENDA WHERE METHOD = 'REQUEST'

As:

Would have given you the properties in VEVENTs and not the components.

---

From: Andrea Campi <[email-masked]>
Date: Thu, 24 Oct 2002 02:01:45 +0200

On Thursday, October 24, 2002, at 12:48 AM, Doug Royer wrote:
>> Well, for one, VCALENDAR is not in comp-name in the ABNF for 
>> CAL-QUERY value type. Also, if looking for an iTIP component, it's 
>> arguably more correct to use:

Aaargh!! Of course!!
So, do you agree this needs to be fixed, or not?

Bye,
	Andrea