Subject: CAP BEEP profile

From: "Preston Stephenson" <[email-masked]>
Date: Wed, 25 Feb 2004 14:39:48 -0700

I posted a query about the CAP BEEP profile back in October but didn't
get a response.
I went ahead and put a bug in bugzilla (657)
It's the only thing I remember that I need resolved.

Thanks.
Preston

> Sorry if I missed this.
> 
> Is there an example of starting the CAP BEEP profile?
> 
> When I initially wrote my CAP server, I think I patterned my start
> exchange after the SASL profiles. Thus:
> 
> C: Content-Type: application/beep+xml
> C:
> C: <start number='3'>
> C:   <profile uri='http://iana.org/beep/cap/1.0'/>
> C: </start
> 
> S: Content-Type: application/beep+xml
> S:
> S: <profile uri='http://iana.org/beep/cap/1.0'>
> S:   <![CDATA[<blob status='complete'/>]]>
> S: </profile>
> 
> In section 12.1 BEEP Profile Registration, it talks about the
initial
> message must be the GET-CAPABILITY command.
> It doesn't talk about the BEEP Start message exchange.
> 
> In section 12.1 there is also a "URI[10]" reference. The "[10]"
> reference seems to have been taken from rfc3080.
> The reference should probably be changed to "[URI]" to be
consistent.
> Thanks.
> Preston

---

From: Doug Royer <[email-masked]>
Date: Sat, 28 Feb 2004 12:14:36 -0700

>>Is there an example of starting the CAP BEEP profile?
Did you mean starting a new channel? (As you have a <start> message below)

Or did to mean to show a <greeting> message? (you said starting the CAP 
BEEP profile).

As I understand BEEP, you send the CAP uri in the greeting message
and then the authentication profile in the start messages.

What was the 'other' format you tested against?

-- 

Doug Royer                     |   http://INET-Consulting.com
-------------------------------|-----------------------------
[email-masked]                 | Office: (208)520-4044
http://Royer.com/People/Doug   | Fax:    (866)594-8574
                               | Cell:   (208)520-4044

              We Do Standards - You Need Standards