Subject: Re: CAP issue #657 (BEEP profile): closed?

From: "Preston Stephenson" <[email-masked]>
Date: Wed, 04 Aug 2004 15:01:34 -0600

The greeting message just says what is available.
You have to send a start message for a channel.
You have to have a channel to communicate.
Channel 0 is reserved for channel management.
For 2.3 of rfc3080
"When a BEEP session starts, only channel number zero is defined,
   which is used for channel management."

          C: <start number='1'>
          C:    <profile uri='http://iana.org/beep/cap/1.0'/>
          C: </start>

Where is the example of starting a CAP channel?

Again I need to see what the server responds to the start of a CAP
channel.
Thanks.

Preston

>>> [email-masked] 08/04/04 2:33 PM >>>

Preston Stephenson wrote:

>There is a greeting that says CAP is supported, but there is not a
BEEP
>start channel for CAP.
Start one - per beep. You have the uri as specified in CAP:

    http://iana.org/beep/cap/1.0 

And BEEP: "2.3.1.2 The Start Message"

>BEEP communicates on channels.
>What channel will be for CAP?
>
Any where you started the channel with the uri = 
http://iana.org/beep/cap/1.0 

>The doc shows starting a channel for authentication, but that is for
>authentication not CAP.
>

CAP does not have its own authentication. It uses the BEEP SASL
profile
for authentication.

Once authentication is complete and valid, send a CAP greeting as
described in CAP "12.3 BEEP connection details", paragraph
that starts with "At this point ...". Once the greeting is accepted
you can open as many channels as you wish providing the CAP uri
for each channel.

 *** And again, I am not what I would call a beep expert. So if
something
is incorrect, please advice! ***

>In the BEEP (RFC3080) spec it shows starting a channel to do TLS.
>
>  
>
>>>>[email-masked] 08/04/04 11:46 AM >>>
>>>>        
>>>>
>
>Is that not covered in "12.3 BEEP connection details" ?
>
>If not, what is missing?
>
>
>Preston Stephenson wrote:
>
>  
>
>>Sorry I haven't been getting copied for some time.
>>I still don't see how to start a BEEP channel for CAP in rev 13.
>>At least with my understanding of BEEP.
>>Preston
>>
>> 
>>
>>    
>>
>
>  
>

-- 

Doug Royer                     |   http://INET-Consulting.com 
-------------------------------|-----------------------------
[email-masked]                 | Office: (208)520-4044
http://Royer.com/People/Doug   | Fax:    (866)594-8574
                               | Cell:   (208)520-4044

              We Do Standards - You Need Standards

---

From: Doug Royer <[email-masked]>
Date: Wed, 04 Aug 2004 18:06:11 -0600

>Where is the example of starting a CAP channel?

I'll reword the text below to mention BEEP and the START command.

CAP: "10.7 GET-CAPABILITY Command"

   CMD: GET-CAPABILITY

   Purpose: The "GET-CAPABILITY" command returns the capabilities of the
   other end point of the session.

   A CUA MUST send a "GET-CAPABILITY" command to a CS after the initial
   connection. A CS MUST send a "GET-CAPABILITY" command to a CUA after
   the initial connection. The "GET-CAPABILITY" command and reply MUST
   BE implemented by all CSs and CUAs.

--