Subject: [Ietf-calsify] Section 6 Recommended Practices #3: Different TZID?

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Sun Nov 5 14:36:43 2006

In section 6 Recommended Practices of RFC 2445 it says:

 > 3.  When the "DTSTART" and "DTEND", for "VEVENT", "VJOURNAL" and
 >     "VFREEBUSY" calendar components, and "DTSTART" and "DUE", for
 >     "VTODO" calendar components, have the same value data type (e.g.,
 >     DATE-TIME), they SHOULD specify values in the same time format
 >     (e.g., UTC time format).

What about DATE-TIME values with different TZID parameter values
(e.g., airline flights, that start in one time zone and end in
another)?  Obviously, I think this should be okay.

Cheers,
Bernard

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Mon Nov 6 00:40:40 2006

> another)?  Obviously, I think this should be okay.

I also think that's okay with the formulation above, as long as both are given 
with TZID. What's not allowed is to have e.g. DTSTART in "Z"-notation and 
DTEND in floating or timezone notation.

Cheers,
Reinhold

- -- 
- ------------------------------------------------------------------
Reinhold Kainhofer, Vienna University of Technology, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at/
 * K Desktop Environment, http://www.kde.org, KOrganizer maintainer
 * Chorvereinigung "Jung-Wien", http://www.jung-wien.at/

---

From: cyrus at daboo.name (Cyrus Daboo)
Date: Mon Nov 6 07:17:00 2006

Hi Bernard,

> another)?  Obviously, I think this should be okay.

Yes - we must allow different TZID's on DTSTART/DTEND/DUE.

-- 
Cyrus Daboo