Subject: [Ietf-calsify] Updated ABNF to address issues 52 & 56

From: alexey.melnikov at isode.com (Alexey Melnikov)
Date: Fri Nov 17 10:58:27 2006

Here is the updated ABNF (based on feedback from Bernard) to address

* Issue 52: (Section 4.3.10 Recurrence Rule: x-name rule part?)
* Issue 56: (Section 4.3.10: Order of rule parts (ABNF issue))

recur           = recur-rule-part *( ";" recur-rule-part )
                ;
                ; The rule parts are not ordered in any
                ; particular sequence
                ;
                ; The FREQ rule part is REQUIRED,
                ; but MUST NOT occur more than once
                ;
                ; The UNTIL or COUNT rule parts are OPTIONAL,
                ; but they MUST NOT occur in the same 'recur'
                ;
                ; The other rule parts are OPTIONAL,
                ; but MUST NOT occur more than once

recur-rule-part = ( "FREQ" "=" freq )
                / ( "UNTIL" "=" enddate )
                / ( "COUNT" "=" 1*DIGIT )
                / ( "INTERVAL" "=" 1*DIGIT )
                / ( "BYSECOND" "=" byseclist )
                / ( "BYMINUTE" "=" byminlist )
                / ( "BYHOUR" "=" byhrlist )
                / ( "BYDAY" "=" bywdaylist )
                / ( "BYMONTHDAY" "=" bymodaylist )
                / ( "BYYEARDAY" "=" byyrdaylist )
                / ( "BYWEEKNO" "=" bywknolist )
                / ( "BYMONTH" "=" bymolist )
                / ( "BYSETPOS" "=" bysplist )
                / ( "WKST" "=" weekday )

Regards,
Alexey

---

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Fri Nov 17 12:30:54 2006

+1 (Obviously!)

Cheers,
Bernard

Alexey Melnikov wrote:
> _______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify