Subject: Re: [ietf-calsify] [Ietf-calsify] \t disallowed in "text" value type but allowed in root "value" type

From: Bernard Desruisseaux <[email-masked]>
Date: Mon, 20 Oct 2008 14:24:51 -0400

To be consistent with what's done with param-value, I propose to change:

    TSAFE-CHAR = %x20-21 / %x23-2B / %x2D-39 / %x3C-5B /
                 %x5D-7E / NON-US-ASCII

to:

    TSAFE-CHAR = WSP / %x21 / %x23-2B / %x2D-39 / %x3C-5B /
                 %x5D-7E / NON-US-ASCII

That is, HTAB (US-ASCII decimal 9) would now be allowed and would NOT 
need to be escaped with a backslash.

Cheers,
Bernard

Nigel Swinson wrote:
> Perhaps I'm reading this incorrectly, but I think the grammer says that 
> \t (0x09) isn't allowed in a text value:
>  
> http://tools.ietf.org/html/draft-ietf-calsify-rfc2445bis-08#section-3.3.11
> 
>         text       = *(TSAFE-CHAR / ":" / DQUOTE / ESCAPED-CHAR)
>            ; Folded according to description above
> 
>         ESCAPED-CHAR = ("\\" / "\;" / "\," / "\N" / "\n")
>            ; \\ encodes \, \N or \n encodes newline
>            ; \; encodes ;, \, encodes ,
> 
>         TSAFE-CHAR = %x20-21 / %x23-2B / %x2D-39 / %x3C-5B /
>                      %x5D-7E / NON-US-ASCII
>            ; Any character except CTLs not needed by the current
>            ; character set, DQUOTE, ";", ":", "\", ","
> 
> Was this a mistake, or a deliberate choice?  It seem especially wierd 
> given that \t is allowed in a "value", and I thought the whole intention 
> of the "text" value type was to allow more characters to be in a value 
> than what "value" allowed.
>  
> http://tools.ietf.org/html/draft-ietf-calsify-rfc2445bis-08#section-3.1
> 
>       contentline   = name *(";" param ) ":" value CRLF
> 
>  
> 
>       value         = *VALUE-CHAR
> 
>       VALUE-CHAR    = WSP / %x21-7E / NON-US-ASCII
>       ; Any textual character
> 
> I think it is a mistake, one that might be easy to rectify should there be a V09?
> 
> Nigel
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify

_______________________________________________
ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify

---

From: Cyrus Daboo <[email-masked]>
Date: Mon, 20 Oct 2008 14:38:09 -0400

Hi Bernard,

> need to be escaped with a backslash.

I think this is a reasonable change, though in theory it would break a 
very, very strict 2445 parser!

-- 
Cyrus Daboo

---

From: Eliot Lear <[email-masked]>
Date: Fri, 31 Oct 2008 15:31:23 +0100

> very, very strict 2445 parser!

Has anyone tested this against common parsers?

Eliot