Subject: [ietf-calsify] Indicating a completed to-do???

From: Reinhold Kainhofer <[email-masked]>
Date: Wed, 13 Jan 2010 14:52:12 +0100

Hi all,
Recently the issue came up in kde how a completed to-do is supposed to be 
indicated. There are three different completion settings defined in rfc 5545:
-) STATUS:COMPLETED (as opposed to NEEDS-ACTION)
-) COMPLETED:20070707T100000Z
-) PERCENT-COMPLETE:100

However, the RFC is quiet which of those is supposed to indicate that a to-do 
is actually completed... There is, however, an example in section 3.6.2 of a 
completed to-do:

      The following is an example of a "VTODO" calendar component that
      was due before 1:00 P.M. UTC on July 9th, 2007 and was completed
      on July 7th, 2007 at 10:00 A.M. UTC.

       BEGIN:VTODO
       UID:[email-masked]
       DTSTAMP:20070514T103211Z
       DTSTART:20070514T110000Z
       DUE:20070709T130000Z
       COMPLETED:20070707T100000Z
       SUMMARY:Submit Revised Internet-Draft
       PRIORITY:1
       STATUS:NEEDS-ACTION
       END:VTODO

Is the STATUS:NEEDS-ACTION really intended or is it an oversight and should 
rather be STATUS:COMPLETED???

The problem we have is interoperability: Horde creates a VTODO with
    STATUS:COMPLETED
    COMPLETED:20100112T125449Z
while Korganizer and kontact instead use only the completion percentage:
    COMPLETED:20100112T124208Z
    PERCENT-COMPLETE:100

Unfortunately, this totally breaks the exchange of to-dos between horde and 
kontact, as completed to-dos in one application won't be detected as completed 
in the other.

In the RFC I couldn't find anything that says that one of the is "correct" and 
the other is not... 

Cheers,
Reinhold

-- 
------------------------------------------------------------------
Reinhold Kainhofer, [email-masked], http://reinhold.kainhofer.com/
 * Financial & Actuarial Math., Vienna Univ. of Technology, Austria
 * http://www.fam.tuwien.ac.at/, DVR: 0005886
 * LilyPond, Music typesetting, http://www.lilypond.org
_______________________________________________
ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify

---

From: Doug Day <[email-masked]>
Date: Thu, 14 Jan 2010 08:29:03 -0700

Reinhold,

Those are some good points, and I'd like to hear other's view on this.

My personal interpretation is that the STATUS is the driving field 
here;  both the COMPLETED and PERCENT-COMPLETE are there for 
informational purposes when determining if the VTODO is complete.

However, there is a kink with this philosophy:

1.  VTODO items can recur.
2.  The only solution I can see for tracking completed status is a 
combination of the STATUS property and the COMPLETED property.  If the 
STATUS field is set to COMPLETED, but the VTODO recurs, then the 
COMPLETED date should be used to determine when the event is again due?  
This is a tricky situation -- one I'd like to see resolved.

For example.  Say you have a VTODO that looks like this:

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
BEGIN:VTODO
UID:fed50a1c-1e72-11db-a465-aae271be3660
SUMMARY:Test Todo
STATUS:COMPLETED
COMPLETED;TZID=US-Eastern:20060825T100000
CLASS:PRIVATE
DTSTART;TZID=US-Eastern:20060728T090000
RRULE:FREQ=WEEKLY;INTERVAL=3;UNTIL=20061207T160000Z
DTSTAMP:20060728T195437Z
END:VTODO
BEGIN:VTIMEZONE
TZID:US-Eastern
LAST-MODIFIED:19870101T000000Z
TZURL:http://zones.stds_r_us.net/tz/US-Eastern
BEGIN:STANDARD
DTSTART:19671029T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:EST
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19870405T020000
RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=4
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
END:DAYLIGHT
END:VTIMEZONE
END:VCALENDAR

Notice the VTODO has been marked both in COMPLETED status and with a 
COMPLETED date/time.  However, the VTODO is also scheduled to recur 
every 3 weeks.  Should the status be reset to NEEDS-ACTION after this 
time?  Should that be implicit?  How should a CUA handle this situation?

Also, how should the recurrence rule be handled?  It seems it should be 
scheduled 3 weeks from the COMPLETED date/time.  Is that accurate?

Any thoughts?
-Doug Day
http://www.ddaysoftware.com

Reinhold

CONFIDENTIALITY NOTICE:  This electronic transmission may contain confidential information.
This information is intended for the use of the individual(s) or entity to whom it is 
intended, even if addressed incorrectly.  This information should not be read, 
given or made accessible to anyone else.  Please delete it from your files if you are 
not the intended recipient.  If you have received this electronic transmission in error, 
please notify the sender immediately via the address shown.  Thank you for your compliance.