Subject: [calsify] Request for review - Schema for representing resources for calendaring and scheduling services

From: Ciny Joy <[email-masked]>
Date: Wed, 12 May 2010 10:36:17 -0700

Hello,
    A draft defining the schema for representing resources for  
calendaring and scheduling services has been submitted to the IETF as  
an Internet Draft - http://tools.ietf.org/html/draft-cal-resource-schema-00 
  . A resource in the scheduling context is any shared entity that can  
be scheduled by a calendar user, but does not control its own  
attendance status. Would really appreciate review and comments.

Thank you,
Ciny

---

From: "Tim Hare" <[email-masked]>
Date: Thu, 13 May 2010 23:16:24 -0400

My comments on the document:

In many places, you have an LPAP example without any text describing it as
an example.  This did not seem clear to me until the third or fourth item
that was treated that way.

You have a comment on many items that says "Not required for a resource
scheduling query".  I think if you are going to take pains to do that, it
would be nice to have comments to say which things are required, and
possibly a table showing the attributes and whether they are required or
not.  On the other hand, I am not sure this information is required for a
schema and perhaps it might be better in a document describing how resources
are scheduled.

Tim Hare
Interested Bystander, Non-Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ciny Joy
Sent: Wednesday, May 12, 2010 1:36 PM
To: [email-masked]
Subject: [calsify] Request for review - Schema for representing resources
for calendaring and scheduling services

Hello,

Thank you,
Ciny
_______________________________________________
calsify mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/calsify

---

From: "Tim Hare" <[email-masked]>
Date: Thu, 13 May 2010 23:16:24 -0400

Tim Hare

-----Original Message-----

Hello,

Thank you,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Fri, 14 May 2010 13:00:58 -0700

Thank you so much for your review and comments.
I will certainly try to mark the examples more clearly.

As far as the comment on scheduling query, I guess I could change so  
that the attributes that could be used for scheduling are indicated in  
some way in their description itself.

Thanks,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Fri, 14 May 2010 13:00:58 -0700

Thanks,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Tue, 18 May 2010 16:11:33 -0700

Hello Tim,

> that was treated that way.
Going through the document, I am not sure which LDAP examples you are  
referring to. I would really appreciate it, if you could point me to  
one such case.

Thanks,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Tue, 18 May 2010 16:11:33 -0700

Hello Tim,

Thanks,
Ciny

---

From: "Tim Hare" <[email-masked]>
Date: Tue, 18 May 2010 21:26:52 -0400

4.1.1, 4.4.1, 4.7.1 ... All places where the paragraph header is followed
only by an expression in parenthesis.

Tim Hare

-----Original Message-----
From: Ciny Joy [mailto:[email-masked]] 
Sent: Tuesday, May 18, 2010 7:12 PM
To: Tim Hare
Cc: [email-masked]
Subject: Re: [calsify] Request for review - Schema for representing
resources for calendaring and scheduling services

Hello Tim,

Thanks,
Ciny

> an Internet Draft -
http://tools.ietf.org/html/draft-cal-resource-schema-00

---

From: "Tim Hare" <[email-masked]>
Date: Tue, 18 May 2010 21:26:52 -0400

Tim Hare

-----Original Message-----
From: Ciny Joy [mailto:[email-masked]] 
Sent: Tuesday, May 18, 2010 7:12 PM
To: Tim Hare
Cc: [email-masked]
Subject: Re: [calsify] Request for review - Schema for representing

Hello Tim,

Thanks,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Wed, 19 May 2010 09:03:18 -0700

> only by an expression in parenthesis.
Actually, those are not examples. They are actual LDAP attribute  
definitions as specified by the header. Would it help to add a line  
explicitly stating that before each one?

Thanks,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Wed, 19 May 2010 09:03:18 -0700

Thanks,
Ciny

---

From: "Tim Hare" <[email-masked]>
Date: Wed, 19 May 2010 17:44:06 -0400

It would help if on at least the first one it specified what it was, for
those who may not have experience working with LDAP directly.

-----Original Message-----
From: Ciny Joy [mailto:[email-masked]] 
Sent: Wednesday, May 19, 2010 12:03 PM
To: Tim Hare
Cc: [email-masked]
Subject: Re: [calsify] Request for review - Schema for representing

Thanks,
Ciny

---

From: "Tim Hare" <[email-masked]>
Date: Wed, 19 May 2010 17:44:06 -0400

-----Original Message-----
From: Ciny Joy [mailto:[email-masked]] 
Sent: Wednesday, May 19, 2010 12:03 PM
To: Tim Hare
Cc: [email-masked]
Subject: Re: [calsify] Request for review - Schema for representing

Thanks,
Ciny

---

From: Ciny Joy <[email-masked]>
Date: Wed, 19 May 2010 18:31:26 -0700

> those who may not have experience working with LDAP directly.

Will sure do. Thanks a lot for the feedback.

Ciny

---

From: Ciny Joy <[email-masked]>
Date: Wed, 19 May 2010 18:31:26 -0700

Ciny