Subject: [calsify] JSGroup/entries

From: Michael Douglass <[email-masked]>
Date: Fri, 8 May 2020 21:19:47 -0400

The spec says in section 5.3.1 - for entries

    Type: "String[JSTask|JSEvent]" (mandatory).

    A collection of group members.  This is represented as a map of the
    "uid" property value to the JSCalendar object member having that uid.
    Implementations MUST ignore entries of unknown type.

What if somebody is sending an attendee a bunch of instances - currently 
the case if somebody is attending only some of the meetings?

The uid is the same in each case.

I guess there are ways round this - e.g. manufacturing a fake master - 
but it seems simpler to send the attendee the full instance(s).

---

From: "Neil Jenkins" <[email-masked]>
Date: Mon, 11 May 2020 14:10:36 +1000

>    Type: "String[JSTask|JSEvent]" (mandatory).

Agreed, I've changed this to `(JSTask|JSEvent)[]` (just an array of objects instead of a map). You could have members with the same UID but different recurrence ids.

Neil.