Subject: Re: [calsify] ECMAScript Extensions to RFC 3339

From: Ujjwal Sharma <[email-masked]>
Date: Wed, 14 Oct 2020 23:20:37 +0530

Hi Ronald, everyone!

I'm trying to get this task done on the Temporal side of things. Is
there any draft specification of the date format including timezones and
calendars you could point us to? Also, could you give a little more
context on the rationale behind not using the [Asia/Hong_Kong] timezone
syntax? We've preferred the Java format so far for a lot of reasons
including interoperability, but at the same time, would like to align
with standards like ISO 8601-3.

Ujjwal

On 9/6/20 2:51 AM, 'Shane Carr' via Temporal Champions wrote:
> Thanks for the info, Ronald!
> 
> Could you loop in the editors of these new draft specs (e.g. ISO 34300)
> and/or ISO/TC 154?  We've done a great deal of work arriving at our
> current state of calendar representation, including a relationship with
> the Unicode Consortium, and it would be very good to sync on the syntax
> and data model in this area.
> 
> Shane
> 
> 
> On Sat, Sep 5, 2020 at 3:12 AM Ronald Tse
> <tse=[email-masked] <mailto:[email-masked]>>
> wrote:
> 
>     Hi Shane,
> 
>     There is a new project in ISO/TC 154 called ISO 8601-3 proposed by
>     CalConnect last year as the third part of ISO 8601.
> 
>     The syntax is as follows:
> 
>     Date: {gre}2019-10-11; {jul}2019-10-11
> 
>     Time: {utc}09:30:20; {gps}09:30:20
> 
>     Datetime (Timezone): {uset}20191011T09:30:20; {iso.34200.us
>     <http://iso.34200.us>et}2019-10-11T09:30:20
> 
>     This syntax is based on the three ISO standards under process, ISO
>     34100 (reference time scales), ISO 34200 (timezones) and ISO 34300
>     (calendars).
> 
>     In this syntax, values can be namespaced, so for example, the ISO
>     34100 value of {gps} can also be expressed as {iso.34100.gps}, which
>     allows us to handle codes from other authorities e.g. IANA TZs.
> 
>     Do would want to align syntax used?
> 
>     Kind regards,
>     Ron
> 
>     _____________________________________
> 
>     Ronald Tse
>     Ribose Inc.
> 
>     +=========================================================+
>     This message may contain confidential and/or privileged
>     information.  If you are not the addressee or authorized to
>     receive this for the addressee, you must not use, copy,
>     disclose or take any action based on this message or any
>     information herein.  If you have received this message in
>     error, please advise the sender immediately by reply e-mail
>     and delete this message.  Thank you for your cooperation.
>     +=========================================================+
> 
>>     On Sep 3, 2020, at 4:43 AM, Shane Carr
>>     <sffc=[email-masked]
>>     <mailto:sffc=[email-masked]>> wrote:
>>
>>     Thank you for the responses!
>>
>>     The "[Europe/Berlin]" suffix is already in common use, e.g. in
>>     Java, and numerous platforms support that syntax.  I feel it would
>>     be smart to retain that form as-is for better interop.
>>
>>     For additional key-value pairs, my latest thought is to have them
>>     use the ';' separator Ken suggested.  It would look like this:
>>
>>     2020-05-22T07:19:35.356-04:00[Europe/Berlin];ca=islamic-umalqura;foo=bar
>>
>>     An additional iteration would be to adopt the extensions pattern,
>>     similar to BCP 47, where different prefixes in the key-value
>>     syntax are managed by different standards bodies, and "x"
>>     signifies private use.  Since Unicode manages the calendar system
>>     identifiers, this form could look like:
>>
>>     2020-05-22T07:19:35.356-04:00[Europe/Berlin];u-ca=islamic-umalqura;x-foo=bar
>>
>>     Thoughts on the proposed syntax?
>>
>>     What would you recommend as next steps?
>>
>>     Would there be harm if TC39 moved syntax such as that shown above
>>     into Stage 3 (roughly equivalent to Draft Standard in RFC 2026
>>     terminology)?
>>
>>     Thanks,
>>     Shane
>>
>>     P.S. We are having additional discussion on this subject in this
>>     GitHub issue:
>>     https://github.com/tc39/proposal-temporal/issues/293#issuecomment-685960090
>>
>>     On Wed, Sep 2, 2020 at 6:30 AM Ken Murchison <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>
>>
>>         On 9/1/20 10:55 PM, Shane Carr wrote:
>>         > Dear CalExt experts,
>>         >
>>         > My name is Shane and I am helping push the ECMAScript Temporal
>>         > proposal, bringing new date/time types to JavaScript.  It's our
>>         > version of Joda Time.
>>         >
>>         > I would like your feedback on the following extensions that
>>         we are
>>         > proposing to the ISO-8601 / RFC 3339 strings outputted by
>>         Temporal.
>>         >
>>         >
>>         https://github.com/tc39/proposal-temporal/blob/main/docs/iso-string-ext.md
>>         >
>>         > Of particular interest is our proposed representation of
>>         dates in
>>         > non-Gregorian calendar systems.
>>
>>
>>         If we're going to parameterize the date/time, why not use
>>         something more
>>         generic, familiar, and extensible, e.g.:
>>
>>         2020-05-22T07:19:35.356-04:00;tzid=America/Indiana/Indianapolis;cs=islamic-umalqura;foo=bar
>>
>>         or
>>
>>         2020-05-22T07:19:35.356-04:00[tzid=America/Indiana/Indianapolis;cs=islamic-umalqura;foo=bar]
>>
>>         -- 
>>         Kenneth Murchison
>>         Senior Software Developer
>>         Fastmail US LLC
>>
>>     _______________________________________________
>>     calsify mailing list
>>     [email-masked] <mailto:[email-masked]>
>>     https://www.ietf.org/mailman/listinfo/calsify
> 
> -- 
> You received this message because you are subscribed to the Google
> Groups "Temporal Champions" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to [email-masked]
> <mailto:[email-masked]>.
> To view this discussion on the web visit
> https://groups.google.com/a/chromium.org/d/msgid/temporal-champions/CABxsp%3D%3D8gtf8_9R0LOwKUOsw52w5sW4Tmy4UOMYzM71dvo22WA%40mail.gmail.com
> <https://groups.google.com/a/chromium.org/d/msgid/temporal-champions/CABxsp%3D%3D8gtf8_9R0LOwKUOsw52w5sW4Tmy4UOMYzM71dvo22WA%40mail.gmail.com?utm_medium=email&utm_source=footer>.

-- 
Ujjwal "Ryzokuken" Sharma (he/him)

Compilers Hacker, Node.js Core Collaborator and Speaker

---

From: Ujjwal Sharma <[email-masked]>
Date: Wed, 14 Oct 2020 23:52:10 +0530

Updating Ronald's email, it seems it got borked at some point.