Subject: Re: [calsify] Warren Kumari's No Objection on draft-ietf-calext-jscalendar-30: (with COMMENT)

From: "Neil Jenkins" <[email-masked]>
Date: Thu, 15 Oct 2020 15:57:09 +1100

I have added the following paragraph to the end of the PatchObject description:

*The PatchObject format is used to significantly reduce file size and duplicated content when specifying variations to a common object, such as with recurring events or when translating the data into multiple languages. It can also better preserve semantic intent if only the properties that should differ between the two objects are patched. For example, if one person is not going to a particular instance of a regularly scheduled event, in iCalendar you would have to duplicate the entire event in the override. In JSCalendar this is a small patch to show the difference. As only this property is patched, if the location of the event is changed, the occurrence will automatically still inherit this.*

Regards,
Neil.

---

From: Warren Kumari <[email-masked]>
Date: Thu, 15 Oct 2020 08:05:35 -0400

Excellent, thank you very much.
This makes it much clearer why this exists / is useful.

Thanks,
W

On Thu, Oct 15, 2020 at 12:57 AM Neil Jenkins <[email-masked]>
wrote:

> *The PatchObject format is used to significantly reduce file size and
> duplicated content when specifying variations to a common object, such as
> with recurring events or when translating the data into multiple languages.
> It can also better preserve semantic intent if only the properties that
> should differ between the two objects are patched. For example, if one
> person is not going to a particular instance of a regularly scheduled
> event, in iCalendar you would have to duplicate the entire event in the
> override. In JSCalendar this is a small patch to show the difference. As
> only this property is patched, if the location of the event is changed, the
> occurrence will automatically still inherit this.*
>
> Regards,
> Neil.
>
-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf