Subject: [calsify] Genart last call review of draft-ietf-calext-valarm-extensions-04

From: Roni Even via Datatracker <[email-masked]>
Date: Mon, 15 Feb 2021 02:32:12 -0800

Reviewer: Roni Even
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-calext-valarm-extensions-??
Reviewer: Roni Even
Review Date: 2021-02-15
IETF LC End Date: 2021-02-16
IESG Telechat date: Not scheduled for a telechat

Summary:
The document is ready for publication as standard track RFC with nits

Major issues:

Minor issues:

Nits/editorial comments:

1. The structured-location is optional so if it is not specified for proximity
I assume that it implies current location?

---

From: Ken Murchison <[email-masked]>
Date: Mon, 15 Feb 2021 07:27:10 -0500

Hi Roni,

Thanks for the review.  Your comment is addressed below.

> I assume that it implies current location?

STRUCTURED-LOCATION is optional because its not used for PROXIMITY: 
[DIS]CONNECT.  I've made the following change to the text:

              <t hangText="Description:">This property is used to
              indicate that an alarm has a location-based trigger. Its
              value identifies the direction of motion used to trigger
-            the alarm. One or more location values are set using
+            the alarm. One or more location values MUST be set using
              "STRUCTURED-LOCATION" properties.</t>

Is this sufficient?

-- 
Kenneth Murchison
Senior Software Developer
Fastmail US LLC

---

From: "Roni Even" <[email-masked]>
Date: Wed, 17 Feb 2021 07:07:42 +0200

Hi Ken,
Thanks, it is OK 
Roni

> -----Original Message-----
> From: Ken Murchison [mailto:[email-masked]]
> Sent: Monday, February 15, 2021 2:27 PM
> To: Roni Even; [email-masked]
> Cc: [email-masked]; [email-masked]; last-
> [email-masked]
> Subject: Re: Genart last call review of draft-ietf-calext-valarm-extensions-04
> 
> Hi Roni,
> 
> > Review Team (Gen-ART) reviews all IETF documents being processed by
> > the IESG for the IETF Chair.  Please treat these comments just like
> > any other last call comments.
> >
> > 1. The structured-location is optional so if it is not specified for
> > proximity I assume that it implies current location?
> 
>

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 24 Feb 2021 14:57:02 -0500

Roni, thanks for your review. Ken, thanks for addressing Roni’s comments. I entered a No Objection ballot.

Alissa

> On Feb 17, 2021, at 12:07 AM, Roni Even <[email-masked]> wrote:
> 
> Hi Ken,
> Thanks, it is OK 
> Roni
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art