Subject: Re: [calsify] Review: draft-ietf-calext-ical-relations-05

From: Michael Douglass <[email-masked]>
Date: Thu, 15 Apr 2021 22:47:05 -0400

Looking through the spec and messages i realized I'd missed a couple of 
these. All are now dealt with.

You also asked if I'd checked for alignment with jscalendar.

There is in fact a misalignment. jscalendar defines the relation type 
"first" for which there is no equivalent in iCalendar. I have added that 
to the version 7 I'm working on.

jscalendar does not define "sibling" but does define "next". The text in 
the icalendar-jscalendar mapping document suggests these are the closest 
match. We could strengthen that language and state that "SIBLING" and 
"next" are equivalent.

There is a slight semantic difference - next seems to imply that some 
order matters while sibling doesn't.

I could add "NEXT" to the relations draft but then we have to deal with 
"SIBLING".

I prefer strengthening the language.

On 8/3/20 19:52, Bron Gondwana wrote:
> Hi Mike,
>
> Thanks for uploading the latest ical relations.  Here's a quick review 
> of a couple of tiny changes needed!
>
> And I need you to confirm that there's no IPR that you're aware of :)
>
> Thanks,
>
> Bron.
>
> *REVIEW:
> *
>
> *Abstract:
> *
>
> nits complains:
>
>    ** The abstract seems to contain references ([RFC5545]), which it
>       shouldn't.  Please replace those with straight textual mentions of the
>       documents in question.
>
> Please change it not to be a reference in the Abstract (it's OK to 
> have a reference in the Introduction)
>
> *1.4 Link*
>
> See [I-D.daboo-caldav-attachments]
>
> Please update this reference to be RFC8607.
>
> *7.1. Concept*
>
> There's a bug in the example:
>
>       SCONCEPT:http://example.com/event-types/sports  <http://example.com/event-types/sports>
>       CONCEPT:http://example.com/event-types/arts/music  <http://example.com/event-types/arts/music>
>       CONCEPT:http://example.com/task-types/delivery  <http://example.com/task-types/delivery>
>
> Please remove the leading 'S'!
>
> ...
>
> I think that's everything I can see :)
>
> Cheers,
>
> Bron.
>
> --
>   Bron Gondwana, CEO, Fastmail Pty Ltd
>   [email-masked]
>
>

---

From: Michael Douglass <[email-masked]>
Date: Thu, 15 Apr 2021 22:56:59 -0400

On 4/15/21 22:47, Michael Douglass wrote:
>
> Looking through the spec and messages i realized I'd missed a couple 
> of these. All are now dealt with.
>
> "first" for which there is no equivalent in iCalendar. I have added 
> that to the version 7 I'm working on.
>
> jscalendar does not define "sibling" but does define "next". The text 
> in the icalendar-jscalendar mapping document suggests these are the 
> closest match. We could strengthen that language and state that 
> "SIBLING" and "next" are equivalent.
>
> I could add "NEXT" to the relations draft but then we have to deal 
> with "SIBLING".
>
And as I add the text I feel a little uneasy about that.

"first" and "next" go together to provide an ordered list of components.

"sibling" might be appropriate for more of a tree structure

>> Thanks for uploading the latest ical relations.  Here's a quick 
>> review of a couple of tiny changes needed!
>>