Subject: Re: [Captive-portals] IETF 99 minutes

From: Gunther Nitzsche <[email-masked]>
Date: Wed, 2 Aug 2017 15:20:56 +0200

Hi

and thanks for the meeting minutes.

I have two (no..three :) small comments on that:
There is an uncontradicted comment saying:

David Dolson: need to
notify non-http-80
Tommy Pauly: expect to interact with web pages
Martin:
considers status code 511 to be dead until new information.

I am wondering why the complete discussion in the last weeks
regarding  511 - status on this mailing list seems to be completely
ignored? At least for me it is still the preferred way to go as I mentioned
earlier here.

And:

Martin: <hat off> Some
feedback I got was (a) there are far too many bits & messages (maybe dest
unreach is enough), you allow provider to provide discriminatory services.
David
B: That's what walled garden does. We shouldn't go there.

..and I thought, we had the consensus that walled garden
is a perfect topic for this ml?

Further down:

Tommy: today, we wait for capport
probe to complete until allowing network access.

That is not what we do. Download of antivirus -patterns or
self- reenabling after abuse block is a valid reason to
reach parts of the network even when the customer is blocked.

Thanks

Gunther

On 31.07.2017 03:00, Erik Kline wrote:
> FYI: I have uploaded the meeting minutes as captured in Etherpad.
> Many thanks to David Dolson (and any others) for taking notes.
>
> You can find the minutes on the wg meetings page:
>
>     https://datatracker.ietf.org/group/capport/meetings/
>     https://datatracker.ietf.org/meeting/99/minutes/capport
>
> and in the wg-materials repo on github:
>
>     https://github.com/capport-wg/wg-materials
>
> I have not edited this initial upload of the minutes in any way.
>
> Please review if/when you get a chance; we can post corrections/clarifications.
>

NetCologne Systemadministration
-- 
NetCologne Gesellschaft für Telekommunikation mbH
Am Coloneum 9 ; 50829 Köln
Geschäftsführer:   
  Timo von Lepel,
  Mario Wilhelm  
Vorsitzender des Aufsichtsrates:
  Dr. Andreas Cerbe
  HRB 25580, AG Köln

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 02 Aug 2017 08:08:29 -0700

> On Aug 2, 2017, at 6:20 AM, Gunther Nitzsche <[email-masked]> wrote:
> 
> Hi
> 

Hi Gunther,

I was referring to what the behavior on Apple operating systems is. When a Wi-Fi network is joined, the captive portal probe is a generally a precondition for allowing the Wi-Fi network to be marked as the default route for the system. While traffic may still be allowed over that network when scoped, general networking traffic is not allowed until the probe completes.

Thanks,
Tommy
> _______________________________________________
> Captive-portals mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/captive-portals <https://www.ietf.org/mailman/listinfo/captive-portals>

---

From: David Bird <[email-masked]>
Date: Wed, 2 Aug 2017 08:44:20 -0700

I don't believe "We shouldn't go there." were my words... We are already
there!

Concerns about net neutrality and 'discriminatory services' is often used
(by the chairs) to raise concerns about ICMP... however, a walled garden
itself is 'discriminatory services' and should we review
Dest-Unreach/Admin-Prohibited or TCP Reset (used today by some NASs when
enforcing walled garden discriminatory services') ?

Yet, I haven't once seen this same concern raised about API methods of
delivering walled garden information.

I agree 100% that this WG does the "work" NOT on the mailing list...
rather, behind closed doors then votes in the in-person meeting...

We need more implementors, deployers, and vendors (specifically the
Guest/Public access business units) to be represented, not just on the
mailing list, but in WG voting and even WG leadership.

On Wed, Aug 2, 2017 at 6:20 AM, Gunther Nitzsche <[email-masked]>
wrote:

> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals
>