Subject: [Capwap] About dynamic udpating Bootrom and Image data

From: zhaoyujin 31390 <[email-masked]>
Date: Tue, 24 Jan 2006 09:56:28 +0500

Hi:

  Both split MAC and local MAC can be called "Fit AP". Presently, many "Fit AP" devices don't have other manangement method (For example Console, Telnet, and so on).

  Can we add two control message elements which are used for updating Bootrom and Image data, when "Fit AP" is running.

Best regards
Michael

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 24 Jan 2006 10:16:22 -0800

The LWAPP protocol already defines a method of downloading firmware on
both Split and Local MAC Aps.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: zhaoyujin 31390 [mailto:[email-masked]] 
> Sent: Monday, January 23, 2006 8:56 PM
> To: Pat Calhoun (pacalhou)
> Cc: [email-masked]
> Subject: About dynamic udpating Bootrom and Image data
> 
> Hi:
> 
>   Both split MAC and local MAC can be called "Fit AP". 
> Presently, many "Fit AP" devices don't have other manangement 
> method (For example Console, Telnet, and so on).
> 
>   Can we add two control message elements which are used for 
> updating Bootrom and Image data, when "Fit AP" is running.
> 
> Best regards
> Michael
>

---

From: zhaoyujin 31390 <[email-masked]>
Date: Mon, 30 Jan 2006 09:07:24 +0500

I have checked current issues, draft, and eval.

There is no mention about "bootrom download".

"Issue40 (Feature resolved): Adapt firmware trigger state machine to allow transition from Run state" resolves that AC can dynamically update AP firmware after AP runs.

I suggestion:

  LWAPP defines a new massage which is used in running state. This massage notifies AP to check or download its firmware or bootrom.

If LWAPP provides this feature, user can directly update bootrom software without take down the AP from the ceiling.

Best regards
Michael

> Why can't the image being downloaded, as defined in the LWAPP, 
> also include the bootrom?
> 
> Pat Calhoun
> > From: zhaoyujin 31390 [[email-masked]] 
> > Sent: Thursday, January 26, 2006 9:23 PM
> > Subject: 回复:RE: RE: About dynamic udpating Bootrom and Image data
> > 
> > I think this is my comment.
> > 
> > Can we provide a method to update the bootrom. Many device 
> > supports update the bootrom on-line.
> > 
> > Best regards
> > Michael
> > 
> > 
> > 
> > > Sorry, but I am not sure that I follow. Is your comment 
> > that you want 
> > > to *also* manage the bootrom?
> > > 
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems
> > > 
> > > 
> > > 
> > > > From: zhaoyujin 31390 [[email-masked]]
> > > > Sent: Wednesday, January 25, 2006 6:01 AM
> > > > Subject: 回复:RE: About dynamic udpating Bootrom and Image data
> > > > 
> > > > Hi pat:
> > > >   
> > > >    But current downloading firmware only before AP is running.
> > > > 
> > > >    For some AP, if we need update the bootrom of device. 
> > We should 
> > > > get the bootrom off device and write it. This is very 
> diffcult to 
> > > > manage.
> > > > 
> > > >    So I think we can provide dynamical downloading firmware 
> and 
> > > > bootrom.
> > > > 
> > > > Best regards
> > > > Michael
> > > > 
> > > > 
> > > > > CTO, Wireless Networking Business Unit Cisco Systems
> > > > > 
> > > > > 
> > > > > 
> > > > > > From: zhaoyujin 31390 [[email-masked]]
> > > > > > Presently, many "Fit AP" devices don't have other
> > > > manangement method
> > > > > > (For example Console, Telnet, and so on).
> > > > > >

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 31 Jan 2006 15:46:09 -0800

I've reopened issue 40, and added your comments, which need to be discussed as a group.

Pat Calhoun

> Sent: Sunday, January 29, 2006 8:07 PM
> Cc: [email-masked]
> Subject: Re:RE: RE: RE: About dynamic udpating Bootrom and Image data
> 
> "Issue40 (Feature resolved): Adapt firmware trigger state 
> machine to allow transition from Run state" resolves that AC 
> can dynamically update AP firmware after AP runs.
> 
> I suggestion:
> 
>   LWAPP defines a new massage which is used in running state. 
> This massage notifies AP to check or download its firmware or bootrom.
> 
> If LWAPP provides this feature, user can directly update 
> bootrom software without take down the AP from the ceiling.
> 
> Best regards
> Michael
> 
> > Why can't the image being downloaded, as defined in the LWAPP, also 
> > include the bootrom?
> > 
> > Pat Calhoun
> > > Can we provide a method to update the bootrom. Many 
> device supports 
> > > update the bootrom on-line.
> > > 
> > > Best regards
> > > Michael
> > > 
> > > 
> > >