Subject: [Capwap] About "IEEE 802.11 Binding"

From: zhaoyujin 31390 <[email-masked]>
Date: Fri, 27 Jan 2006 10:47:17 +0500

Hi all:

   I have a doubt about AP configuration.

   All WLAN configurations are on AC. When LWAPP transmits WLAN configuration using "11.8.1.1  IEEE 802.11 Add WLAN".

   But on AP device, configuration process may be asynchronous. This means AP responses the "11.8.1.1  IEEE 802.11 Add WLAN" message before finishing configuration process. If configuration is fail (For example memory is not enough), how to notify AC about this error.

   Can LWAPP defines notification message for "11.  IEEE 802.11 Binding". Or LWAPP appends mention that all "11.  IEEE 802.11 Binding" message should firstly be processed before AP sends corresponding response.

Best regards
Michael

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 27 Jan 2006 08:19:48 -0800

They do have to be processed prior to responding. What would you like to
see changed to make this clearer?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: zhaoyujin 31390 [mailto:[email-masked]] 
> Sent: Thursday, January 26, 2006 9:47 PM
> To: [email-masked]
> Subject: [Capwap] About "IEEE 802.11 Binding"
> 
> Hi all:
> 
>    All WLAN configurations are on AC. When LWAPP transmits 
> WLAN configuration using "11.8.1.1  IEEE 802.11 Add WLAN".
> 
>    But on AP device, configuration process may be 
> asynchronous. This means AP responses the "11.8.1.1  IEEE 
> 802.11 Add WLAN" message before finishing configuration 
> process. If configuration is fail (For example memory is not 
> enough), how to notify AC about this error.
> 
>    Can LWAPP defines notification message for "11.  IEEE 
> 802.11 Binding". Or LWAPP appends mention that all "11.  IEEE 
> 802.11 Binding" message should firstly be processed before AP 
> sends corresponding response.
> 
> Best regards
> Michael
>

---

From: zhaoyujin 31390 <[email-masked]>
Date: Sat, 28 Jan 2006 15:08:33 +0500

Because deifferent product has different process mechanism, LWAPP need give clear description about process.

I suggest:

>11.8.2  IEEE 802.11 WLAN Config Response
>
>   The IEEE 802.11 WLAN Configuration Response is sent by the WTP to the
>   AC as an acknowledgement of the receipt of an IEEE 802.11 WLAN
>   Configuration Request.
>   This LWAPP control message does not include any message elements.

change to:
11.8.2  IEEE 802.11 WLAN Config Response
    The IEEE 802.11 WLAN Configuration Response is sent by the WTP to the
    AC as an acknowledgement of the receipt of an IEEE 802.11 WLAN
    Configuration Request.

    Before this LWAPP control message is sent, the IEEE 802.11 WLAN 
    Cofiguration should be successfully implemented.

    This LWAPP control message does not include any message elements.

>9.2  Mobile Config Response
>
>   The Mobile Configuration Response is used to acknowledge a previously
>   received Mobile Configuration Request, and includes a Result Code
>   message element which indicates whether an error occured on the WTP.
>
>   This message requires no special processing, and is only used to
>   acknowledge the Mobile Configuration Request.
>
>   The data transfer request message MUST contain the message elements
>   described in the next subsection.

change to:
9.2  Mobile Config Response

   The Mobile Configuration Response is used to acknowledge a previously
   received Mobile Configuration Request, and includes a Result Code
   message element which indicates whether an error occured on the WTP.

   Before this message is sent, the Mobile Cofiguration should be implemented.
   The Result Code indicate if Mobile Cofiguration is successfully on WTP.

   This message requires no special processing, and is only used to
   acknowledge the Mobile Configuration Request.

   The data transfer request message MUST contain the message elements
   described in the next subsection.

And if "IEEE 802.11 WLAN Configuration Response" also has a Result Code message element
as "Mobile Config Response", 802.11 protocol may be better to control WLAN configuration.

Best regards
Michael

> > From: zhaoyujin 31390 [[email-masked]]