Subject: RE: [Capwap] Question on LWAPP-03 draft

From: "Vishwas Manral" <[email-masked]>
Date: Wed, 4 Jan 2006 20:38:53 -0800

Hi Puneet,

One small typo!! I had stated "I guess for IPv6 it is already stated that we do not do fragmentation at LWAPP level" I meant at "IPv6 level" I meant.

Thanks,
Vishwas
-----Original Message-----
From: Vishwas Manral [mailto:[email-masked]] 
Sent: Thursday, January 05, 2006 9:54 AM
To: Puneet Agarwal; Abhijit Choudhury; [email-masked]
Subject: RE: [Capwap] Question on LWAPP-03 draft

Hi Puneet,

I think you mean all middleboxes and not just firewalls.

I guess for IPv6 it is already stated that we do not do fragmentation at LWAPP level because we have to do MTU discovery and hence fragments can be done at the application level itself. I think only if Path MTU discovery is done for IPv4 too, can we avoid fragmentation. 

Are you saying that the F, L and Fragment Id fields were only valid for Layer-2 transport and not for Layer-3 transport earlier?

Thanks,
Vishwas
________________________________________
From: Puneet Agarwal [mailto:[email-masked]] 
Sent: Thursday, January 05, 2006 4:16 AM
To: Abhijit Choudhury; [email-masked]
Subject: RE: [Capwap] Question on LWAPP-03 draft

The main issue is passing IP fragments via firewalls. Most firewalls drop fragmented packets (in fact the note is section 3.3.4 also refers to that). Hence the question.
 
Hope this helps.
 
Thanks.
 
-Puneet

________________________________________
From: Abhijit Choudhury [mailto:[email-masked]] 
Sent: Wednesday, January 04, 2006 11:42 AM
To: Puneet Agarwal; [email-masked]
Subject: RE: [Capwap] Question on LWAPP-03 draft
For L3 transport, as the spec says, only the first IP fragment
would have an LWAPP header. Standard IP reassembly is used to put the
fragments together.  F, L, and FragID fields in the LWAPP header
are not neeed for reassembly.
 
Am I missing something ?
 
Thanks,
   Abhijit
-----Original Message-----
From: Puneet Agarwal [mailto:[email-masked]] 
Sent: Tuesday, January 03, 2006 7:57 PM
To: [email-masked]; Pat Calhoun (pacalhou)
Subject: [Capwap] Question on LWAPP-03 draft
Question of IPv4 frag/reassembly (Section 3.3.4):
 
There was some talk in the past about performing the fragmentation/reassembly at the application level to avoid IP fragments. In that case, the F,L and FragID bits would need to be used even for L3 transport. Did we ever reach a consensus on this one?
 
My recommendation would be to do the frag/reassembly at application level.
 
Thanks.
 
-Puneet

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: sujay <[email-masked]>
Date: Thu, 05 Jan 2006 12:14:40 +0530

Hi Vishwas,

The F, L and Frag-id fields should be of use only for L2 transport.

Fragmentation causes issues at the firewalls, essentially because
the lwapp header is carried in the first fragment alone.

If the MTU is pre-determined for IPv4/6, the application has to take 
care of re-assembly.
There the F, L and Frag- id fields could be of use.
Additionally a few more fields may be required !

Puneet, 
IMO there is no advantage by pushing the fragmentation/ assembly
to the application.

If firewall is the issue, is it possible to add the lwapp header
 in all fragments..??

Regds,
Sujay

-----Original Message-----
From: Vishwas Manral [mailto:[email-masked]] 
Sent: Thursday, January 05, 2006 10:09 AM
To: Vishwas Manral; Puneet Agarwal; Abhijit Choudhury;
[email-masked]

Hi Puneet,

One small typo!! I had stated "I guess for IPv6 it is already stated
that we do not do fragmentation at LWAPP level" I meant at "IPv6 level"
I meant.

Thanks,
Vishwas
-----Original Message-----
From: Vishwas Manral [mailto:[email-masked]] 
Sent: Thursday, January 05, 2006 9:54 AM
To: Puneet Agarwal; Abhijit Choudhury; [email-masked]
Subject: RE: [Capwap] Question on LWAPP-03 draft

Hi Puneet,

I guess for IPv6 it is already stated that we do not do fragmentation at
LWAPP level because we have to do MTU discovery and hence fragments can
be done at the application level itself. I think only if Path MTU
discovery is done for IPv4 too, can we avoid fragmentation. 

Are you saying that the F, L and Fragment Id fields were only valid for
Layer-2 transport and not for Layer-3 transport earlier?

Thanks,
Vishwas

The main issue is passing IP fragments via firewalls. Most firewalls
drop fragmented packets (in fact the note is section 3.3.4 also refers
to that). Hence the question.
 
Hope this helps.
 
Thanks.
 
-Puneet

________________________________________
From: Abhijit Choudhury [mailto:[email-masked]] 
Sent: Wednesday, January 04, 2006 11:42 AM
To: Puneet Agarwal; [email-masked]
Subject: RE: [Capwap] Question on LWAPP-03 draft
For L3 transport, as the spec says, only the first IP fragment would
have an LWAPP header. Standard IP reassembly is used to put the
fragments together.  F, L, and FragID fields in the LWAPP header are not
neeed for reassembly.
 
Am I missing something ?
 
Thanks,
   Abhijit
-----Original Message-----
From: Puneet Agarwal [mailto:[email-masked]] 
Sent: Tuesday, January 03, 2006 7:57 PM
To: [email-masked]; Pat Calhoun (pacalhou)
Subject: [Capwap] Question on LWAPP-03 draft
 
There was some talk in the past about performing the
fragmentation/reassembly at the application level to avoid IP fragments.
In that case, the F,L and FragID bits would need to be used even for L3
transport. Did we ever reach a consensus on this one?
 
My recommendation would be to do the frag/reassembly at application
level.
 
Thanks.
 
-Puneet