Subject: [Capwap] Question about vlan tagging of 802.11 data frames

From: sitarama penumatsa <[email-masked]>
Date: Mon, 16 Jan 2006 19:18:34 +0000 (GMT)

Hi All,

 I recently joined this group and i am delighted to
see emails from many industry experts in this group. I
have a quick questions about vlan tagging of 802.11
data frames.

 According to any of existing or drafting 802.11
standards, is it allowed to insert vlan tags in a
802.11 data frames? I have recently come across an AP
that inserts vlan tags in 802.11 data frames in the
frame payload right after the LLC header. Are WLAN NIC
cards expected to decode such packets? I thought that
the most common way of implementing vlans in 802.11 is
through multiple BSSIDs and not through vlan tags. Is
this correct?

 Any responses are greaty appreciated.

Thanks a lot,
Sitaram

___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Mon, 16 Jan 2006 23:24:51 -0500

As far as I know, you are correct. 802.11 does not know about VLANs currently.

Donald 

-----Original Message-----
From: sitarama penumatsa [mailto:[email-masked]] 
Sent: Monday, January 16, 2006 2:19 PM
To: [email-masked]
Subject: [Capwap] Question about vlan tagging of 802.11 data frames

Hi All,

 I recently joined this group and i am delighted to see emails from many industry experts in this group. I have a quick questions about vlan tagging of 802.11 data frames.

 According to any of existing or drafting 802.11 standards, is it allowed to insert vlan tags in a
802.11 data frames? I have recently come across an AP that inserts vlan tags in 802.11 data frames in the frame payload right after the LLC header. Are WLAN NIC cards expected to decode such packets? I thought that the most common way of implementing vlans in 802.11 is through multiple BSSIDs and not through vlan tags. Is this correct?

Thanks a lot,
Sitaram

___________________________________________________________
How much free photo storage do you get? Store your holiday snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com _________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

---

From: zhaoyujin 31390 <[email-masked]>
Date: Wed, 18 Jan 2006 13:12:29 +0500

Hi:

   I think this is a good concept. Maybe in the future, station can support
protocol vlan.

  But at present, station is a vlan-unware device , so that station does not
insert vlan tag in 802.11 frame.

  And when AP receives 802.11 frame, it can transform to 802.3 frames or
directly send to AC. Only AP or AC is a vlan-ware device, it may insert a vlan tag for received frames.

Best regards
Michael