Subject: Re:[Capwap] get WLAN Config message

From: zhaoyujin 31390 <[email-masked]>
Date: Fri, 03 Feb 2006 08:55:51 +0500

Why LWAPP need this?

LWAPP should maintain the consistent configuration between AP and AC. All configuration of AP is distributed with LWAPP with AC. If AP occurs some configuration error, LWAPP can know this problem and should do some operation for it (Maybe reboot AP).

So that, AC does not need to check the AP configuration.

Best regards
Michael 

> 
> I would like to go back to my request for an additional message to 
> find 
> out the ssid.  I think the spec could be enhanced to allow an 
> OPTIONAL 
> get_wlan_config message from the AC to the WTP.  This would occur 
> after 
> the join.  This would then allow the AC to know all the 
> information 
> that is configured in the AP since there already is a get_config 
> message.
> 
> Opinions ?
> 
> Philip
> 
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
> 
> Archives: http://lists.frascone.com/pipermail/capwap
> 

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: [email-masked]
Date: Fri, 03 Feb 2006 10:07:08 +0000

Michael,

How is the AC supposed to know if some configuration error occurs if it 
cannot read the configuration?

Philip

Quoting zhaoyujin 31390 <[email-masked]>:

> Why LWAPP need this?
>
> LWAPP should maintain the consistent configuration between AP and AC. 
> All configuration of AP is distributed with LWAPP with AC. If AP 
> occurs some configuration error, LWAPP can know this problem and 
> should do some operation for it (Maybe reboot AP).
>

---

From: [email-masked]
Date: Fri, 03 Feb 2006 05:58:51 -0500

I agree that NOT having the ability to read the configuration from the 
AP is dangerous.  While I accept the argument that the configuration on 
both the AC and the AP SHOULD be the same, in practice humans are 
fallible and bugs will occur.

I would go so far as to suggest that the AC should not rely on what it 
thinks that the AP has been programmed with, but should always read the 
updated configuration from the AP.

Sorry, but I have spent a lot of time in debugging other people's code. 
  I would sooner nip this bug in the bud.  Especially as this will be 
more of a problem when the AC and the AP come from different vendors.  
And that is what CAPWAP is about.

Maurice

-----Original Message-----
From: [email-masked]
To: zhaoyujin 31390 <[email-masked]>
Cc: [email-masked]; [email-masked]
Sent: Fri, 03 Feb 2006 10:07:08 +0000
Subject: Re:[Capwap] get WLAN Config message

  Michael,

  How is the AC supposed to know if some configuration error occurs if 
it cannot read the configuration?

 Philip

 Quoting zhaoyujin 31390 <[email-masked]>:

 > Why LWAPP need this?
 >
  > LWAPP should maintain the consistent configuration between AP and 
AC. > All configuration of AP is distributed with LWAPP with AC. If AP 
 > occurs some configuration error, LWAPP can know this problem and > 

________________________________________________________________________
Check Out the new free AIM(R) Mail -- 2 GB of storage and 
industry-leading spam and email virus protection.

---

From: Charles Clancy <[email-masked]>
Date: Fri, 03 Feb 2006 21:44:48 -0500

Rather than reading back entire configurations, the AC could ask the WTP 
to send a hash of its configuration back.  Perhaps these ACKs could 
include the hash automatically?  Then someone trying to verify 
configurations could check consistence.  If something didn't match, they 
could upload the correct configuration.  Seems like a compromise?

[ t. charles clancy ]--[ [email-masked] ]--[ www.cs.umd.edu/~clancy ]
[ computer science ]-----[ university of maryland | college park ]

[email-masked] wrote:
>  > All configuration of AP is distributed with LWAPP with AC. If AP >

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 3 Feb 2006 19:23:01 -0800 (PST)

HI,

There are issues:
 1) as presently specified in the LWAPP-03 spec that if
    static blacklist entries are added (see 7.4.11)
    which persist across reboots, then there is no
    way to find out what they are (and you have to
    know what they are to delete one (see 7.4.12)).
    In general, if there should be no persistent
    config that an AC cannot determine because an
    AC may lose track, and a WTP may switch to 
    another AC.
 2) The Configuration Update message assumes no partial
    success (see section 7.4). That is, it assumes all
    or nothing. Some WTPs may not work like this. The
    responses does not indicate which config element
    was applied, which failed, and which were aborted.
    Thus, an AC may not know the configuration after
    a failed Configuration Update message
 3) Failure of Configue Response
 4) Modification of the configuration on the WTP
    via another management interface. In the original
    example, I believe that it said via debugging
    the WTP. (I classify this as "out of scope".)
    However, the WTP may have a console, or contain
    an SNMP agent. So far, these haven't been classified
    as "out of scope".

Note that solving this issue doesn't look too difficult
or costly to me. I'd just add a Retrieve Config Request
and Retrieve Config Response. (There are a few details
to work out.)

> >  >> that is configured in the AP since there already is a get_config
Regards,
/david t. perkins