Subject: [Capwap] doubt-admin and change state tlv.

From: sujay <[email-masked]>
Date: Fri, 24 Feb 2006 15:36:28 +0530

Hi Group,
 
There is a slight confusion w.r.t draft-lwappp-03.
 
As per;
7.2.1 Administrative State

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

| Radio ID | Admin State |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

The Admin State TLV is used to change the Admin State of 
one or ALL radios in a WTP.
 
the possible states being;
1- Enabled 
2- Disabled

Compare to;
7.3.2 Change State Event

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

| Radio ID | State | Cause |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Here the State holds value of;
 
1 - for Disabled
 
2 - for Enabled

*BOTH* the above TLV's can be send by the AC to the AP in 
Configuration Update Request Message.

What should be AP's(rather Radio's) expected behaviour with these
TLV's??

Thanks,
Sujay

 
My Location;
 
<http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.52508
5&t=h&hl=en>
http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.525085
&t=h&hl=en
 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: young <[email-masked]>
Date: Fri, 24 Feb 2006 16:26:49 +0530

Hi Group:

I thought the "Admin TLV" idea is to help AC to control AP's radio status,
the "Change state event"  TLV is to help AP to inform AC about its radio
Operation status.

If  it is this ideal, I think Change state event TLV should always come from
AP to AC, never from AC to AP.

So  Configure response should take "Admin TLV", not to take "change state
event" TLV. But  in the standard, it suggest to use "Change state event" in
the configure response.

BTW,  Configure request  is special case: In order to inform AC about a AP's
old configuration, AP send use "Admin TLV" .

In other case, "Admin TLV"  is always from AC to AP.

How do you think?

 Richard

-----Original Message-----
From: sujay [mailto:[email-masked]] 
Sent: Friday, February 24, 2006 4:08 PM
To: [email-masked]
Subject: FW: [Capwap] doubt-admin and change state tlv.

-----Original Message-----
From: sujay [mailto:[email-masked]] 
Sent: Friday, February 24, 2006 3:36 PM
To: [email-masked]
Subject: [Capwap] doubt-admin and change state tlv.

Hi Group,

As per;

1- Enabled 

2- Disabled

Compare to;

7.3.2 Change State Event

1 - for Disabled

2 - for Enabled

 

What should be AP's(rather Radio's) expected behaviour with these TLV's??

Thanks,

Sujay

 

My Location;

<http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.525085&t=
h&hl=en>
http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.724852,7.525085&t=h
&hl=en

---

From: ArchanaSuresh <[email-masked]>
Date: Fri, 24 Feb 2006 17:39:27 +0530

Hi,

As per draft CfgReq (ap- to ac), sends only Admin tlv.

Why admin tlv from ap to ac to inform the operating state of the radio?? 

As per draft CfgResp (ac- to AP), sends only Change state tlv.

Why change state tlv from ac to AP??   All Administrative configurations
from ac to ap for the radio state should get into the admin tlv

IT SHOULD BE Admin state TLV

As per draft CfgUpdReq (ac- to ap), sends both Change state tlv & admin tlv.

Why both are required from ac to ap??  

Only one can be used as like CfgResp either admin or chgstate tlv.

Regards,

Archana Suresh

-----Original Message-----

Hi Group,

As per;

1- Enabled 

2- Disabled

Compare to;

7.3.2 Change State Event

1 - for Disabled

2 - for Enabled

 

 

Thanks,

Sujay

 

My Location;