Subject: RE: [Capwap] Join to Image Data

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 6 Feb 2006 08:48:20 -0800

I disagree. I believe that the best state transition to get firmware
downloaded is post join. My main concern is pushing the firmware
download in the Run state is that it minimizes the impact of protocol
changes to Discovery and Join. So if an AC is running code that is
drastically different from what's on the WTP, you really only need to
worry about backward compatibility in those two messages, vs. possibly
every message defined in the protocol. 

This was my main objection to the evaluation team's request to allow the
Run->Image Data state transition.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Wednesday, February 01, 2006 2:00 PM
> To: [email-masked]
> Subject: [Capwap] Join to Image Data
> 
> HI,
> 
> The LWAPP State Machine in figure 2 has the transition 
> labelled "m" that is Join to Image Data. This transition is 
> not described, and it seems inappropriate.
> I believe that it should be removed.
> 
> Regards,
> /david t. perkins 
> 
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
> 
> Archives: http://lists.frascone.com/pipermail/capwap
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 6 Feb 2006 10:08:15 -0800 (PST)

HI,

I'm confused. I'm looking at the LWAPP-03 draft and the
state diagram in figure 2 and the descriptions of the
states transitions that follow. The join state has
a transition labeled "m" that goes to the image data
state. I couldn't find a description of that transition.
It also has a transition labeled "z" that goes
to the Join-Confirm state. In the descriptions,
it didn't seem like the "m" transition would
ever occur. What I'm I missing?

In general, it seems like that there are many different
understandings, instead of a single one as to what
resources and boot model is supported by the CAPWAP
protocol. I'll follow up later today on this with 
details. However, I was confused whether or not
a WTP is always running the "boot loader" code
in the Discovery, Join, Image Data, and Join-Confirm
states, and when is a switch made to the
"system image" code. I was assuming that
happened in the transition from Join-Confirm
to Configure.

As Pat points out, and which I agree, one certainly
wants to minimize the ammount of "knowledge" in
the boot loader so that 1) it's complexity and
memory footprint are minimized, 2) to isolate
it from changes in the CAPWAP protocol (so support
going from a very old CAPWAP version to a very
new CAPWAP version). 

Regards,
/david t. perkins