Subject: [Capwap] I recommend LWAPP add a new notification message "Gratuitous disconnect notification"

From: zhaoyujin 31390 <[email-masked]>
Date: Tue, 07 Feb 2006 22:20:08 +0500

Hi:

  Many protocol defines "Gratuitous notification message". Based on this message, the peer device can avoid to wait timeout for detecting the protocol is down and release the system resource. 

  At present, LWAPP defines "Reset AP", I think it is not enough.

  Can LWAPP add a same message. Before AP reboots, it try to send a "Gratuitous notification message" to AC. And same for AC.

Best regards
Micheal

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 7 Feb 2006 09:29:41 -0800

If I understand properly, you are asking for a response to the Reboot
request, to allow the AC to immediately clear out its state?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: zhaoyujin 31390 [mailto:[email-masked]] 
> Sent: Tuesday, February 07, 2006 9:20 AM
> To: [email-masked]
> Subject: [Capwap] I recommend LWAPP add a new notification 
> message "Gratuitous disconnect notification"
> 
> Hi:
> 
>   Many protocol defines "Gratuitous notification message". 
> Based on this message, the peer device can avoid to wait 
> timeout for detecting the protocol is down and release the 
> system resource. 
> 
>   Can LWAPP add a same message. Before AP reboots, it try to 
> send a "Gratuitous notification message" to AC. And same for AC.
> 
> Best regards
> Micheal
>

---

From: zhaoyujin 31390 <[email-masked]>
Date: Wed, 08 Feb 2006 13:14:26 +0500

> request, to allow the AC to immediately clear out its state?

This is only one application.
Aother scenario:

Because AP occurs some fatal error, it maybe restart the system of AP. Before this operation, I recommend AP need try to notify AC this information. Based on this, AC can immediately clear out its state.

Best regards
Michael

> > From: zhaoyujin 31390 [[email-masked]]

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 15 Feb 2006 08:59:35 -0800

Issue 75 has been created to track this issue.

Pat Calhoun

> Sent: Wednesday, February 08, 2006 12:14 AM
> To: Pat Calhoun (pacalhou)
> Cc: [email-masked]
> Subject: Re:RE: [Capwap] I recommend LWAPP add a new 
> notification message "Gratuitous disconnect notification"
> 
> 
> 
> Because AP occurs some fatal error, it maybe restart the 
> system of AP. Before this operation, I recommend AP need try 
> to notify AC this information. Based on this, AC can 
> immediately clear out its state.
> 
> Best regards
> Michael
> 
> 
> 
> 
> > 
> > Pat Calhoun
> > CTO, Wireless Networking Business Unit Cisco Systems
> > 
> > 
> > 
> > > Subject: [Capwap] I recommend LWAPP add a new 
> notification message 
> > > "Gratuitous disconnect notification"
> > > 
> > > Hi:
> > > 
> timeout for 
> > > detecting the protocol is down and release the system resource.
> > > 
> > >   Can LWAPP add a same message. Before AP reboots, it try 
> to send a 
> > > "Gratuitous notification message" to AC. And same for AC.
> > > 
> > > Best regards
> > > Micheal
> > >