Subject: [Capwap] Join to Image Data

From: "David T. Perkins" <[email-masked]>
Date: Wed, 1 Feb 2006 13:59:46 -0800 (PST)

HI,

The LWAPP State Machine in figure 2 has the transition
labelled "m" that is Join to Image Data. This transition
is not described, and it seems inappropriate.
I believe that it should be removed.

Regards,
/david t. perkins 

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Scott G. Kelly" <[email-masked]>
Date: Mon, 6 Feb 2006 09:24:20 -0800 (GMT-08:00)

This touches on one of the questions Nancy raised about the dtls draft, so now's as good a time as any to bring this up. Nancy wanted to know why there was a similar transition proposed there. I put it there because it seemed to me that to upgrade from the current lwapp to an lwapp-dtls system without a manual reflash, the ability to upgrade the firmware without explicitly joining would be required. Of course, I assumed the image would be signed, but now I'm not so sure such a requirement belongs in the capwap protocol.

How do you deal with this issue if you don't require signing? Do you (a) require a manual re-flash if the join transaction becomes incompatible? Seems like the only other alternatives are (b) require firmware signing, or (c) require a compatibility mode. 

Seems like (c) imposes undue economic pressure on people who are implementing from scratch, and it's not clear to me that (b) would be appropriate. I'm thinking (a) is the only reasonable path forward. Thoughts?

-----Original Message-----
>From: "Pat Calhoun (pacalhou)" <[email-masked]>
>Sent: Feb 6, 2006 8:48 AM
>To: "David T. Perkins" <[email-masked]>, [email-masked]
>Subject: RE: [Capwap] Join to Image Data
>
>I disagree. I believe that the best state transition to get firmware
>downloaded is post join. My main concern is pushing the firmware
>download in the Run state is that it minimizes the impact of protocol
>changes to Discovery and Join. So if an AC is running code that is
>drastically different from what's on the WTP, you really only need to
>worry about backward compatibility in those two messages, vs. possibly
>every message defined in the protocol. 
>
>This was my main objection to the evaluation team's request to allow the
>Run->Image Data state transition.
>
>Pat Calhoun
>CTO, Wireless Networking Business Unit
>Cisco Systems
>
> 
>
>> -----Original Message-----
>> From: David T. Perkins [mailto:[email-masked]] 
>> Sent: Wednesday, February 01, 2006 2:00 PM
>> To: [email-masked]
>> Subject: [Capwap] Join to Image Data
>> 
>> HI,
>> 
>> labelled "m" that is Join to Image Data. This transition is 
>> not described, and it seems inappropriate.

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 6 Feb 2006 09:53:00 -0800

That's my thinking as well.

Pat Calhoun

> From: Scott G. Kelly [mailto:[email-masked]] 
> Sent: Monday, February 06, 2006 9:24 AM
> To: Pat Calhoun (pacalhou); David T. Perkins; [email-masked]
> This touches on one of the questions Nancy raised about the 
> dtls draft, so now's as good a time as any to bring this up. 
> Nancy wanted to know why there was a similar transition 
> proposed there. I put it there because it seemed to me that 
> to upgrade from the current lwapp to an lwapp-dtls system 
> without a manual reflash, the ability to upgrade the firmware 
> without explicitly joining would be required. Of course, I 
> assumed the image would be signed, but now I'm not so sure 
> such a requirement belongs in the capwap protocol.
> 
> How do you deal with this issue if you don't require signing? 
> Do you (a) require a manual re-flash if the join transaction 
> becomes incompatible? Seems like the only other alternatives 
> are (b) require firmware signing, or (c) require a 
> compatibility mode. 
> 
> Seems like (c) imposes undue economic pressure on people who 
> are implementing from scratch, and it's not clear to me that 
> (b) would be appropriate. I'm thinking (a) is the only 
> reasonable path forward. Thoughts?
> 
> labelled "m" 
> >> that is Join to Image Data. This transition is not 
> described, and it 
> >> seems inappropriate.

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Feb 2006 11:43:52 -0700

Scott:

Did you get my comments on the DTLS state machine?
I'm assuming you did based on these comments.

Sue Hares

-----Original Message-----
From: Scott G. Kelly [mailto:[email-masked]] 
Sent: Monday, February 06, 2006 12:24 PM
To: Pat Calhoun (pacalhou); David T. Perkins; [email-masked]
Subject: RE: [Capwap] Join to Image Data

This touches on one of the questions Nancy raised about the dtls draft,
so now's as good a time as any to bring this up. Nancy wanted to know
why there was a similar transition proposed there. I put it there
because it seemed to me that to upgrade from the current lwapp to an
lwapp-dtls system without a manual reflash, the ability to upgrade the
firmware without explicitly joining would be required. Of course, I
assumed the image would be signed, but now I'm not so sure such a
requirement belongs in the capwap protocol.

How do you deal with this issue if you don't require signing? Do you (a)
require a manual re-flash if the join transaction becomes incompatible?
Seems like the only other alternatives are (b) require firmware signing,
or (c) require a compatibility mode. 

Seems like (c) imposes undue economic pressure on people who are
implementing from scratch, and it's not clear to me that (b) would be
appropriate. I'm thinking (a) is the only reasonable path forward.
Thoughts?

---

From: "Scott G. Kelly" <[email-masked]>
Date: Mon, 6 Feb 2006 12:17:52 -0800 (GMT-08:00)

Yes, I received your edits in the .doc file. I may have confused you and Nancy in my comments below, but either way, one (or perhaps both) of you noted this issue, and it is being addressed.

We hope to finish up edits based on both of your comments within the next few days.

-----Original Message-----
>From: Susan Hares <[email-masked]>
>Sent: Feb 6, 2006 10:43 AM
>To: "Scott G. Kelly" <[email-masked]>, "Pat Calhoun (pacalhou)" <[email-masked]>, "David T. Perkins" <[email-masked]>, [email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Feb 2006 13:35:47 -0700

Scott:

My issues were a bit more far reaching in the word document.
Please check that you have the word document.
I will resend to list in non-word document format.

Sue

-----Original Message-----
From: Scott G. Kelly [mailto:[email-masked]] 
Sent: Monday, February 06, 2006 3:18 PM
To: Susan Hares; Pat Calhoun (pacalhou); David T. Perkins;
[email-masked]"capwap"
Subject: RE: [Capwap] Join to Image Data

Yes, I received your edits in the .doc file. I may have confused you and
Nancy in my comments below, but either way, one (or perhaps both) of you
noted this issue, and it is being addressed.

We hope to finish up edits based on both of your comments within the
next few days.

-----Original Message-----
>To: "Scott G. Kelly" <[email-masked]>, "Pat Calhoun (pacalhou)"
<[email-masked]>, "David T. Perkins" <[email-masked]>,
[email-masked]

---

From: "Scott G. Kelly" <[email-masked]>
Date: Mon, 6 Feb 2006 12:56:32 -0800 (GMT-08:00)

Yes, I have it.

-----Original Message-----
>Sent: Feb 6, 2006 12:35 PM