Subject: Re: [Capwap] Clarification for Echo Request update - Issue 45

From: "Dorothy Stanley" <[email-masked]>
Date: Wed, 24 May 2006 08:58:57 -0700

Saravanan, all,

Agree that documenting the design choice is a good idea.

I suggest that a better place for the proposed text is in section 7, Control
Channel
Management, since the "operational" indication can come via control messages

other than just WTP Event Request. Section 7 defines the Echo Request and
Response messages.

Propose to change the first (and only) paragraph in Section 7

From:

"The Control Channel Management messages are used by the WTP and AC to
maintain a control communication channel."

To

"The Control Channel Management messages are used by the WTP and AC to
maintain a control communication channel. CAPWAP control messages, such as
the
WTP Event Request message sent from the WTP to the AC indicate to the AC
that the
WTP is operational. When such control messages are not being sent,
the Echo Request and Echo Response messages are used to maintain the control
communication channel.

Dorothy

On 5/23/06, Saravanan Govindan <[email-masked]> wrote:
>
> All,
>
> I want to propose an update to the text for Issue 45 on combining
> messages.
>
> In addition to the recent updates, I think it is important to clarify
> the design choice behind the changes.
>
> In Section 9.5 "WTP Event Request" of Specifications v01, I propose the
> following;
>
>
>    9.5.  WTP Event Request
>
>    WTP Event Request message is used by a WTP to send information to its
>    AC.  The WTP Event Request message may be sent periodically, or sent
>    in response to an asynchronous event on the WTP.  For example, a WTP
>    MAY collect statistics and use the WTP Event Request message to
>    transmit the statistics to the AC.
>
>    [PROPOSED TEXT]
>
>    WTP Event Request messages together with other control messages from
> a
>    WTP indicate operational capacity of that WTP. This presumes that a
> WTP
>    capable of sending periodic control messages (such as statistics) or
>
>    irregular control messages (such as errors) is operational. In the
> case
>    where regular control messages are not sent, an operational WTP sends
> the
>    Echo Request message to indicate operational readiness.
>
>    ----XXXX----
>
> Comments?
>
> Saravanan
>
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 24 May 2006 09:04:55 -0700

Works for me.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Dorothy Stanley [mailto:[email-masked]] 
	Sent: Wednesday, May 24, 2006 8:59 AM
	To: Saravanan Govindan
	Cc: capwap
	Subject: Re: [Capwap] Clarification for Echo Request update -
Issue 45

	Saravanan, all,

	I suggest that a better place for the proposed text is in
section 7, Control Channel
	Management, since the "operational" indication can come via
control messages 
	other than just WTP Event Request. Section 7 defines the Echo
Request and Response messages.

	From:
	
	"The Control Channel Management messages are used by the WTP and
AC to
	maintain a control communication channel."
	
	To
	
	"The Control Channel Management messages are used by the WTP and
AC to
	maintain a control communication channel. CAPWAP control
messages, such as the
	WTP Event Request message sent from the WTP to the AC indicate
to the AC that the 
	WTP is operational. When such control messages are not being
sent,
	the Echo Request and Echo Response messages are used to maintain
the control
	communication channel.

	Dorothy

	On 5/23/06, Saravanan Govindan
<[email-masked]> wrote: 

		All,
		
		I want to propose an update to the text for Issue 45 on
combining
		messages.
		
		In addition to the recent updates, I think it is
important to clarify
		the design choice behind the changes.
		
		In Section 9.5 "WTP Event Request" of Specifications
v01, I propose the
		following;

		   9.5.  WTP Event Request
		
		   WTP Event Request message is used by a WTP to send
information to its
		   AC.  The WTP Event Request message may be sent
periodically, or sent
		   in response to an asynchronous event on the WTP.  For
example, a WTP 
		   MAY collect statistics and use the WTP Event Request
message to
		   transmit the statistics to the AC.
		
		   [PROPOSED TEXT]
		
		   WTP Event Request messages together with other
control messages from
		a 
		   WTP indicate operational capacity of that WTP. This
presumes that a
		WTP
		   capable of sending periodic control messages (such as
statistics) or
		
		   irregular control messages (such as errors) is
operational. In the 
		case
		   where regular control messages are not sent, an
operational WTP sends
		the
		   Echo Request message to indicate operational
readiness.
		
		   ----XXXX----
		
		Comments?
		
		Saravanan

_________________________________________________________________ 
		To unsubscribe or modify your subscription options,
please visit:
		http://lists.frascone.com/mailman/listinfo/capwap