Subject: Re: [Capwap] Insufficient description of WTPs during discovery

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 12 Sep 2006 11:21:22 -0700

> The reason is that it seems that there are two opposing views 
> as to who decides the binding between a WTP and AC, and also 
> two opposing views as to the ammount of information that 
> should be in discovery messages (which are sent "in the clear").
We discussed this during the DTLS adoption threads, and the comments by
both Scott and Charles stated this would be ok. If you feel this is
still an issue, and we made an incorrect decision, could you start a new
thread?

> 
> I suggest that we first list the scenarios, and then list the 
> possible aproaches. In doing this, all the assumptions need 
> to be made visible. For example, does an WTP have other 
> management interfaces (such as a CLI) or is CAPWAP the only 
> management interface to WTP? Does a WTP have "field 
> replacable units" so that different technologies for 
> interfaces can be installed, and thus making WTP model type 
> insufficient for determining the interfaces on a WTP? 
1. We have to assume a CAPWAP interface. We cannot assume any other
interface, but also cannot forbid it.
2. As an AC vendor, I can't keep track of what a WTP model means. I
don't plan to have that close of a relationship with all of the WTP
vendors. That said, the model number is useful to present to the end
user that uses the AC to monitor their network.

> 
> So, there are many items in the below that I fundamentally 
> disagree with, specifically "a WTP still makes the decision 
> as to which AC it will join". I do this because it can result 
> in nondetermanistic behavior, and can be a security risk. 
WTP must make the decision, but the AC helps provide guidance. 

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 12 Sep 2006 12:32:15 -0700 (PDT)

HI,

It appears that you might have misunderstood the first point,
and I was hoping for a lot more on the second point.

The first is not which entity establishes the DTLS sessionn
(but if you wish, we can revisit that discussion). The point
is how an WTP decides which AC to establish that session.
And yes, as long as a WTP establishes the session, it must
ultimately decide. The issue is how it decides. 

The CAPWAP-02 has the WTP deciding based on some AC
utilization info. I believe where there is a split in the WP
is whether or not AC utilization is appropriate factor in
a WTP's decision, and whether or not providing AC utlitzation
and WTP capabilities in the clear durring discovery is
appropriate.

For the second point, I was hope that you would list scenarios
like initial enrolement, reboot after saved config, referal
by another AC, recover after redeployment, etc.

> CTO, Wireless Networking Business Unit
Regards,
/david t. perkins