Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue 214 -Prioritization of IEEE 802.1X frames

From: "Cheng Hong" <[email-masked]>
Date: Tue, 26 Sep 2006 09:21:38 +0800

Hi Mike,
 
In this case, I tend to agree with the other Michael on the first point.

However, on the mapping 802.11e priority back to CAPWAP priority, I am
not really sure how that is done. Is it based on 802.11e AC or TID (UP)?
For later case, does it mean the WTP need to read into the QoS Control
Field?
 
cheers
 
Cheng Hong

  _____  

From: Michael Montemurro [mailto:[email-masked]] 
Sent: Tuesday, September 26, 2006 1:17 AM
To: Cheng Hong
Cc: zhaoyujin 31390; capwap
Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue
214 -Prioritization of IEEE 802.1X frames

Cheng Hong,
 
In the CAPWAP draft, both wireless data and management frames are
treated as CAPWAP data frames. Given that, all CAPWAP data traffic would
need to go to the same logical instance of the AC.
 
Cheers,
 
Mike

On 9/24/06, Cheng Hong <[email-masked]> wrote: 

Hi Michael & Michael,
 
Sorry if the issue has already been discussed before. Just thinking if
the WTP does not differentiate 802.1X frames from normal data frames,
would it be possible that the 802.1X frames being forwarded to a
different AC instance than the one processing the control/management
frames? (in case different ACs are used to process the control and data
channel) Is this acceptable?
 
cheers
 
Cheng Hong

  _____  

From: Michael Montemurro [mailto:[email-masked]] 
Sent: Sunday, September 24, 2006 3:18 AM
To: zhaoyujin 31390
Cc: capwap
Subject: Re: [Capwap] This is not need.: Proposed resolution to Issue
214 -Prioritization of IEEE 802.1X frames 

Michael,
 
Thanks. Is anybody else opinionated on this feature. 
 
Cheers,
 
Mike

On 9/23/06, zhaoyujin 31390 <[email-masked]
<mailto:[email-masked]> > wrote: 

Firstly, I have some doubt one this suggestion.

1. If CAPWAP difines like this, AP device must decode the payload frames
of 802.11 frames.
2. Another problem, the 802.1x priority should be implement by 802.11e.
When station sends 802.11 data frames, it can set 802.11e priority. AP
should transfer 802.11e to actual CAPWAP packet priority.

So that I think CAPWAP does not need consider the priority of 802.11
data frames payload. 

Thanks
Michael

>Practically speaking, IEEE 802.1X frames should be transmitted at the
same priority as >IEEE 802.11 Management frames.
>
>I will update Section 11.5, rename Quality of Service for IEEE 802.11
Control Messages >to "Quality
>of Service for IEEE 802.11 control messages and IEEE 802.1X EAPoL
frames" and add text to >indicate that IEEE 802.1X frames are sent at a
higher priority.
>Cheers,
>Mike

This e-mail and attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient's) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email 
immediately and delete it!

Practically speaking, IEEE 802.1X frames should be transmitted at the
same priority as IEEE 802.11 Management frames. 
 
I will update Section 11.5, rename Quality of Service for IEEE 802.11
Control Messages to "Quality
of Service for IEEE 802.11 control messages and IEEE 802.1X EAPoL
frames" and add text to indicate that IEEE 802.1X frames are sent at a
higher priority.
 
Cheers,
 
Mike

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap
<http://lists.frascone.com/pipermail/capwap> 

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Michael Montemurro" <[email-masked]>
Date: Tue, 26 Sep 2006 12:24:12 -0400

Cheng,

Thanks for you input.

Also, that's a good question. In my opinion, the CAPWAP priority should be
based on the TID(UP). Which means yes, the WTP would need to read into the
QoS control field.

Cheers,

Mike

On 9/25/06, Cheng Hong <[email-masked]> wrote:
> However, on the mapping 802.11e priority back to CAPWAP priority, I am not
> really sure how that is done. Is it based on 802.11e AC or TID (UP)? For
> later case, does it mean the WTP need to read into the QoS Control Field?
>
> cheers
>
> Cheng Hong
>
>
>
>  ------------------------------
> *From:* Michael Montemurro [mailto:[email-masked]]
> *Sent:* Tuesday, September 26, 2006 1:17 AM
> *To:* Cheng Hong
> *Cc:* zhaoyujin 31390; capwap
> *Subject:* Re: [Capwap] This is not need.: Proposed resolution to Issue
> In the CAPWAP draft, both wireless data and management frames are treated
> as CAPWAP data frames. Given that, all CAPWAP data traffic would need to go
> to the same logical instance of the AC.
>
> Cheers,
>
> Mike
>
>
>
> > different AC instance than the one processing the control/management frames?
> > (in case different ACs are used to process the control and data channel) Is
> > this acceptable?
> >
> > cheers
> >
> > Cheng Hong
> >
> >
> >
> >
> >  ------------------------------
> > *From:* Michael Montemurro [mailto:[email-masked]]
> > *Sent:* Sunday, September 24, 2006 3:18 AM
> > *To:* zhaoyujin 31390
> > *Cc:* capwap
> > *Subject:* Re: [Capwap] This is not need.: Proposed resolution to Issue
> > On 9/23/06, zhaoyujin 31390 <[email-masked] > wrote:
> > >
> > > 1. If CAPWAP difines like this, AP device must decode the payload
> > > frames of 802.11 frames.
> > > So that I think CAPWAP does not need consider the priority of 802.11data frames payload.
> > >
> > > Thanks
> > > Michael
> > >
> > >
> > >
> > > >I will update Section 11.5, rename Quality of Service for IEEE 802.11Control Messages >to "Quality
> > > frames" and add text to >indicate that IEEE 802.1X frames are sent at
> > > a higher priority.
> > > >
> > > >Cheers,
> > > >
> > > >Mike
> > >
> > >
> > > (including, but not limited to, total or partial disclosure, reproduction,
> > > or dissemination) by persons other than the intended recipient's) is
> > > prohibited. If you receive this e-mail in error, please notify the sender by
> > > phone or email
> > > I will update Section 11.5, rename Quality of Service for IEEE 802.11Control Messages to "Quality