Subject: Re: [Capwap] Issue 161: Ther term "Mobile" is not really accurate

From: "Dorothy Stanley" <[email-masked]>
Date: Fri, 1 Sep 2006 07:35:30 -0700

Pat, all,

How about

Wireless End Device (WED)? It captures the essential nature of the end
device: "wireless", and
it is not wireless-type specific.

It is better than

Station (an 802.11 term with specific meaning in .11 as Bob points out)
Mobile - since the end device may be but is not required to be able to move,
as noted by David
Wireless End Point (WEP) -  problematic in many ways.....
Mobile Unit  (MU) - again, the endpoint need not move. This would be my
second choice though, as it is more specific than just "mobile".

Dorothy

On 8/31/06, Pat Calhoun (pacalhou) <[email-masked]> wrote:
>
> Folks, I need a term.
>
> I don't care if it's foobar, but need something everyone will agree to.
> If station doesn't cut it, as bob insists, then I need something to work
> it.
>
> Help,
>
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
>
>
>
> > -----Original Message-----
> > From: David T. Perkins [mailto:[email-masked]]
> > Sent: Sunday, August 20, 2006 12:03 PM
> > To: Bob O'Hara (boohara)
> > Cc: Pat Calhoun (pacalhou); [email-masked]
> > Subject: Re: [Capwap] Issue 161: Ther term "Mobile" is not
> > really accurate
> >
> > HI,
> >
> > Bob can you suggest an appropriate term to use here. The term
> > "mobile" has dictionary meaning of moving. However, being
> > capable of moving is not the fundamental defining attribute
> > of the interface that differentiates from other technologies.
> >
> > Regards,
> > /david t. perkins
> >
> >
> > On Wed, 16 Aug 2006, Bob O'Hara (boohara) wrote:
> > > STOP!  Put that editor down and step away from the draft!
> > I think it
> > > is a big mistake to embed a term that is tied to a single
> > binding into
> > > the entirety of the draft.
> > >
> > >  -Bob
> > >
> > > -----Original Message-----
> > > From: Pat Calhoun (pacalhou)
> > > Sent: Tuesday, August 15, 2006 6:04 PM
> > > To: [email-masked]
> > > Subject: [Capwap] Issue 161: Ther term "Mobile" is not
> > really accurate
> > >
> > > The term "mobile" is not really accurate when describing wireless
> > > interfaces, since wireless does not imply mobile. Can we
> > just use the
> > > techie term "STA" instead.
> > >
> > > <PRC> In my honest opinion, this is one of those change
> > requests that
> > > is really unnecessary. Traditionally, the IETF has used the term
> > > mobile (e.g., mobile station in Mobile IP). However, given the
> > > comment, and the fact that the
> > > 802.11 WG uses the term station, or STA for short, I will
> > go ahead and
> > > make the change. Of course, the next binding technology may end up
> > > using different terminology (including mobile).
> > >
> > > This will, of course, touch nearly every section of the
> > specification
> > > (read: diffs will be more complex).
> > >
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems
> > > _________________________________________________________________
> > > To unsubscribe or modify your subscription options, please visit:
> > > http://lists.frascone.com/mailman/listinfo/capwap
> > >
> > > Archives: http://lists.frascone.com/pipermail/capwap
> > > _________________________________________________________________
> > > To unsubscribe or modify your subscription options, please visit:
> > > http://lists.frascone.com/mailman/listinfo/capwap
> > >
> > > Archives: http://lists.frascone.com/pipermail/capwap
> > >
> >
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 1 Sep 2006 10:16:23 -0700 (PDT)

HI,

All good points. One issue is that we are really talking about
interfaces. A good many number of devices that have a network
interface may have a single network interface, and that interface
can be be used to characterize the device as a Wireless end device.
However, other devices may have other network interfaces that
are not wireless. 

Regards,
/david t. perkins

---

From: "Dorothy Stanley" <[email-masked]>
Date: Tue, 5 Sep 2006 15:48:47 -0700

Hi David, all,

I am fine with using either

- Mobile Unit (MU) - a general term, describing the unit rather than any
interfaces, and
attributing the quality of mobility to the unit
- Wireless End Device - a general term, attributing the characteristic of
having a
wireless interface of the type of interest to CAPWAP, but not necessarily
having the
quality of mobility. Could also be Wireless End Unit.

True, there may be multiple interfaces on the device. From the perspective
of
CAPWAP, we are interested in devices that support a wireless interface of
interest.

Mobile Station - is close to what we have; the term "station" is overloaded
with
802.11 usage, potential confusion.
Mobile Node - prefer Mobile Unit, as "unit" connotes a device, "node" is
more general
Mobile Equipment - No particular benefit over Mobile unit
User Equipment - applicable to cellular networks, not as applicable to e.g.
RFID

Dorothy

---

From: "Michael Montemurro" <[email-masked]>
Date: Wed, 6 Sep 2006 16:34:44 -0400

>From what I remember (and have heard), the term Mobile Unit was used in IEEE
802.11 in the beginnings of the standard to refer to a WLAN device that
transitions between AP's.

Given that one of the main features of CAPWAP is mobility, it sounds that it
would be appropriate to use that term.

Then again, that term did not make it into the IEEE 802.11 standard.

Wireless End Device sounds cumbersome to me.

Cheers,

Mike

On 9/5/06, Dorothy Stanley <[email-masked]> wrote:
> Mobile Station - is close to what we have; the term "station" is
> overloaded with
> > > On 8/31/06, Pat Calhoun (pacalhou) < [email-masked]> wrote:
> > > >
> > > > Folks, I need a term.
> > > >

---

From: <[email-masked]>
Date: Wed, 6 Sep 2006 15:51:42 -0700

Hi Mike,
 
Of the terms below, Mobile Node (MN) is the most "standard-ish", and
crosses organizational boundaries nicely. It doesn't put any limitations
on the type of device...but makes it clear it's a single device... it
provides an abstraction without adding additional constraints.
 
The most popular by far is Mobile Device (MD), not on the list below.
User Equipment (UE) comes right behind  it in terms of frequency of
usage in our broad context. End Device (ED) is just after that in
popularity, but goes beyond our context a bit.
 
Mobile Unit is most often used in the sense of a group of things moving
around together as a unit, not really what we want.
Mobile Equipment most commonly connotes something like a vehicle, also
not what we want.
 
I'd suggest MN, MD, UE and ED in that order of priority.
 
Best Regards,
Michael

________________________________

From: ext Michael Montemurro [mailto:[email-masked]] 
Sent: Wednesday, September 06, 2006 1:35 PM
To: Dorothy Stanley
Cc: [email-masked]
Subject: Re: [Capwap] Issue 161: Ther term "Mobile" is not really
accurate

>From what I remember (and have heard), the term Mobile Unit was used in
IEEE 802.11 in the beginnings of the standard to refer to a WLAN device
that transitions between AP's.

Given that one of the main features of CAPWAP is mobility, it sounds
that it would be appropriate to use that term.

 
Cheers,
 
Mike

	Hi David, all,

	- Mobile Unit (MU) - a general term, describing the unit rather
than any interfaces, and
	attributing the quality of mobility to the unit
	- Wireless End Device - a general term, attributing the
characteristic of having a 
	wireless interface of the type of interest to CAPWAP, but not
necessarily having the
	quality of mobility. Could also be Wireless End Unit.

	True, there may be multiple interfaces on the device. From the
perspective of 
	CAPWAP, we are interested in devices that support a wireless
interface of interest.
	
	Mobile Station - is close to what we have; the term "station" is
overloaded with 
	802.11 usage, potential confusion. 
	Mobile Node - prefer Mobile Unit, as "unit" connotes a device,
"node" is more general
	Mobile Equipment - No particular benefit over Mobile unit
	User Equipment - applicable to cellular networks, not as
applicable to e.g. RFID 

	Dorothy

	On 9/1/06, David T. Perkins <[email-masked] > wrote: 

		HI,
		
		All good points. One issue is that we are really talking
about
		interfaces. A good many number of devices that have a
network 
		interface may have a single network interface, and that
interface
		can be be used to characterize the device as a Wireless
end device. 
		However, other devices may have other network interfaces
that
		are not wireless. 
		
		Regards,
		/david t. perkins

		> > > > Archives:
http://lists.frascone.com/pipermail/capwap
		> > > > Archives:
http://lists.frascone.com/pipermail/capwap

	
_________________________________________________________________
	To unsubscribe or modify your subscription options, please
visit:
	http://lists.frascone.com/mailman/listinfo/capwap

---

From: "Hasan Raza" <[email-masked]>
Date: Fri, 8 Sep 2006 08:03:23 -0700

Hi,

I feel that there are few ambiguities in the capwap 02 draft related
to the tunnel creation and data plane policy negotiation. Forgive me
if these points have already been brought up and discussed over this
list.

1. Draft -02 does not talk about when the capwap data tunnel is
   created or deleted. Is it implicitly assumed that data tunnel is
   created once WTP and AC reach join state?

2. From the draft, WTP can encapsulate and tunnel wireless packets
    differently for different wlans. That is why, tunnel mode is passed
    to WTP in dot11 add wlan message element.

    But how different type of tunneled packets are identified over
    the data plane? For e.g., bss0 tunnels 802.3 frames whereas,
    bss1 tunnels 802.11 frame. So when a capwap data packet
    arrives at AC, how the employed tunnel mode is identified?
    Capwap transport header does not carry any payload
    encapsulation type. Moreover, the radio mac address optional
    field in capwap transport header may need to carry bssid instead
    of radio address -- there are multiple bss on a radio.

3. Draft does not also talk about how WTP is informed whether DTLS
    is used over data channel or not. Since it is a modifiable parameter,
    administrator can decide to turn on DTLS for say wtp0. But how wtp0
    would know that administrator has changed this setting? wtp0 might
    still be sending plain packets which get discarded by the AC. Actually AC
    should inform this change over the capwap control plane to the WTP.
    But there is no such notification to WTP for this.

Is that the data plane policy is supposed to be vendor specific information,
and it is exchanged through vendor specific payload message element?

Thanks
Hasan