Subject: [Capwap] Ambiguities with DTLS

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Thu, 14 Sep 2006 09:21:46 -0700

The current draft seems to be ambiguous with respect to two DTLS items.

The draft says in the section describing the stat machine transitions:
Idle to Init (Z): This transition indicates the beginning of a DTLS
session.

WTP: The state transition is triggered by receipt of the DTLSStart
command from the CAPWAP state machine, and causes the WTP to send a DTLS
ClientHello to the AC.

AC: The state transition is triggered by receipt of the DTLSStart
command from the CAPWAP state machine. The AC starts the WaitJoin timer
and awaits reception of a DTLS ClientHello message.

In the description of transition aa, the draft says:
AC: Upon receipt of a ClientHello message containing a valid cookie, the
AC sets the WaitJoin timer.  

These two transitions seem to require "starting" or "setting" the
Waitjoin timer in the AC both before and after the receipt of the
ClientHello message.  I believe the text in transition z is correct and
should either be reflected in the description of transition aa, or
removed from it to avoid conflict.

The draft also says, in the description of transition o, that the WTP
should send DTLSReset to the state machine.  Should this be
DTLSShutdown?

 -Bob

Bob O'Hara
Cisco Systems - WNBU

Phone:  +1 408 853 5513
Mobile: +1 408 218 4025
 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 14 Sep 2006 09:50:19 -0700

Tracker issue 220 created.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: Bob O'Hara (boohara) 
> Sent: Thursday, September 14, 2006 9:22 AM
> To: [email-masked]
> Subject: [Capwap] Ambiguities with DTLS
> 
> Idle to Init (Z): This transition indicates the beginning of 
> a DTLS session.
> 
> WTP: The state transition is triggered by receipt of the 
> DTLSStart command from the CAPWAP state machine, and causes 
> the WTP to send a DTLS ClientHello to the AC.
> 
> AC: The state transition is triggered by receipt of the 
> DTLSStart command from the CAPWAP state machine. The AC 
> starts the WaitJoin timer and awaits reception of a DTLS 
> ClientHello message.
> 
> AC: Upon receipt of a ClientHello message containing a valid 
> cookie, the AC sets the WaitJoin timer.  
> 
> These two transitions seem to require "starting" or "setting" 
> the Waitjoin timer in the AC both before and after the 
> receipt of the ClientHello message.  I believe the text in 
> transition z is correct and should either be reflected in the 
> description of transition aa, or removed from it to avoid conflict.
> 
> The draft also says, in the description of transition o, that 
> the WTP should send DTLSReset to the state machine.  Should 
> this be DTLSShutdown?
> 
>  -Bob
> 
> Bob O'Hara
> Cisco Systems - WNBU
> 
> Phone:  +1 408 853 5513
> Mobile: +1 408 218 4025
>