Subject: Re: [Capwap] Idle timeout

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 8 Jan 2007 08:25:46 -0800

Peter,
 
The WTP cannot forge an 802.11 deauth, because these frames will
eventually become encrypted. Therefore, they need to be transmitted by
the AC.
 
The Configuration Update Request (shown below) is a bi-directional
message, meaning that the WTP can send it as well as the AC. In the case
of an idle timeout (or for some other reason), it is used by the WTP to
communicate to the AC that a mobile station is no longer being serviced

<prc - existing text>
8.4.  Configuration Update Request

   Configuration Update Request messages are sent by the AC to provision
   the WTP while in the Run state.  This is used to modify the
   configuration of the WTP while it is operational.

   When an AC receives a Configuration Update Request message it will
   respond with a Configuration Update Response message, with the
   appropriate Result Code.
[...]
</prc - existing text>

The Delete Station is how this would be communicated, but the current
text does not really make this clear, so I am proposing adding a
paragraph to the spec:

<prc - existing text>
4.4.18.  Delete Station

   The Delete Station message element is used by the AC to inform an WTP
   that it should no longer provide service to a particular station.
   The WTP must terminate service immediately upon receiving this
   message element.

   The transmission of a Delete Station message element could occur for
   various reasons, including for administrative reasons, as a result of
   the fact that the station has roamed to another WTP, etc.
</prc - existing text>

<prc - new text>
   The Delete Station message element MAY be sent by the WTP to inform
the
   AC that a particular station is no longer being provided service.
This
   could occur as a result of an Idle Timeout (see section 4.4.43), due
   to internal resource shortages or for some other reason.
</prc - new text>

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Peter Nilsson J (LI/EAB)
[mailto:[email-masked]] 
	Sent: Wednesday, December 20, 2006 11:44 PM
	To: [email-masked]
	Subject: [Capwap] Idle timeout

	The Idle Timeout message element defines the timeout that the
WTP shall use to enforce for its active station entries. 
	But I can not see anywhere in the specification what happens
when the timeout expires for a station. 
	Will the WTP forge a 802.11 De-authenticate frame and send to
the AC or what? 

	Peter Nilsson 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 8 Jan 2007 08:37:16 -0800

BTW, I created issue 233.

Pat Calhoun

> -----Original Message-----
> From: Pat Calhoun (pacalhou) 
> Sent: Monday, January 08, 2007 8:26 AM
> To: Peter Nilsson J (LI/EAB); [email-masked]
> Subject: Re: [Capwap] Idle timeout
> 
> Peter,
>  
> The WTP cannot forge an 802.11 deauth, because these frames 
> will eventually become encrypted. Therefore, they need to be 
> transmitted by the AC.
>  
> The Configuration Update Request (shown below) is a 
> bi-directional message, meaning that the WTP can send it as 
> well as the AC. In the case of an idle timeout (or for some 
> other reason), it is used by the WTP to communicate to the AC 
> that a mobile station is no longer being serviced
> 
> <prc - existing text>
> The Delete Station is how this would be communicated, but the 
> current text does not really make this clear, so I am 
> proposing adding a paragraph to the spec:
> 
> <prc - existing text>
> 4.4.18.  Delete Station
> 
>    The Delete Station message element MAY be sent by the WTP 
> to inform the
> 	The Idle Timeout message element defines the timeout 
> that the WTP shall use to enforce for its active station entries. 
> 	But I can not see anywhere in the specification what 
> happens when the timeout expires for a station. 
> 	Will the WTP forge a 802.11 De-authenticate frame and 
> send to the AC or what? 
> 
> 	Peter Nilsson

---

From: "Peter Nilsson J (LI/EAB)" <[email-masked]>
Date: Tue, 9 Jan 2007 13:00:27 +0100

This would work for me if it is true that Configuration Update Request
is bi-directional, which is not easy to read out from the spec.
 
I have been reading the following text as AC was misstyped and should
have been replaced by WTP.
   "When an AC receives a Configuration Update Request message it will
   respond with a Configuration Update Response message, with the
   appropriate Result Code."

As a reference I would interpret the corresponding text for
Configuration Update Response that Configuration Update Response to be
uni-directional WTP -> AC.

Peter

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: den 8 januari 2007 17:26
To: Peter Nilsson J (LI/EAB); [email-masked]
Subject: RE: [Capwap] Idle timeout

Peter,

<prc - existing text>

<prc - existing text>
4.4.18.  Delete Station

<prc - new text>

Pat Calhoun

	Peter Nilsson

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 9 Jan 2007 08:33:59 -0800

I don't believe it was a typo. However, we can certainly clarify the
text to make it less ambiguous.

Pat Calhoun

> From: Peter Nilsson J (LI/EAB) [mailto:[email-masked]] 
> Sent: Tuesday, January 09, 2007 4:00 AM
> To: Pat Calhoun (pacalhou); [email-masked]
> This would work for me if it is true that Configuration 
> Update Request is bi-directional, which is not easy to read 
> out from the spec.
>  
> I have been reading the following text as AC was misstyped 
> and should have been replaced by WTP.
> Configuration Update Response that Configuration Update 
> Response to be uni-directional WTP -> AC.
> 
> Peter
> 
>

---

From: "Peter Nilsson J (LI/EAB)" <[email-masked]>
Date: Wed, 10 Jan 2007 12:26:19 +0100

I would instead suggest that the WTP send the Delete Station message
element in an WTP Event Request message to indicate that a station has
been removed from the WTP, you could really see this as an event
occuring in the WTP.

And I suggest that Configuration Update Request is clearly defined to be
uni-directional AC -> WTP which I think the CAPWAP specification is
saying with the exeption you are pointing out.

Peter

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: den 9 januari 2007 17:34
To: Peter Nilsson J (LI/EAB); [email-masked]
Subject: RE: [Capwap] Idle timeout

Pat Calhoun

> message, meaning that the WTP can send it as well as the AC. In the 
> case of an idle timeout (or for some other reason), it is used by the 
> WTP to communicate to the AC that a mobile station is no longer being 
> serviced
> 
> <prc - existing text>

> CTO, Wireless Networking Business Unit Cisco Systems
> 
>  
> 
> 
WTP 
> shall use to enforce for its active station entries.
when the 
> timeout expires for a station.
the AC 
> or what?

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 10 Jan 2007 06:53:35 -0800

ohhh... I like that idea... a lot. So the proposed text would end up
being:

4.5.18.  Delete Station
[...]
   The Delete Station message element MAY be sent by the WTP, through
   the WTP Event Request, to inform the AC that a particular station is
   no longer being provided service.  This could occur as a result of an
   Idle Timeout (see section 4.4.43), due to internal resource shortages
   or for some other reason.

9.5.  WTP Event Request
[...]
   The presence of the Delete Station message element is used by the WTP
   to inform the AC that it is no longer providing service to the
   station.  This could be the result of an Idle Timeout (see
   Section 4.5.23), due to to resource shortages, or some other reason.

   o  Delete Station, see Section 4.5.18

Does that work?

Pat Calhoun

> Sent: Wednesday, January 10, 2007 3:26 AM
> I would instead suggest that the WTP send the Delete Station 
> message element in an WTP Event Request message to indicate 
> that a station has been removed from the WTP, you could 
> really see this as an event occuring in the WTP.
> 
> And I suggest that Configuration Update Request is clearly 
> defined to be uni-directional AC -> WTP which I think the 
> CAPWAP specification is saying with the exeption you are pointing out.
> 
> Peter
> 
> I don't believe it was a typo. However, we can certainly 
> clarify the text to make it less ambiguous.
> 
> Pat Calhoun
> Update Request
> Response to be
> >    The Delete Station message element is used by the AC to 
> inform an 
> > WTP
> >    various reasons, including for administrative reasons, 
> as a result 
> > of

---

From: "Peter Nilsson J (LI/EAB)" <[email-masked]>
Date: Fri, 12 Jan 2007 08:54:14 +0100

Looks good!

Peter 

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: den 10 januari 2007 15:54
To: Peter Nilsson J (LI/EAB); [email-masked]
Subject: RE: [Capwap] Idle timeout

4.5.18.  Delete Station
[...]

9.5.  WTP Event Request
[...]

Does that work?

Pat Calhoun

> And I suggest that Configuration Update Request is clearly defined to 
> be uni-directional AC -> WTP which I think the CAPWAP specification is