Subject: Re: [Capwap] Proposed Resolution to Issue 232: WTP Static IP Address, RSNA Error Report Text Error

From: "Partha Narasimhan" <[email-masked]>
Date: Tue, 9 Jan 2007 14:29:33 -0800

Maybe I am missing something here - if the protocol is running over IP
(i.e. if the WTP first needs an IP address to be able to communicate
with an AC), why do we see a need for sending IP address information to
the WTP? Does this belong in CAPWAP or should we use other existing
mechanisms (DHCP comes to mind) for these things.

Thanks

partha

________________________________

From: Dorothy Stanley [mailto:[email-masked]] 
Sent: Friday, January 05, 2007 2:54 PM
To: Peter Nilsson J (LI/EAB)
Cc: [email-masked]
Subject: [Capwap] Proposed Resolution to Issue 232: WTP Static IP
Address,RSNA Error Report Text Error

All,

Issue 232 is listed below:

In the description of the WTP Static IP Address Information it is said
that the

AC uses this to configure the IP address of the WTP

But the message element is not listed either as MUST or MAY for
Configuration

Status Response or Configuration Update Request

* The description of the IEEE 802.11 RSNA Error Report From Station is

The IEEE 802.11 RSN Error Report From Station message element is sent by
an AC

to an WTP to send RSN error reports to the AC. The WTP does not need to
transmit

any reports that do not include any failures. The fields from this
message

element come from the IEEE 802.11 Dot11RSNAStatsEntry table, see [3].

I guess it should say the  that it is sent by the WTP to the AC.

Moreover the message element is listed to be sent in Configuration
Update

Request but I guess it would be more appropriate to send it in WTP Event
Request

messages.

Proposed Resolution:

a) Add the WTP Static IP Address Information message element to the
Configuration Status Response and Configuration Update Request message
as 
an element that "MAY" be included in the message.

b) In the binding document, section 6.12, "IEEE 802.11 RSNA Error Report
from Station"
change the text to "sent by a WTP to an AC". Add the message element to
the list of
message elements that "MAY" be included in the ETP Event Request message
(section 5.8).

Comments welcome,

Thanks,

Dorothy Stanley

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 10 Jan 2007 06:55:15 -0800

Many enterprises want/need their infrastructure to have static
addresses. The purpose of this feature is to provide a solution to those
enterprises.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

	From: Partha Narasimhan [mailto:[email-masked]] 
	Sent: Tuesday, January 09, 2007 2:30 PM
	To: Dorothy Stanley; Peter Nilsson J (LI/EAB)
	Cc: [email-masked]
	Subject: Re: [Capwap] Proposed Resolution to Issue 232: WTP
Static IPAddress, RSNA Error Report Text Error

	Maybe I am missing something here - if the protocol is running
over IP (i.e. if the WTP first needs an IP address to be able to
communicate with an AC), why do we see a need for sending IP address
information to the WTP? Does this belong in CAPWAP or should we use
other existing mechanisms (DHCP comes to mind) for these things.

	Thanks

	partha

	From: Dorothy Stanley [mailto:[email-masked]] 
	Sent: Friday, January 05, 2007 2:54 PM
	To: Peter Nilsson J (LI/EAB)
	Cc: [email-masked]
	Subject: [Capwap] Proposed Resolution to Issue 232: WTP Static
IP Address,RSNA Error Report Text Error

	All,

	In the description of the WTP Static IP Address Information it
is said that the

	

	
	* The description of the IEEE 802.11 RSNA Error Report From
Station is
	
	The IEEE 802.11 RSN Error Report From Station message element is
sent by an AC
	
	to an WTP to send RSN error reports to the AC. The WTP does not
need to transmit

	any reports that do not include any failures. The fields from
this message
	
	element come from the IEEE 802.11 Dot11RSNAStatsEntry table, see
[3].

	Moreover the message element is listed to be sent in
Configuration Update
	
	Request but I guess it would be more appropriate to send it in
WTP Event Request
	
	messages.

	Proposed Resolution:
	
	a) Add the WTP Static IP Address Information message element to
the
	Configuration Status Response and Configuration Update Request
message as 
	an element that "MAY" be included in the message.
	
	b) In the binding document, section 6.12, "IEEE 802.11 RSNA
Error Report from Station"
	change the text to "sent by a WTP to an AC". Add the message
element to the list of
	message elements that "MAY" be included in the ETP Event Request
message (section 5.8).
	
	Comments welcome,
	
	Thanks,
	
	Dorothy Stanley