Subject: [Capwap] CAPWAP message formats

From: "David T. Perkins" <[email-masked]>
Date: Mon, 8 Jan 2007 16:06:02 -0800 (PST)

HI,

At the Nov 2007 IETF, the CAPWAP group met and Pat gave a presentation
on header formats. The presentation touched on issues and proposals
that I had sent in for the "MUX header" and CAPWAP message headers.
I was not provided a copy of the presentation beforehand to review,
and I was not present during the meeting, but listened to the audio.
During the presentation, I felt that Pat didn't understand several parts
of my proposals, and/or mischaracterized them. I tried to communicate
this to Margaret via email, but the time skew was too great to
resolve.

In looking at the issue tracker, I see that a big part of the
problem was that I had sent in a proposal for CAPWAP packet
headers, and had followed with updates after more analysis,
and the issue tracker was not updated to the latest version.
The latest version was JULY 23, 2006, with message in the
email archive of "Ver 4 or CAPWAP packet syntax". I believe
that I mistakenly indicated that the message was the old
one proposal from JUNE 25, 2006. I am sorry for this
mistake.

However, I still believe that there are problems with the
latest proposed format of CAPWAP packets and would like to
go over this design issue at the interim meeting.

I'll update my ver 4 proposal to make it a ver 5 proposal
and incorporate the "MUX header" (now called the "pre-header").

Regards,
/david t. perkins
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 8 Jan 2007 16:57:14 -0800

I would strongly urge the group to not try to wait until the interim to
address all issues. if you have issues with the currently proposed text,
which has been on the list for over 3 weeks, then I would ask that we
start the discussion now.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Monday, January 08, 2007 4:06 PM
> To: [email-masked]
> Subject: [Capwap] CAPWAP message formats
> 
> HI,
> 
> At the Nov 2007 IETF, the CAPWAP group met and Pat gave a 
> presentation on header formats. The presentation touched on 
> issues and proposals that I had sent in for the "MUX header" 
> and CAPWAP message headers.
> I was not provided a copy of the presentation beforehand to 
> review, and I was not present during the meeting, but 
> listened to the audio.
> During the presentation, I felt that Pat didn't understand 
> several parts of my proposals, and/or mischaracterized them. 
> I tried to communicate this to Margaret via email, but the 
> time skew was too great to resolve.
> 
> that I mistakenly indicated that the message was the old one 
> proposal from JUNE 25, 2006. I am sorry for this mistake.
> 
> latest proposed format of CAPWAP packets and would like to go 
> over this design issue at the interim meeting.
> 
> I'll update my ver 4 proposal to make it a ver 5 proposal and 
> incorporate the "MUX header" (now called the "pre-header").
> 
> Regards,
> /david t. perkins

---

From: "Puneet Agarwal" <[email-masked]>
Date: Mon, 8 Jan 2007 19:24:56 -0800

Hi Pat,

Jim Murphy's "Data channel keep-alive proposed text" would modify the
data packet format (as it proposes to remove the overhead of the session
id from every data packets while providing the keep-alive and binding
services).

I support Jim's proposal.

Thanks.

-Puneet 

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: Monday, January 08, 2007 4:57 PM
To: David T. Perkins; [email-masked]
Subject: Re: [Capwap] CAPWAP message formats

Pat Calhoun

> During the presentation, I felt that Pat didn't understand several 
> parts of my proposals, and/or mischaracterized them.
> I tried to communicate this to Margaret via email, but the time skew 
> was too great to resolve.
> 
> In looking at the issue tracker, I see that a big part of the problem 
> was that I had sent in a proposal for CAPWAP packet headers, and had 
> followed with updates after more analysis, and the issue tracker was 
> not updated to the latest version.
> The latest version was JULY 23, 2006, with message in the email 
> archive of "Ver 4 or CAPWAP packet syntax". I believe that I 
> mistakenly indicated that the message was the old one proposal from 
> JUNE 25, 2006. I am sorry for this mistake.
> 
> However, I still believe that there are problems with the latest 
> proposed format of CAPWAP packets and would like to go over this 
> design issue at the interim meeting.
>

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 12 Jan 2007 15:23:01 -0500

Hi David,

Is it possible for you to send e-mail to the WG that contains a list  
of the specific problems that you see with the headers that Pat has  
most recently proposed, including a suggestion for how to fix each  
problem?  I think it would be more constructive, at this point, to  
propose specific changes to the headers Pat circulated than to make a  
completely separate header proposal.

Margaret

On Jan 8, 2007, at 7:06 PM, David T. Perkins wrote:

> parts