Subject: [Capwap] CAPWAP and congestion control

From: "Abhijit Choudhury (achoudhu)" <[email-masked]>
Date: Tue, 7 Aug 2007 16:44:56 -0700

Another issue that the transport A-Ds raised was that 
congestion control needs to be considered for CAPWAP.
The concern was that in case of congestion in the network,
packets could get discarded and the sources may not be 
notified or may not realize it. This could lead to 
congestion collapse and fairness issues.
 
In reality, almost all data traffic being tunneled over
CAPWAP is IP.  Note that the CAPWAP tunnel is 
between the WTP and AC only. TCP already has its own congestion
control mechanism between the source and the sink, and 
I'd argue that creating another congestion control loop 
in the path would interfere with TCP's congestion control loop
and lead to undesirable effects.  
 
I'd suggest we add a Transport Considerations section
to the CAPWAP spec recommending that non-IP traffic not be
sent over the Internet when using CAPWPAP.
Some proposed text is provided below.
 
Thoughts/comments ?
 
Thanks,
Abhijit 
 
-------------PROPOSED TEXT ---------------
 
Transport Considerations
 
The CAPWAP protocol does not provide a congestion control mechanism.
The underlying assumption is that data being tunneled by CAPWAP is 
IP. Since it is essentially a tunneling protocol between two
intermediate
points in the path between the wireless client and the end host, it 
was felt that having a separate congestion control for CAPWAP would 
actually interfere with the congestion control mechanisms already
in place.
 
In order to prevent congestion collapse and fairness issues from
happening in the Internet, it is recommended that non-IP traffic
not be tunneled over CAPWAP.
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 28 Aug 2007 17:00:16 -0700

Any objections before I go ahead and change the spec? Do we want to run
this by the transport ADs and advisors?
 
PatC

________________________________

From: Abhijit Choudhury (achoudhu) 
Sent: Tuesday, August 07, 2007 4:45 PM
To: capwap
Subject: [Capwap] CAPWAP and congestion control

 
 
Thoughts/comments ?
 
Thanks,
Abhijit 
 
-------------PROPOSED TEXT ---------------
 
Transport Considerations