Subject: [Capwap] Which one is preferred between capwapBase and cwb

From: young <[email-masked]>
Date: Fri, 26 Sep 2008 08:59:13 +0800

Dear Dan and David:
For me, either capwapBase or cwb as prefix is ok. 
CapwapBase prefix is seemed a bit longer.
Cwb prefix does not use all first character of "Control And Provisioning of
Wireless Access Points". 
Kindly suggest which one is better?
Regards
Richard

-----邮件原件-----
发件人: Chris Elliott [mailto:[email-masked]] 
发送时间: 2008年9月25日 23:33
收件人: young
抄送: [email-masked]; 'Yong Zhang'
主题: Re: Kindly give some suggestion for TC in MIBs

Richard,

I'd recommend something like your second method, method b.

Also, as a base name, "capwapBase" sees too long to me as it leads to  
very long object names. Inside Cisco, we usually shorten the prefix to  
only the initials. In this case, you could use "cwb", for example.  
Names in SNMP do not have to be unique, but it is desirable that they  
are. I don't see any standard MIB modules using "cwb" as a prefix.  
There are a couple of Cisco-proprietary MIB modules using "cwb",  
however, they only use it in the conformance/compliance sections and  
they only use "cwbAtm", "cwbIlmi", and "cwbPort".

Chris.

On Sep 24, 2008, at 9:07 PM, young wrote:

> HI,
> Yong joined the MIB works, and became co-editors of MIB drafts.
> We have done lots of improvement work these days.
> We have some questions and hope mailing list could give some  
> suggestion.
> I will send separated email about each question in the mailing list.
> Kindly give your response.
>
> Now, most TCs have the following problem:
> 1. smilint complains about:
> mibs/CAPWAP-MIB:314: [5] {identifier-case-match} warning: identifier
> `capwapWTPId' differs from `CapwapWTPId' only in case
> * CapwapWTPId is an example.
>
> Now, there are two methods here.
> a)       Rename object
> In the new version of Base MIB draft, we intend to use capwapBase as  
> prefix to MIB
> Objects. We could keep current TC ” CapwapWTPId”,and rename object  
> “capwapWtpId”
> as “capwapBaseWtpId”.
> The problem is: TC doesn’t use CapwapBase as prefix, then TC and  
> object will use different prefix
> (except first character in the prefix)) whether this way is  
> acceptable or not?
>
> b)       Rename object
> TC “CapwapWTPId' is rename as CapwapBaseWTPId to follow prefix rule  
> mentioned above.
> Object of capwapBaseWtpId is renamed as capwapBaseWtpObj.
> If use this method, we have to ensure the name of object is good  
> enough.
> The new name is good ?
>
> Please suggest which method is better or you have some other  
> suggestion?
>
> Regards
> Richard
>
>
>

--
Chris Elliott
CCIE# 2013
RTP, NC, USA
+1-919-392-2146
[email-masked]

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Yong Zhang" <[email-masked]>
Date: Thu, 25 Sep 2008 19:05:16 -0700

Can we use cwBase? We can also use cwDot11 for capwapDot11.

Do these short names also apply for the TC? or just for the objects?

Yong

2008/9/25 young <[email-masked]>:
>> Objects. We could keep current TC " CapwapWTPId",and rename object
>> "capwapWtpId"
>> as "capwapBaseWtpId".
>> The problem is: TC doesn't use CapwapBase as prefix, then TC and
>> TC "CapwapWTPId' is rename as CapwapBaseWTPId to follow prefix rule
>> mentioned above.

---

From: "David Harrington" <[email-masked]>
Date: Fri, 26 Sep 2008 10:32:35 +0300

Hi,

I don't see much benefit to shorter names. I would much prefer
meaningful names.
capwapBaseXXX seems a lot more meaningful than cwb or cwBase.
The OPS area has learned that readability should be a prime concern.
The biggest users of MIB documents are operators, and they are often
using them when troubleshooting problems. You want names that are
meaningful - quickly - to operators.

The MIB module should be named something so an operator looking at
object names on an NMS screen can immediately tell that the objects
are from the capwapBase-MIB and know that the data refers to capwap
management. cwb and CWB-MIB, or cwBase and cwBase-MIB are much less
meaniingful to anybody except the editors. So I recommend
capwapBaseMIB and, per 4181, capwapBase should then be the prefix, or
just capwapMIB and a capwap prefix..

These recent proposals for changes are purely editorial and not
technical, but they would make any previous implementstion
non-compatible. This means anybody who has already tried implementing
this MIB would have to go rewrite their implementation, and there
would be no technical benefit to expending the programming resources
to do this rewrite. Let's concentrate on resolving any remaining
technical problems so the MIB can be submitted for advancement, rather
than worrying about names. The WG already reached consensus on the
names and the IANA registration; they do not need to be changed.

dbh

> -----Original Message-----
> From: Yong Zhang [mailto:[email-masked]] 
> Sent: Friday, September 26, 2008 5:05 AM
> To: young
> Cc: [email-masked]; Chris Elliott; Harrington David
> Subject: Re: [Capwap] Which one is preferred between 
> capwapBase and cwb
>

---

From: young <[email-masked]>
Date: Fri, 26 Sep 2008 17:35:41 +0800

Hi, if there is no other advice, we will use capwapBase as prefix.

Regards
Richard

-----邮件原件-----
发件人: David Harrington [mailto:[email-masked]] 
发送时间: 2008年9月26日 15:33
收件人: 'Yong Zhang'; 'young'
抄送: [email-masked]; 'Chris Elliott'; 'Harrington David'
主题: RE: [Capwap] Which one is preferred between capwapBase and cwb

Hi,

dbh