Subject: Re: [Capwap] Capwap Digest, Vol 34, Issue 3

From: "Yong Zhang" <[email-masked]>
Date: Fri, 5 Sep 2008 09:27:12 -0700

Pat,

In the <new text>,  the definition for Vendor Identifier is missing.

Yong

On Fri, Sep 5, 2008 at 3:16 AM,  <[email-masked]> wrote:
> Send Capwap mailing list submissions to
>        [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>        http://lists.frascone.com/mailman/listinfo/capwap
> or, via email, send a message with subject or body 'help' to
>        [email-masked]
>
> You can reach the person managing the list at
>        [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Capwap digest..."
>
>
> Today's Topics:
>
>   1. Data Length invalid in Image Identifier (Pat Calhoun (pacalhou))
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 4 Sep 2008 13:31:26 -0700
> From: "Pat Calhoun (pacalhou)" <[email-masked]>
> Subject: [Capwap] Data Length invalid in Image Identifier
> To: <[email-masked]>
> Cc: [email-masked]
> Message-ID:
>        <[email-masked]>
> Content-Type: text/plain;       charset="us-ascii"
>
> I have forwarded this e-mail to the list on behalf of Glenn.
>
> Hi Glenn,
>
> I have created issue 176 to track this one. You are correct, the Data
> Length field shouldn't have been referenced, as it is not in the actual
> figure. The new text reads:
>
> <new text>
> 4.6.26.  Image Identifier
> [...]
>
>      0                   1                   2                   3
>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |                       Vendor Identifier                       |
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |                             Data...
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>   Type:   25 for Image Identifier
>
>   Length:   >= 5
>
>   Data:   A variable length UTF-8 encoded string [RFC3629] containing
>      the firmware identifier to be run on the WTP, whose length MUST
>      NOT exceed 1024 octets.  The length of this field is inferred from
>      this message element's length field.
> </new text>
>
> PatC
>
>
> ------------------------------------------------------------------------
> --------
>
> From: Glenn Chagnot [mailto:[email-masked]]
> Sent: Tuesday, September 02, 2008 6:29 PM
> To: [email-masked]'
> Subject: Image Identifier Potential Issue
>
> Hi Pat,
>
> As I have been working my way through the CAPWAP Protocol Base -11
> draft, I found the encoding information for the Image Identifier a bit
> confusing.  In addition to Pasi's earlier feedback that the length
> should be >= 5, I also found the description of Data Length confusing.
> The line that confuses me states:
>
> "Data Length:   Length of data field, with a maximum size of 65535.
>
> In the description for the Data field, the statement is made:
>
> "The length of this field is inferred from this message element's length
> field."
>
> It seems to me that the Data Length line does not belong in this
> description at all, particularly since it is not shown in the message
> element diagram.  In other words, I think the message element should
> contain:
>
> Type                        2 octets
> Length                      2 octets
> Vendor ID                   4 octets
> Data                        1-1024 octets
>
>  If it does belong in the description, then the diagram probably should
> be updated and a description an update to the text is in order to
> clarify its usage further.
>
> Thanks!
>
> Glenn
>
>
> ------------------------------
>
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>
> End of Capwap Digest, Vol 34, Issue 3
> *************************************
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 5 Sep 2008 09:36:57 -0700

Oh, great. I copy/paste'd too early :(

Here is the text I meant to send:

<new text>
      0                   1                   2                   3

   Length:   >= 5

   Vendor Identifier:   A 32-bit value containing the IANA assigned "SMI
      Network Management Private Enterprise Codes"

PatC
-----Original Message-----
From: Yong Zhang [mailto:[email-masked]] 
Sent: Friday, September 05, 2008 9:27 AM
To: Pat Calhoun (pacalhou)
Cc: [email-masked]
Subject: Re: Capwap Digest, Vol 34, Issue 3

Pat,

Yong

> Length field shouldn't have been referenced, as it is not in the 
> actual figure. The new text reads:
>
> <new text>
> 4.6.26.  Image Identifier
> [...]
>
>      0                   1                   2                   3
> --

> "The length of this field is inferred from this message element's 
> length field."
>
>  If it does belong in the description, then the diagram probably 
> should be updated and a description an update to the text is in order 
> to clarify its usage further.
>
> Thanks!
>
> Glenn
>
>