Subject: [Capwap] Issue 207: Need clarity on AC behind NAT

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 24 Sep 2008 18:08:01 -0700

All,

The following was raised during the IESG review.

> Section 11., paragraph 2:
> >    In the second case, two or more WTPs are deployed behind the same
NAT
> >    system.  Here, the AC would receive multiple connection requests
from
> >    the same IP address, and cannot differentiate the originating WTP
of
> >    the connection requests.
> 
>   The UDP source ports will be different for the two connection
>   requests, which could be used to distinguish them.

Yes, but that wasn't what the text was trying to get to. However, given
your comment, it is clear we need to clarity the point that is being
made. I would therefore propose changing the second sentence to:

<updated text>
11.  NAT Considerations
[...]
   In the second case, two or more WTPs are deployed behind the same NAT
   system. Here, the AC would receive multiple connection requests from
the
   same IP address, and therefore cannot use the WTP's IP address alone
to
   bind the CAPWAP control and data channel. The CAPWAP Data Check
state,
   which establishes the data plane connection and communicates the
CAPWAP
   Data Channel Keepalive, includes the Session Identifier message
element,
   which is used to bind the control and data plane. Use of the Session
   Identifier message element enables the AC to match the control and
data
   plane flows from multiple WTPs behind the same NAT system (multiple
WTPs
   sharing the same IP address).
</updated text>

PatC
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 24 Sep 2008 18:09:23 -0700

Sorry, title should have read WTP behind NAT 

-----Original Message-----
From: Pat Calhoun (pacalhou) 
Sent: Wednesday, September 24, 2008 6:08 PM
To: [email-masked]
Subject: [Capwap] Issue 207: Need clarity on AC behind NAT

All,

NAT
from
of

<updated text>
11.  NAT Considerations
[...]

PatC