Subject: [Cbor] Tag for binary UUID?

From: "Lundblade, Laurence" <[email-masked]>
Date: Sun, 27 Nov 2016 03:08:47 +0000

UUIDs (RFC 4122) have a base binary representation in 16 bytes and a much longer URN-oriented string representation. Seems like a type 6 tag would be a good thing to label a UUID, especially the binary one, so that converters to JSON know to do the string expansion.  Does that seem right?

LL

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Nov 2016 06:11:16 +0100

> UUIDs (RFC 4122) have a base binary representation in 16 bytes and a much longer URN-oriented string representation. Seems like a type 6 tag would be a good thing to label a UUID, especially the bi…

Indeed.  One of the nice things about CBOR tags as an extension mechanism is that anyone can extend CBOR by just registering a tag.  A tag for binary UUIDs (37) has been registered a while ago:

https://www.iana.org/assignments/cbor-tags/cbor-tags.xhtml

Spec is in:
https://github.com/lucas-clemente/cbor-specs/blob/master/uuid.md

Grüße, Carsten