Subject: [Cbor] Stephen Farrell's No Objection on charter-ietf-cbor-00-01: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 01 Dec 2016 06:30:06 -0800

Stephen Farrell has entered the following ballot position for
charter-ietf-cbor-00-01: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-cbor/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Were this being proposed for approval, I would be balloting
a BLOCK so I'd like to understand the issue below before
we get there, if at all possible.

- What is GRASP? 

- As I think of it, COSE did not really adopt CBOR, but
is an ancillary part of CBOR. For example, it would be
impossible for COSE to be COSE and choose something
that is not CBOR:-) So there was no "adoption" step
ever, for COSE.

- COSE did not "successfully" use CDDL IMO. The CDDL
text there is specifically stated to be non-normative, and 
its inclusion was controversial during the WG process.

The above seems to me to mean that the level of 
interest claimed for CBOR/CDDL is not justified by the 
charter text. 

And the reason that raises to a possible BLOCK
ballot for me is that such enthusiasm, while understandable,
doesn't seem to go well with the last part of the charter.
"Where these proposals are deemed useful" just seems
too likely to happen if I'm to judge by the overly 
positive "spin" in the current charter language. (Note
that "spin" isn't meant pejoratively there, it's quite
fine that the proponents of this are proponents of 
this:-)

I think the solution here is to provide more evidence
of the claimed level of interest in CBOR/CDDL That could be 
done in the charter text but may be fine if only done in 
the email discussion leading up to that. And toning down
the language would help too. (Note that fixing errata
in CBOR isn't a problem but by itself wouldn't justify
a WG.)

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 01 Dec 2016 15:00:47 +0000

Stephen,

> its inclusion was controversial during the WG process.

This can be reworded.

> in CBOR isn't a problem but by itself wouldn't justify

There are multiple documents in CORE that are using CDDL, so I am sure
there is some interest in at least that.

I am happy to tone this down.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 2 Dec 2016 09:07:06 +0100

Hi Stephen,

Alexey has already said that the charter can be reworded.
But I’ll try to answer your comment as best as I can, in three parts.

# CBOR adoption

> - What is GRASP? 

The Generic Autonomic Signaling Protocol (draft-ietf-anima-grasp), nearing WGLC in the ANIMA WG.

> that is not CBOR:-) So there was no "adoption" step

Well, creating a new WG to exploit the capabilities of a base standard by creating another standard on top of it is a form of “adoption” of the base standard in my dictionary.  
But I’m not a native English speaker.

# CDDL “success"

> - COSE did not "successfully" use CDDL IMO.

COSE very successfully used CDDL as a tool to communicate about the COSE data structures during development.  In large parts, the (normative) English language spec text we still need right now was then developed from the CDDL.

> The CDDL
> text there is specifically stated to be non-normative,

Of course: to avoid a downref to an I-D.

> and 

That’s not what happened.

There was a discussion how to make use of CDDL in COSE while CDDL itself is still a draft.
Solved as said above.

There was an individual in the WG who does not see any benefit to using CDDL.
(That individual does not even see a benefit to using ABNF, either.  Different people work in different ways, so I don’t blame him for this view at all, but a lot of people do derive benefits from both ABNF and CDDL.)

We then had a discussion whether we should keep the CDDL specs in the main text (as opposed to moving it to an appendix).  This discussion even had a chairs’ call for consensus.  That call resoundingly validated keeping the CDDL in the main text, with a single person in the rough.

“Controversial” is not the word I would use for that level of consensus, but then again I’m not a native English speaker.

# Specs for additional CBOR Tags

> fine that the proponents of this are proponents of 

The fact that CDDL is actually useful (and is increasingly being used in other SDOs as well, unfortunately at this time shrouded by their confidential modes of operation) does not mean that these CBOR Tag specs are useful.  I do have some doubts even about some of the parts of the CBOR Tag specs I’m a co-author on, and I’m sure the WG will be good to determine what parts to keep.

So yes, the charter language should be clear that this is not an open invitation for doing more of these additional CBOR Tag specifications.  Alexey’s approach (wait for completion [or WG decision not to do them!] for the first two specs we have on the table now) sounds right to me.

Grüße, Carsten

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 02 Dec 2016 14:27:22 +0000

I am looking at
<https://datatracker.ietf.org/doc/draft-greevenbosch-appsawg-cbor-cddl/referencedby/>
this is a rather impressive list of drafts referencing CDDL.

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 2 Dec 2016 14:37:19 +0000

> this is a rather impressive list of drafts referencing CDDL.

Yep. Agreed. Just a matter of tweaking the text then
which is easier.

TBH though, I still do have some concerns about the
relative lack of author diversity in that set of
drafts. But it is diverse enough I guess. Just.

Note that that's nothing personal, I remember other
times the IETF went down wrong but seemingly reasonable
paths that looked similar from that respect. (BEEP
anyone?;-)

Thanks,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 3 Dec 2016 08:19:33 +1300

Hi Stephen,

On 03/12/2016 03:37, Stephen Farrell wrote:>
> paths that looked similar from that respect. (BEEP

I'm not sure that's comparable. BEEP* failed, but CBOR is quite a
success, and CDDL is a useful tool for CBOR-using protocol design.
We *could* have written the various Anima drafts without CDDL, but
it would have needed a lot of extra words to reach the same level of
precision. We *could* wordsmith the drafts to get rid of the normative
references, but it would be artificial.

In my GRASP prototype, I didn't attempt to develop a CDDL-driven
parser or message generator, but I assume that would be possible too.

*(Wasn't BEEP a noble attempt to do better than SOAP?)

Regards,
     Brian