Subject: [Cbor] If not CCDL then ... ?

From: "Matthew A. Miller" <[email-masked]>
Date: Thu, 30 Mar 2017 16:19:59 -0500

As mentioned in the face-to-face meeting, the WG might want to consider
a different name before adopting draft-greevenbosch-appsawg-cbor-cddl.

I offer a number of suggestions:

* Language Describing CBOR Data
* CBOR Description Format
* CBOR Data Description Format

I tried a couple of quick searches across Bing/DuckDuckGo/Google/Yahoo,
and none of the results -- to me -- seemed ripe for confusion by the
users of CBOR.

-- 
- m&m

Matthew A. Miller

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Mar 2017 16:39:40 -0500

> * CBOR Data Description Format

s/Format/Form/?

That would at least echo (A)BNF, and it at least alliterates with CDDL.

(I’d still rather cuddle.)

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Mar 2017 10:54:13 +1300

If the name is the only issue we're in good shape.

Personally I'm fine with CDDL. Clashing with the name of a license is really not an issue IMHO.

    Brian

On 31/03/2017 10:39, Carsten Bormann wrote:
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 31 Mar 2017 06:05:09 -0500

> Personally I'm fine with CDDL. Clashing with the name of a license is really not an issue IMHO.

Off-list, it has been pointed out to me that, since CDDL is not just for CBOR, maybe that should be reflected in the name.

So here is my entry in the contest:

Concise Data Definition Language (CDDL).

Grüße, Carsten

(Why “concise”?  One answer may be here:
https://www.iab.org/wp-content/IAB-uploads/2016/03/Noise-in-specifications-hurts.pdf
)

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 1 Apr 2017 01:11:02 +1300

> Concise Data Definition Language (CDDL).

To be concise, +1

   Brian