Subject: [Cbor] Agenda for tomorrow

From: Jim Schaad <[email-masked]>
Date: Tue, 7 Aug 2018 10:00:41 -0700

Is there an agenda for the call tomorrow?

Jim

---

From: Barry Leiba <[email-masked]>
Date: Tue, 7 Aug 2018 13:52:27 -0400

> Is there an agenda for the call tomorrow?

The agenda for all the call is to check the work status, work out
whatever issues/impediments there are, and keep the work progressing.

For this first call, the main thing on the table is that Carsten
promised a CDDL document update by the end of July, which we don't
seem to have yet, so we'll be discussing that -- is there something we
need to do in order to keep CDDL moving?  Perhaps get an alternative
active editor who can keep progress going if Carsten is too busy.

Barry

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 7 Aug 2018 23:54:25 +0200

If we have time, we could also look at the current draft:

https://cbor-wg.github.io/cddl/

https://cbor-wg.github.io/cddl/draft-ietf-cbor-cddl.html

https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-cbor-cddl.txt&url2=https://cbor-wg.github.io/cddl/draft-ietf-cbor-cddl.txt

(We could have submitted that state as a -04, but I’d assume further fixes are likely to be made right after the Interim.  In particular:)

The solution for the .ne/.eq question is somewhat novel, let’s see if we can live with that.
(We tried to keep as many of the current specifications valid as possible, but that means that .ne/.eq is a bit of a .)

I also went ahead and made h’f000’ and b64’BAA’ case-insensitive, so they can be written as H’f000’ and B64’BAA’ — a result of some side-track we had on this list.  This makes all of the surface syntax of CDDL case-insensitive (the rule names, of course, stay case-sensitive).

Grüße, Carsten

> On Aug 7, 2018, at 19:52, Barry Leiba <[email-masked]> wrote:
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>