Subject: [Cbor] Ambiguous CDDL statement

From: Jim Schaad <[email-masked]>
Date: Wed, 22 Aug 2018 07:16:20 -0700

Using the grammar as defined today, the following statement is not well
defined

a = ( uint )

It is not clear if 'a' is a type or a group.

rule - typename assignt type
type - type1
type1 - type2
type2 - "(" type ")"

or

rule - groupname assign grpent
grpent - "(" group ")"
group - grpchoice
grpchoice - grpent
grpent - type

jim

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 22 Aug 2018 18:13:47 +0200

Hi Jim,

thanks for this comment and for the good discussion we had in the interim meeting.

https://github.com/cbor-wg/cddl/commit/d9512e has the text I’m proposing to add to -05 to address this.

Grüße, Carsten

> On Aug 22, 2018, at 16:16, Jim Schaad <[email-masked]> wrote:
> 
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>