Subject: [Cbor] Minutes from 3rd webex call

From: Francesca Palombini <[email-masked]>
Date: Wed, 19 Sep 2018 15:56:45 +0000

Hi all,

I took some notes from today's meeting, they are now also uploaded on the datatracker, together with the past ones: https://datatracker.ietf.org/group/cbor/meetings/
To the participants, please let me know if anything was not captured correctly.

Thanks,
Francesca

--
CBOR WG Conference Call
Wednesday, Sept 19 2018, 15:00 - 16:00 UTC
Chairs: Barry Leiba, Francesca Palombini

Minute takers: Francesca

Participants:
* Carsten Bormann
* Michael Richardson
* Laurence Lundblade
* Sean
* Jim Schaad
* Henk Birkholz
* Francesca

Carsten presenting updates to documents:

CDDL in Alexey's hands. Will start with open PR on CBORBis, then let's talk some more about CDDL.

CBOR bis pull requests:
    * #32
- Laurence: proposal sounds reasonable
- Carsten: will make a change to reduce the text. Let's do 28 first and then we can go back to 32 and fix it.
    * #28
- will go not to the next update because we need an update right now (draft expired), but for the next one (October 1, after Carsten's vacation)
   * #27
- will go in this week
   * #24
- proposal: fix text for tag 35 but not try to do stronger version
- Michael: makes total sense.
   * #19
-  tried to understand this, but needs details from Jeffrey. Waiting for his eply, but will probably get in the version uploaded in october
   * #17
- will partly integrate this this week. Needs more input from the wg if we want to distinguish between "illformed" and "fatally illformed"
- Laurence: dont want to distinguish between those two. Bad idea to "allow" some form of ill-formed.
- Carsten: Jeffrey want to underline that broken is broken

CDDL: received several comments (although in IESG review):

* Representation variants: some parts are not in CBOR (but are in CBORbis)... might need to add some text.
* Map matching is not very well defined.
* .cborseq
* additional editorial comments (other comments go to another version)

Francesca: will send an email to Alexey notifying we are improving on editorial (and his review can be done in parallel)

AOB:
- Carsten: A while ago the array tag got stuck. Resolution: going to change into 2 bytes then working group adoption.
- Francesca: Yes, the document already had agreement to be adopted, it was confirmed in the ml as well, it was just waiting on your update
- Carsten: Ok, let's get it adopted this week

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 20 Sep 2018 23:17:21 +0200

On 19. Sep 2018, at 17:56, Francesca Palombini <[email-masked]> wrote:
> open PR on CBORBis

I just submitted draft-ietf-cbor-7049bis-03.txt — I didn’t quite get as far as I wanted, but that’s how far I got.
More in the first week of October.  Would be glad for a few cross-checks of the changes:

https://tools.ietf.org/rfcdiff?url2=draft-ietf-cbor-7049bis-03.txt

If I cherry-picked from your pull request, my one-week vacation would also be a good time to resolve the conflicts.

Grüße, Carsten