Subject: [Cbor] Ben Campbell's No Objection on draft-ietf-cbor-cddl-06: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Tue, 20 Nov 2018 12:18:06 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-cbor-cddl-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cbor-cddl/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Most of my comments have already been captured by others, save one:

Is there a specific reason the normative appendices are not part of the main
body? I think a lot of RFC readers assume that appendices are optional to read.
We should not surprise them without reason.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 20 Nov 2018 21:33:23 +0100

Hi Ben,

> https://datatracker.ietf.org/doc/draft-ietf-cbor-cddl/

The original reason is that none of the authors is part of the tradition that you can ignore appendices.
(To the contrary, I’m used to documents where *all* the meat is in the appendices; this is almost the normal state in the world of FDT.)
The reason we didn’t reshuffle things when we heard that this appears to be a widespread concept in the minds of IETFers is that there are so many documents that refer to specific appendices of the draft, so we didn’t want to disturb all those references.

If you think this is a big enough problem that disturbing all these references is worth fixing it, we can reshuffle.

Grüße, Carsten

---

From: Ben Campbell <[email-masked]>
Date: Tue, 20 Nov 2018 15:35:54 -0600

> On Nov 20, 2018, at 2:33 PM, Carsten Bormann <[email-masked]> wrote:
> 
> Hi Ben,
> 

No, I don’t think it is that big of a problem.

Thanks!

Ben.